[PPT97] Microsoft PowerPoint プレゼンテーションのメタデータを最小限にする方法

文書翻訳 文書翻訳
文書番号: 223793 - 対象製品
この記事は、以前は次の ID で公開されていました: JP223793
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
Microsoft PowerPoint 2002 については、次の資料を参照してください。
314800 [PPT2000] Microsoft PowerPoint プレゼンテーションのメタデータを最小限にする方法
Microsoft PowerPoint 2000 については、次の資料を参照してください。
314797 [PPT2000] Microsoft PowerPoint プレゼンテーションのメタデータを最小限にする方法
すべて展開する | すべて折りたたむ

目次

概要

この資料では、PowerPoint プレゼンテーションに含まれるメタデータの量を最小限に抑えるためのさまざまな方法について説明します。

PowerPoint でプレゼンテーションのを作成したり、開いたり、保存したりする場合、そのプレゼンテーションを電子的に配布したときに第三者に見られては困る内容がプレゼンテーションに含まれる可能性があります。この情報は "メタデータ" と呼ばれます。メタデータは、Office 文書の編集や表示、保存、検索を強化するために、さまざまな目的で使用されます。

メタデータには、PowerPoint のユーザー インターフェイスから簡単にアクセスできるものもありますが、低レベルのバイナリ ファイル エディタでプレゼンテーションを開くなど、特殊な方法を使用しなければアクセスできないものもあります。以下に、プレゼンテーションに格納されるメタデータの例をいくつか示します。
  • ユーザー名
  • 頭文字
  • 会社名と組織名
  • コンピュータ名
  • プレゼンテーションを保存したネットワーク サーバーまたはハード ディスクの名前
  • その他のプロパティと概要情報
  • 埋め込み OLE オブジェクトの非表示部分
  • テンプレートの情報
  • コメント

詳細

PowerPoint プレゼンテーション内でメタデータが作成される方法は、それぞれ異なります。このため、これらのメタデータを一括してプレゼンテーションから取り除く方法はありません。ここでは、メタデータが PowerPoint プレゼンテーション内に格納される領域について説明します。

Microsoft Office 97 SR-2 を入手していない場合

Microsoft Office 97 Service Release 2 (以下 SR-2) を使用していない場合、SR-2 を入手してインストールする必要があります。SR-2 をダウンロードする (または SR-2 の CD-ROM を入手する) には、以下のマイクロソフト Web サイトを参照してください。
http://office.microsoft.com/japan/downloads/9798/ofsr2aof97.aspx

プログラムからユーザー名を削除する方法

現在のユーザー名を参照または変更するには、次の手順を実行します
  1. [ツール] メニューの [オプション] をクリックします。[全般] タブをクリックすると、[名前] ボックスと [頭文字] ボックスが表示されます。
  2. これらの情報がプレゼンテーションに表示されないようにするには、自分を特定されない文字列かスペースを該当するボックスに入力し、[OK] をクリックして変更内容を確定します。
新規に作成するプレゼンテーションには、Office を最初にインストールしたときに入力したデフォルト値ではなく、すべてこの情報が含まれます。ただし、既存のプレゼンテーションには、既にインストール時に入力した情報が含まれている可能性があります。

個人の概要情報を削除する方法

PowerPoint でプレゼンテーションを作成または保存すると、概要情報がプレゼンテーションに保存される可能性があります。この情報にアクセスするために使用できる方法は複数あります。
  • プレゼンテーションを開き、[ファイル] メニューの [プロパティ] をクリックします。[ファイルの概要]、[詳細情報]、[ファイルの構成]、および [ユーザー設定] タブにはすべて、ユーザー名、管理者の名前、会社名など、さまざまなプロパティが含まれている可能性があります。
  • Windows エクスプローラでプレゼンテーションを右クリックし、ショートカット メニューの [プロパティ] をクリックします。[プロパティ] ダイアログ ボックス内の各タブにこれらの情報が含まれている可能性があります。
  • Visual Basic マクロやその他のプログラム コードを使用して、[プロパティ] ダイアログ ボックスに表示されるプロパティを読み取ることができます。
既存のプレゼンテーションから概要情報を削除するには、以下の手順を実行します。
  1. プレゼンテーションを開きます。
  2. [ファイル] メニューの [プロパティ] をクリックします。
  3. [ファイルの概要] タブで、[作成者]、[管理者]、[会社名]、および配布したくない情報が入力されているその他のボックスの内容をすべて削除します。
  4. [ユーザー設定] タブで、配布したくない情報が入力されているプロパティをすべて削除します。
  5. 以上の手順が完了した後、[OK] をクリックし、[ファイル] メニューの [上書き保存] をクリックします。
  6. [ファイル] メニューの [閉じる] をクリックします。
上の手順が完了したプレゼンテーションには、概要プロパティは含まれません。

ネットワークに接続したときの個人の概要情報を削除する方法

ネットワークにログオンしている場合、プレゼンテーションを保存すると、[ファイルの概要] タブの [作成者] ボックス、および [詳細情報] タブの [更新者] フィールドにネットワーク ユーザー名が表示されることがあります。その他の個人情報をコンピュータからすべて削除しても、この処理は行われる可能性があります。

ネットワークを利用しているときに、プレゼンテーションから概要情報を削除するには、以下の手順を実行します。
  1. プレゼンテーションがネットワーク サーバーに保管されている場合は、そのプレゼンテーションをローカルのハード ディスクにコピーします。
  2. コンピュータを再起動します。ただし、ネットワークにはログオンしないようにします。ネットワークのログオン ダイアログ ボックスが表示されたら、[キャンセル] をクリックするか Esc キーを押します。

    注意: Esc キーを押して Windows を起動できない場合 (Windows NT/2000/XP を実行している場合など) は、この手順を続行することはできません。
  3. プレゼンテーションを開きます。
  4. [ファイル] メニューの [プロパティ] をクリックします。
  5. [ファイルの概要] タブで、[作成者]、[管理者]、[会社名]、および配布したくない情報が入力されているその他のボックスの内容をすべて削除します。
  6. [ユーザー設定] タブで、配布したくない情報が入力されているプロパティをすべて削除します。
  7. 以上の手順が完了した後、[OK] をクリックし、[ファイル] メニューの [上書き保存] をクリックします。
  8. [ファイル] メニューの [閉じる] をクリックします。
ネットワークにログオンしている状態でファイルを開かないでください。ファイルを開くと、ネットワーク ユーザー名がファイルに書き込まれる可能性があります。ただし、エクスプローラを使用して、ファイルをネットワーク サーバーまたはフロッピー ディスクにコピーすることはできます。

プレゼンテーション内のコメントを削除する方法

PowerPoint には、プレゼンテーションにコメントを挿入する機能があります。通常、コメントには作成者の名前が付加され、書き込んだユーザー名がわかるようになっています。

PowerPoint では、コメントを選択して Del キーを押すか、または [チェック/コメント] ツール バーの [コメントの削除] をクリックすることによってコメントを削除できます。

注意: PowerPoint でコメントを表示するには、[表示] メニューの [コメント] をクリックします。

上記の手順によって [オプション] ダイアログ ボックスからユーザー名を削除すると、以後新しく作成したコメントにはユーザー名が含まれません。

プレゼンテーションからヘッダーとフッターを削除する方法

プレゼンテーションのヘッダーとフッターには、識別情報が含まれていることがあります。ヘッダーとフッターから情報を削除するには、[表示] メニューの [ヘッダーとフッター] をクリックし、必要に応じてヘッダーやフッターを変更します。変更が完了したら、[適用] または [すべてに適用] をクリックします。

PowerPoint で高速保存をオフにする方法

PowerPoint には、Microsoft Word と同様の高速保存機能があります。PowerPoint で高速保存をオフにするには、以下の手順を実行します。
  1. [ツール] メニューの [オプション] をクリックします。
  2. [保存] タブをクリックします。
  3. [高速保存] チェック ボックスを オフ にして、[OK] をクリックします。

プレゼンテーションからハイパーリンクを削除する方法

プレゼンテーションには、他のドキュメントまたはイントラネットやインターネット上の Web ページへのハイパーリンクが含まれていることがあります。ハイパーリンクは通常、青い下線付きのテキスト文字列として表示されます。

ハイパーリンクを右クリックし、ショートカット メニューの [ハイパーリンク] をポイントして、[ハイパーリンクの削除] をクリックすることにより、プレゼンテーションから単一のハイパーリンクを手動で削除することができます。

Visual Basic マクロを使用することにより、プレゼンテーションに含まれるすべてのハイパーリンクを削除することができます。このようなマクロの作成方法については、以下のサポート技術情報を参照してください。
156353 XL97: No Menu Choice to Select All Hyperlinks

プレゼンテーションから回覧先情報を削除する方法

回覧先を使用して、プレゼンテーションを電子メールによって送信する場合、回覧情報がプレゼンテーションに添付される可能性があります。この情報をプレゼンテーションから削除するには、回覧先情報が保持されない形式でプレゼンテーションを保存する必要があります。

これを行うには、次の手順を実行します。
  1. 上記の手順を使用して高速保存をオフにします。
  2. [ファイル] メニューの [送信] をポイントし、[ほかの回覧先] をクリックします。
  3. [クリア] をクリックして回覧先を削除してから、[追加] をクリックします。
  4. [ファイル] メニューの [上書き保存] をクリックします。
これにより、回覧先情報が何も含まれない状態でプレゼンテーションが保存されます。

Visual Basic のコードからユーザー名を削除する方法

PowerPoint で Visual Basic のマクロを記録する場合、記録されたマクロは、次のようなヘッダーで始まります。

' マクロ記録日: 02/3/11 ユーザー名: <ユーザー名>


記録したすべてのマクロから自分のユーザー名を削除するには、以下の手順を実行します。
  1. マクロが含まれているプレゼンテーションを開きます。
  2. [ツール] メニューの [マクロ] をポイントして [Visual Basic Editor] をクリックします (または Alt + F11 キーを押します)。
  3. プロジェクト ウィンドウで、対象となるマクロが含まれているモジュールをダブルクリックします。
  4. 記録されているマクロ コードからユーザー名を削除します。
ユーザー名の削除が完了したら、Alt + Q キーを押してアプリケーションに戻ります。[ファイル] メニューの [上書き保存] をクリックします。

他のファイルに対する Visual Basic の参照設定を削除する方法

Visual Basic Editor では、他のファイルへの参照を作成することが可能です。他のファイルへの参照が含まれているプレゼンテーションを開くと、参照先ファイルの名前が表示されます。

これらの参照を削除するには、以下の手順を実行します。
  1. 参照が含まれるプレゼンテーションを開きます。
  2. [ツール] メニューの [マクロ] をポイントして [Visual Basic Editor] をクリックします (または Alt + F11 キーを押します)。
  3. [ツール] メニューの [参照設定] をクリックします。
  4. 参照されているファイルの横にあるチェック ボックスを オフ にします。完了したら、[OK] をクリックします。
  5. Alt + Q キーを押します。
  6. [ファイル] メニューの [上書き保存] をクリックします。
注意 : 他のファイルへの参照を削除すると、プレゼンテーション内のマクロの機能が損なわれ、正常に動作しなくなる可能性があります。

プレゼンテーションからネットワークやハード ディスクの情報を削除する方法

プレゼンテーションをローカル ハード ディスクまたはネットワーク サーバー上に保存すると、ローカル ハード ディスクやネットワーク サーバーを識別する情報がプレゼンテーションに書き込まれる可能性があります。

プレゼンテーションからこの情報を削除するには、以下の手順を実行します。
  1. プレゼンテーションを開きます。
  2. [ファイル] メニューの [名前を付けて保存] をクリックし、プレゼンテーションをフロッピー ディスク ドライブ (通常は A:) に保存します。
  3. [ファイル] メニューの [閉じる] をクリックします。
  4. フロッピー ディスク ドライブからフロッピー ディスクを取り出します。
これにより、エクスプローラを使用して、フロッピー ディスクから任意のハード ディスクまたはネットワーク サーバーにプレゼンテーション ファイルをコピーすることができます。

注意 : フロッピー ディスクの容量の制限 (通常 1.44 MB まで) のため、プレゼンテーション ファイルのサイズがフロッピー ディスクの空き容量を超えている場合、この方法は使用できません。

プレゼンテーション内の埋め込みオブジェクトにメタデータが含まれることがある

プレゼンテーション内にオブジェクトを埋め込んだ場合、プレゼンテーションにどのような操作を行っても、そのオブジェクト内の独自のプロパティが保持されます。たとえば、Microsoft Word 文書を PowerPoint 内に埋め込んだ場合、文書とプレゼンテーションはそれぞれ独自のプロパティを持ちます。

オブジェクトをアクティブにし、上記の方法でメタデータを削除して、コンテナ ドキュメント (上の例では PowerPoint プレゼンテーション) を再びアクティブにした後でコンテナ ドキュメントを保存することにより、埋め込みオブジェクトからメタデータを削除することができます。

注意 : プレゼンテーションの埋め込みオブジェクトをアクティブにする場合、埋め込みオブジェクトの一部のみがプレゼンテーションに表示されます。オブジェクトには、表示されないその他の情報が含まれている可能性があります。埋め込みオブジェクトの実際の内容ではなく、表示されている部分のみがプレゼンテーションに含まれるようにするには、オブジェクトを切り取ってから、[編集] メニューの [形式を指定して貼り付け] を使用して、オブジェクトを図 (拡張メタファイル) 形式でプレゼンテーションに貼り付けます。この処理を実行すると、埋め込みオブジェクトの編集はできなくなりますが、メタデータは完全に含まれなくなります。

Office ドキュメントから一意の識別子を削除する方法

Microsoft Office 97 に含まれるプログラムの仕様上、Microsoft Office 97 で作成および保存されたドキュメントには一意の識別子が含まれています。これらの一意の識別子の詳細および削除方法については、以下のサポート技術情報を参照してください。
222180 OFF97: Unique Identifiers and Microsoft Office 97 Documents

セキュリティに関する一般的な注意点

使用しているコンピュータ環境でセキュリティのレベルを高めるための一般的な注意点について記載します。
  • コンピュータのそばから離れるときは、パスワードで保護されたスクリーン セーバー、システム起動時のパスワード、または Windows NT のロック機能を必ず使用してコンピュータを保護してください。
  • 使用しているコンピュータに共有フォルダがある場合は、必ずパスワードを適用して、権限のあるユーザーだけが共有にアクセスできるようにします。より高いセキュリティを実現するためには、ユーザー レベルのアクセス管理を使用し、コンピュータの共有にアクセスできるユーザーを厳密に制御します。
  • ファイルを削除した後で、すぐにごみ箱を空にします。ファイルを削除するときに、自動的に完全消去または上書きを行うユーティリティの使用を検討することもできます。
  • バックアップしたデータは、金庫または鍵付きのキャビネットなどの安全な場所に保管します。
  • 重要な文書はパスワードで保護し、権限のあるユーザー以外は開くことができないようにします。パスワードは、安全な別の場所に保管する必要があります。パスワードを忘れた場合、パスワード保護された文書の内容を取り出す方法はないため、注意が必要です。
  • 電子的な形態で文書を配布しないようにし、代わりに印刷します。独自のフォント、透かし、ロゴ、または特殊な用紙など、相手から自分が特定されるような要素は、(プレゼンテーションなどで) 必要な場合を除いて、使用しないようにします。
  • 電子メールは匿名では処理されません。何らかの方法で文書に自分の識別情報が添付されることを懸念する場合は、文書を電子メールで送信しないでください。
  • HTTP または FTP プロトコルを使用して、インターネット上でドキュメントを送信しないでください。これらのプロトコルを使用して送信される情報は、"クリア テキスト" で送信されます。これは、その内容を盗み見ることが (考えにくいことですが) 技術的に不可能ではないことを意味します。

関連情報

参考資料

この資料に記載した内容の関連情報については、以下のサポート技術情報を参照してください。
223396 [OFF] Microsoft Office ドキュメント内のメタデータを最小限に抑える方法
223789 [XL2002] Microsoft Excel ブックのメタデータを最小限にする方法
223790 [WD97] Microsoft Word 文書のメタデータを最小限にする方法
222180 OFF97: Unique Identifiers and Microsoft Office 97 Documents


この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 223793 (最終更新日 2001-05-26) をもとに作成したものです。

プロパティ

文書番号: 223793 - 最終更新日: 2014年2月9日 - リビジョン: 2.2
この資料は以下の製品について記述したものです。
  • Microsoft PowerPoint 97 Standard Edition
キーワード:?
kbnosurvey kbarchive kbdownload kbdta kbfaq kbinfo kbui ppt8 ppt97 メタ情報 個人情報 KB223793
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com