PPT97: How to Minimize Metadata in Microsoft PowerPoint Presentations

Article translations Article translations
Article ID: 223793 - View products that this article applies to.
This article was previously published under Q223793
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

Summary

When you create, open, or save a presentation in Microsoft PowerPoint 97, the presentation may contain content that you may not want to share with others when you distribute the presentation electronically. This information is known as "metadata". Metadata is used for a variety of purposes to enhance the editing, viewing, filing, and retrieval of Office documents.

Some metadata is readily accessible through PowerPoint's user interface; other metadata is only accessible through other means, such as opening a presentation in a low-level binary file editor. Here are some examples of metadata that may be stored in your presentations:
  • Your name
  • Your initials
  • Your company or organization name
  • The name of your computer
  • The name of the network server or hard disk where you saved the presentation
  • Other file properties and summary information
  • Non-visible portions of embedded OLE objects
  • Template information
  • Comments
This article explains various methods that you can use to minimize the amount of metadata that is contained within your PowerPoint presentations.

More information

Metadata is created in a variety of ways within PowerPoint presentations. As a result, there is no single method that you can use to eliminate all such content from your presentations. The following sections describe areas where metadata may be saved within PowerPoint presentations.

If You Do Not Already Have Microsoft Office 97 SR-2

If you are not already using it, you should obtain and install Microsoft Office 97 Service Release 2 (SR-2). To download SR-2, or to order an SR-2 CD, visit the following Microsoft Web site:
Office 97 Service Release 2b (SR-2b) Download Information

How to Remove Your User Name from Your Programs

To view or change your user name, follow these steps:
  1. On the Tools menu, click Options. Click the General tab. You will see the Name and Initials edit boxes.
  2. If you do not want any of this information to appear in your presentations, type non-identifying information or spaces in the appropriate edit box(es), and then click OK to accept the changes.
Any new presentations that you create will now contain this new information, rather than the default values you typed when you first installed Office. However, existing presentations may already contain this information.

How to Remove Personal Summary Information

When you create or save a presentation in Microsoft PowerPoint, summary information may be saved within the presentation. There are several methods you can use to access this information:
  • Open the presentation. On the File menu, click Properties. The Summary, Statistics, Contents, and Custom tabs may all contain various properties, such as your name, your manager's name, and your company name.
  • In the Windows Explorer, right-click your presentation, and click Properties on the shortcut menu. The tabs within the Properties dialog box may contain information.
  • It is possible to use a Visual Basic macro or other program code to read the properties shown in the Properties dialog box.
To clear summary information from an existing presentation, follow these steps:
  1. Open the presentation.
  2. On the File menu, click Properties.
  3. In the Summary tab, clear the Author, Manager, Company, and any other edit boxes that you do not want to distribute.
  4. In the Custom tab, delete any properties that contain information you do not want to distribute.
  5. When you are finished, click OK. On the File menu, click Save.
  6. On the File menu, click Close.
Once you have completed these steps, the presentation should not contain summary properties.

Removing Personal Summary Information when Connected to a Network

If you are logged onto a network, your network user name (for example, JDoe) may appear in the Author edit box in the Summary tab, and in the Last saved by field in the Statistics tab, when you save a presentation. This can occur even if you have removed all other personal information from your computer.

To remove summary information from a presentation when you are on a network:
  1. If the presentation is stored on a network server, copy it to your local hard disk.
  2. Start your computer, but do NOT log on to your network. When you see the network logon dialog box, click Cancel or press ESC.

    NOTE: If you are unable to start Windows by pressing ESC (for example, your computer is running Windows NT), you cannot continue these steps.
  3. Open the presentation.
  4. On the File menu, click Properties.
  5. In the Summary tab, clear the Author, Manager, Company, and any other edit boxes that contain information you do not wish to distribute.
  6. In the Custom tab, delete any properties that contain information that you do not wish to distribute.
  7. When you are finished, click OK. On the File menu, click Save.
  8. On the File menu, click Close.
When you log on to the network, DO NOT OPEN THE FILE. If you do, your network user name may be written into the file. However, you can use the Windows Explorer to copy the file to either a network server or a floppy disk.

How to Remove Comments within Presentations

Microsoft PowerPoint offers the ability to add comments to presentations. Typically, comments contain the name of the person who created them, so that you can tell who wrote them.

In Microsoft PowerPoint, you can remove a comment by selecting the comment and either pressing the DELETE key or clicking the Delete Comment tool on the Reviewing toolbar.

NOTE: To view comments in Microsoft PowerPoint, click Comments on the View menu.

Any new comments that you create should not contain your user name, since you have removed it from your Options dialog box, as shown above.

How to Remove Headers and Footers from Presentations

Headers and footers in presentations may contain identifying information. To remove information from headers and footers, click Header And Footer on the View menu. Change the header and/or footer as desired. When you are done, click Apply or Apply To All.

How to Disable FastSave in Microsoft PowerPoint

Microsoft PowerPoint includes a FastSave feature similar to that included in Microsoft Word. To disable FastSave in Microsoft PowerPoint, follow these steps:
  1. On the Tools menu, click Options.
  2. Click the Save tab.
  3. Click to clear the Allow Fast Saves check box. Click OK.

How to Remove Hyperlinks from Presentations

Presentations may contain hyperlinks to other documents or web pages on either an intranet or the Internet. Hyperlinks usually appear as blue underlined text strings.

You can manually delete a single hyperlink from a presentation by right-clicking the hyperlink, pointing to Hyperlink on the shortcut menu, and clicking Remove Hyperlink.

If you want to delete all hyperlinks in a presentation, you can use a Visual Basic macro to do this. For information on how to write such a macro, please see the following article in the Microsoft Knowledge Base:
156353 XL97: No Menu Choice to Select All Hyperlinks

How to Remove Routing Slip Information from a Presentation

If you send a presentation through e-mail using a routing slip, routing information may be attached to the presentation. To remove this information from the presentation, you must save the presentation in a format that does not retain routing slip information.

To do this, follow these steps:
  1. Turn off FastSave using the previous instructions.
  2. On the File menu, point to Send To, and click Other Routing Recipient.
  3. Click Clear to remove the routing slip. Then, click Add Slip.
  4. On the File menu, click Save.
The presentation is now saved without any routing slip information.

How to Remove Your Name from Visual Basic Code

When you record a Visual Basic macro in Microsoft PowerPoint, the recorded macro begins with a header similar to the following:
' Macro1 Macro
' Macro recorded 3/11/1999 by J. Doe
To remove your name from any macros that you have recorded, follow these steps:
  1. Open the presentation that contains the macros.
  2. On the Tools menu, point to Macro, and click Visual Basic Editor. Or, press ALT + F11.
  3. In the project window, double-click the module that contains the macros.
  4. Remove your name from the recorded macro code.
When you are done removing your name, press ALT + Q to return to the program. Then, click Save on the File menu.

How to Remove Visual Basic References to Other Files

In the Visual Basic Editor, it is possible to create a reference to another file. If a user opens a presentation that contains references to other files, they will be able to see the names of the referenced files.

To remove these references:
  1. Open the presentation that contains references.
  2. On the Tools menu, point to Macro, and click Visual Basic Editor. Or, press ALT + F11.
  3. On the Tools menu, click References.
  4. Click to clear he check box next to the referenced file(s). When you are done, click OK.
  5. Press ALT + Q.
  6. On the File menu, click Save.
NOTE: Removing references to other files may impair the ability of macros in your presentation from functioning correctly.

How to Remove Network or Hard Disk Information from a Presentation

When you save a presentation to either your local hard disk or to a network server, information that identifies the local hard disk or network server may be written into the presentation.

To remove this information from the presentation, follow these steps:
  1. Open the presentation.
  2. On the File menu, click Save As. Save the presentation to your floppy disk drive (usually, A:).
  3. On the File menu, click Close.
  4. Remove the floppy disk from your floppy disk drive.
You can now use the Windows Explorer to copy the presentation file from the floppy disk to any hard disk or network server.

NOTE: Due to the space limitation of a floppy disk (usually 1.44 MB), this method cannot be used if the presentation file size exceeds the amount of free space on the floppy disk.

Embedded Objects within Presentations may Contain Metadata

If you embed an object within a presentation, the object still retains its own properties, regardless of what you do to the presentation. For example, if you embed a Microsoft Word document within a Microsoft PowerPoint presentation, the document and the presentation each have their own properties.

You can remove metadata from an embedded object by activating the object, removing any metadata as previously described, reactivating the container document (using the previous example, this would be the PowerPoint presentation), and then saving the container document.

NOTE: When you activate an embedded object in a presentation, only part of the embedded object is displayed within the presentation; the object may contain additional information that does not appear. If you want a presentation to contain only a rendering of the embedded object, and not the actual contents, cut the object and then use the Paste Special menu item on the Edit menu to paste the object into the presentation using a Metafile format. Once you do this, you will no longer be able to edit the embedded object; however, it will not contain any metadata.

How to Remove Unique Identifiers from Office Documents

Because of the design of the programs included in Microsoft Office 97, documents that are created or saved in Office 97 programs may contain a unique identifier. For more information about these identifiers and how to remove them, please see the following article in the Microsoft Knowledge Base:
222180 OFF97: Unique Identifiers and Microsoft Office 97 Documents

General Suggestions Concerning Security

Here are some general suggestions that you can use to increase the level of security in your computing environment:
  • Whenever you are not at your computer, secure it with a password-protected screen saver, power-on password, or the Windows NT lock feature.
  • If your computer has any shared folders, make sure you apply passwords to them so that only authorized users can access your shares. For even better security, use user-level access control so that you can control exactly who can access your computer's shares.
  • When you delete a file, empty the Recycle Bin immediately. You may want to consider a utility that complete erases or overwrites files when they are deleted.
  • When you back up your data, store the backup files in a secure location, such as a safe, a security deposit box, or a locked cabinet. Store one copy of your backups at a secure off-site location in case your primary location is unusable.
  • Important documents should be password-protected, to ensure that only authorized users can open them. Your passwords should be stored in a secure, separate location. Note that if you cannot recall a password, there is no way to recover the contents of a password-protected document.
  • Do not distribute documents in electronic form. Instead, print them out. Do not use identifying elements such as distinctive fonts, watermarks, logos, or special paper, unless necessary (for example, for a presentation).
  • E-mail is NOT anonymous. Do not e-mail a document if you are concerned about your identity being attached in any way to the document.
  • Do not send a document over the Internet using either HTTP or FTP protocols. Information sent across these protocols is sent in "clear text", which means that it's technically possible (however unlikely)for it to be intercepted.

For More Information

For more information related to the topics previously discussed, please see the following articles in the Microsoft Knowledge Base:
223396 OFF97: How to Minimize Metadata in Office Documents
223789 XL97: How to Minimize Metadata in Excel Workbooks
223790 WD97: How to Minimize Metadata in Word Documents
222180 OFF97: Unique Identifiers and Microsoft Office 97 Documents

Properties

Article ID: 223793 - Last Review: November 2, 2013 - Revision: 4.0
Applies to
  • Microsoft PowerPoint 97 Standard Edition
Keywords: 
kbnosurvey kbarchive kbdownload kbhowto kbui KB223793

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com