You receive a "The disk is full or too many files are open" error message when you save a document in Word 2000

Article translations Article translations
Article ID: 224041 - View products that this article applies to.
This article was previously published under Q224041
For a Microsoft Word 97 version of this article, see 137918.
For a Microsoft Word 95 version of this article, see 186957.
For a Microsoft Word 98 version of this article, see 255598.
Expand all | Collapse all

On This Page

Symptoms

When you save a document, you may receive an error message similar to the following if you run Word under Microsoft Windows 95 or later:
The disk is full or too many files are open. (C:\WINWORD\DOC1.DOC)
A similar error message may appear when Word performs an AutoSave operation:
The disk is full or too many files are open. (C:\WINWORD\~WRANNNN.ASD)
Also, when you try to run ScanDisk on Windows 95 or later, the following error message may appear:
ScanDisk cannot check the drive as it is not properly formatted or a utility has locked it, format the hard disk or wait for the utility to finish and re-run ScanDisk.
NOTE: Microsoft Office 2000 has built-in functionality that allows you to get more information about difficult-to-troubleshoot alerts or error messages. If you want to enable this functionality for this and other error messages in Microsoft Office 2000, please download the Microsoft Office 2000 Customizable Alerts file from the Microsoft Office Update Web site at the following address:
http://www.microsoft.com/downloads/details.aspx?FamilyID=8FBEE1D3-C5BB-4A36-A2F7-DC63DE2A818C
NOTE: If you reached this article by clicking the Web Info button in an error message, you already have Customizable Alerts enabled.

Resolution


The document contains corrupt or invalid links.

This problem is known to occur with Microsoft Equation Editor objects. However, this problem can also occur with corrupt or invalid links of other object types.

Equation Editor, a special version of the MathType equation editor from Design Science, Inc., is customized for use with Microsoft applications. For more information about MathType, browse to the following MathType Web site:
http://www.dessci.com
Using Equation Editor, you can build complex equations by picking symbols from a toolbar and typing variables and numbers. As you build an equation, Equation Editor automatically adjusts font sizes, spacing, and formatting in keeping with mathematical typesetting conventions. You can also adjust formatting as you work and redefine the automatic styles.
Use one of the following methods to work around this problem:

Method 1: Save Your Word Document as Rich Text Format

  1. On the File menu, click Save As.
  2. In the Save As dialog box, change the Save as type box to Rich Text Format.

    NOTE: You may also want to change the File name box to a new name for your document to prevent accidentally overwriting your original document.
  3. Click Save.
  4. On the File menu, click Close.
  5. On the File menu, click Open and open the Rich Text Format file that you saved in steps 1 through 3.

    NOTE: In the Open dialog box, you may need to change the Files of type box to Rich Text Format before you can see your new file. If the Convert File dialog box appears, make sure that Rich Text Format (RTF) is selected, and then click OK.
  6. After the Rich Text Format document is open, click Save As on the File menu, and resave your new document as a Word Document with a new file name.

    NOTE: It is recommended that you not save your new Word document back to the original file name. Instead, save your new Word document by using a new file name. If the problem with the document is corrected, you can delete the problem document (the original Word document) and rename your new Word document to the original files name later.
Method 2: Save Your Word Document as a Web Archive

You can save your Word document as a Web Archive. For information about the Web Archive Add-on and how to use it, please see the following article in the Microsoft Knowledge Base:

252472 WD2000: Microsoft Office 2000 Web Archive Add-on Available
Method 3: Test for Invalid Object Links

To test for invalid object links in your Word document, you must update the fields in Word. To do this, follow these steps:
  1. On the Edit menu, click Select All.
  2. Press F9.
Word should display the following message on the status bar when it is updating fields:
Word is updating the fields in the document
If an error message appears at this point, one or more of the fields may be invalid and may show a message similar to the following in place of the equation object:
Error! Object cannot be created from editing field codes.
It may be possible to unlink the problem equation field, or it may be necessary to delete the equation object and recreate it. In either case, do the following steps:
  1. On the Edit menu, click Undo Update Fields.
  2. Do one of the following:
    • Click the problem equation object. Then press CTRL+SHIFT+F9 to unlink the equation object. After the object is unlinked, you cannot edit the object in Equation Editor. However, you may be able to save your Word document.

      -or-
    • Delete and recreate the equation object. For more information, please see Method 4 later in this article.
Repeat these steps for each problem equation object in your Word document.

Method 4: Paste the Problem Object as a Picture

You may be able to identify a problem equation object in your Word document.

NOTE: Using this method causes your equation object to become a picture, and you cannot edit the equation object in Equation Editor. However, you may be able to save your Word document. If you need to edit the equation object, you must recreate it. For more information, please see Method 4 later in this article.
  1. Click the problem equation object.
  2. On the Edit menu, click Cut.
  3. Make sure that the insertion point is located where you want the equation object to appear, and then click Paste Special on the Edit menu.
  4. In the Paste Special dialog box, click Picture, and then click OK.
Method 5: Recreate the Microsoft Equation Object

Delete the problem equation object, and then recreate it in Microsoft Equation Editor 3.0.

For more information about how to create a new equation object, click Microsoft Word Help on the Help menu, type insert equation in the Office Assistant or the Answer Wizard, and then click Search to view the topics returned.



You are running the Bgmail.exe utility.

Bgmail.exe is a tool that is installed on AT&T computers to provide access to AT&T proprietary mail services.

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
134456 Err Msg: ScanDisk Cannot Check This Drive Now Because the...
Bgmail.exe prevents Windows tools from locking the hard disk properly. Note that Bgmail.exe is loaded from either the Winstart.bat file or the Autoexec.bat file.

If you are running the Bgmail utility, edit the Winstart.bat file or the Autoexec.bat file, and place a semicolon (;) at the beginning of the Bgmail.exe line to temporarily turn it off. Save and close the file, and then restart Windows and run ScanDisk.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Properties

Article ID: 224041 - Last Review: August 16, 2012 - Revision: 3.0
Applies to
  • Microsoft Word 2000
Keywords: 
kbprb kbtshoot kbopenfile kberrmsg kbsavefile kbinfo KB224041

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com