You receive a "Word was unable to open the data source" error message when you attach a data source to your mail-merge main document in Word 2000

Article translations Article translations
Article ID: 224056 - View products that this article applies to.
This article was previously published under Q224056
For a Microsoft Word 97 version of this article, see 115171.
Expand all | Collapse all

On This Page

Symptoms

When you try to attach a data source to your mail-merge main document, you may receive the following error message:
Word was unable to open the data source.
You may also receive the following error message:
External table isn't in the expected format.

Field1|Field2|Field3|Field4|Field5 isn't a valid name.

Syntax error in FROM clause.
When you close the mail-merge main document, you may receive the following error message:
Microsoft Word: Word cannot open the document.
Try one or more of the following
* On the File menu, click open to open the document
* Make sure the document has a .Doc extension
(Outlook Address Book)
NOTE: Microsoft Office 2000 has built-in functionality that allows you to get more information about difficult-to-troubleshoot alerts or error messages. If you want to enable this functionality for this and other error messages in Microsoft Office 2000, please download the Microsoft Office 2000 Customizable Alerts file from the Microsoft Office Update Web site at the following address:
http://www.microsoft.com/downloads/details.aspx?FamilyID=8FBEE1D3-C5BB-4A36-A2F7-DC63DE2A818C
NOTE: If you reached this article by clicking the Web Info button in an error message, you already have Customizable Alerts enabled.

Things to Try

The data source text file is open on a different computer.

Close the data source text file on the other system, and then restart your mail merge in Word.




The ODBC Text driver installed by Microsoft Office for Windows does not support the delimiter that you used to separate text in your data source text file.

Some known delimiters that the ODBC Text driver does not support are:
  • Tab Delimited
  • Tilde (~) Delimited
  • Pipe Delimited
To work around this problem, use one of the following methods.

Method 1: Rename the extension of your tab-delimited text file to an "unrecognized" extension. For example, if your tab-delimited text file is named Address.txt, rename the file to Address.too.

Method 2: Use a comma-delimited text file as your data source, instead of a tab-delimited data source.




You are using MSQuery to generate a data source for a Word mail merge, and your query string exceeds 255 characters.

To resolve this problem, obtain Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a).

To obtain SR-1/SR-1a, click the article number below to view the article in the Microsoft Knowledge Base:
245025 OFF2000: How to Obtain and Install the Microsoft Office 2000 SR-1/SR-1a Update
To temporarily work around this problem, use one of the following methods.

Method 1: Shorten the search string. For example, shorten the path to the data source, shorten the file name, or select fewer columns of data when you define your query.

Method 2: Connect to the data source by using dynamic data exchange (DDE) instead of MSQuery.




You selected Outlook Express as your default e-mail program and simple MAPI client.

Do not set Outlook Express as the default simple MAPI client. Outlook Express was designed for use with Microsoft Internet Explorer 4.x. Although you can use Outlook Express to send e-mail from Word, the Outlook Express Address Book is not designed for use with Word.

NOTE: To send e-mail from Word, point to Send To on the File menu, and then click Mail recipient.

To clear the Make Outlook Express my default Simple MAPI client check box, follow these steps:
  1. In Outlook Express, on the Tools menu, click Options.
  2. On the General tab, click to clear the Make Outlook Express my default Simple MAPI client check box.
NOTE: The Make Outlook Express my default Simple MAPI client check box is not available unless the Make Outlook Express my default e-mail program check box is selected.

You may need to restart your computer, or reinstall Microsoft Office or Outlook after you clear the Make Outlook Express my default Simple MAPI client check box. After you restart your computer or reinstall Office or Outlook, your previous address book should again function correctly with Word.




You are using the Microsoft Outlook Address Book, and you may have an Outlook Personal Distribution List that contains a Global Distribution List and one or more single members.

To work around this problem, you can set your Exchange Services Keep personal addresses in setting to Personal Address Book.
  1. In Outlook, on the Tools menu, click Services.
  2. On the Addressing tab in the Keep personal addresses in list box, click to select Personal Address Book.
To view your personal distribution list in Outlook 2000, follow these steps:
  1. In Outlook 2000, click the Contacts folder.
  2. In your list of contacts, find your personal distribution list.
  3. Double-click the personal distribution list to view the contents.



You have more than 128 address books.

To resolve this problem, obtain Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a).

To obtain SR-1/SR-1a, click the article number below to view the article in the Microsoft Knowledge Base:
245025 OFF2000: How to Obtain and Install the Microsoft Office 2000 SR-1/SR-1a Update



Your Outlook Address Book contains no contacts.

Before you can use the Microsoft Outlook Address Book as a data source in a Word mail merge, you must type a contact in the Address Book. To do this, follow these steps:
  1. Start Microsoft Outlook.
  2. On the Tools menu, click Services. On the Services tab, make sure Outlook Address Book is in the profile list. If Outlook Address Book is not in the list, click Add and add Outlook Address Book.For additional information if your contact information does not appear correctly, click the article number below to view the article in the Microsoft Knowledge Base:
    197907 OL2000: (CW) Contact Information Does Not Appear in Address Book
  3. On the Outlook Bar, which is on the left, click Contacts. If the Outlook Bar is not visible, click Outlook Bar on the View menu.
  4. On the File menu, click New, and then click Contact.
  5. Type the information for the new contact entry.
  6. On the Contact toolbar, click Save and Close.
  7. On the Outlook Bar, right-click Contacts. Click Properties on the shortcut menu, and then click the Outlook Address Book tab.
  8. Click to select the Show this folder as an e-mail Address Book check box, and then click OK.



Your Access database file requires a password to open.

When you use ODBC, you do not receive a dialog box that allows you to type the password, because the password that is needed to open your SQL data source is not passed through Microsoft Access to the SQL Server.

When you insert the link table in the Microsoft Access database, select the Save password check box in the Link Tables dialog box.

For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:
101084 ACC: Storing SQL Database Login IDs and Passwords Locally
101375 ACC: How to Query SQL Server Tables Without Linking/Attaching



The option to hide file extensions is selected (turned on) in Windows.

Use one of the following methods to work around this problem.

Method 1: Use the Select Method Option

  1. Open the Open Data Source dialog box using one of the following methods:
    • On the Database toolbar (on the View menu, click Toolbars, and then click Database), click Insert Database.

      -or-
    • In the Mail Merge Helper (on the Tools menu, click Mail Merge), click Get Data, and then click Open Data Source.
  2. Select the database file that you want to use, click to select the Select Method check box, and then click OK.
  3. In the Confirm Data Source dialog box, click Text Files, and then click OK.

    NOTE: There is a Text Files via ODBC (*.txt, *.csv) entry if the ODBC text converter is installed. Do not select this option.

Method 2: Turn Off the Option to Hide File Extensions

  1. Right-click the Windows Start button.
  2. On the shortcut menu, click Explore.
  3. In Windows Explorer, on the View menu, click Folder Options.
  4. Click the View tab.
  5. Click to clear the Hide extensions for known file types check box, and then click OK.
  6. Close Windows Explorer.



The data source text file is already opened by the same text converter.

For example, if you have an open mail-merge main document that is attached to a text file data source, and then you attempt to start another mail-merge main document (without closing the first one), and try to attach the same text file data source, you receive an error message.

To work around this problem, close the other mail-merge main document, and then restart your mail merge in Microsoft Word.

Properties

Article ID: 224056 - Last Review: August 16, 2012 - Revision: 2.0
Applies to
  • Microsoft Word 2000
Keywords: 
kbopenfile kbformat kberrmsg kbmerge kbemail kbtshoot kbdta kbprb wd2000 KB224056

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com