Servidor de ping de clientes DCOM después el programa cliente se apaga

Seleccione idioma Seleccione idioma
Id. de artículo: 224837 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Síntomas

Después de ejecutar un cliente de modelo de objetos componentes (COM) distribuidas sin autenticar que utiliza la API de COM CoSetProxBlanket para establecer seguridad en su interfaz remota y llamadas el objeto de servidor remoto, distribuido (COM) ping puede conservar incluso aunque el programa de cliente ha publicado la interfaz y apagar.

Causa

Esta revisión es una actualización para la revisión descrita en el siguiente artículo:
184278Servidor en un dominio puede desconectar el cliente en otro dominio
Esta revisión corrige el caso donde un cliente no seguro activa de forma segura especificando las credenciales en la estructura COAUTHINFO con que pasa a CoCreateInstanceEx. El cliente puede ofrecer a continuación, llamadas seguras utilizando CoSetProxyBlanket o simplemente puede hacer que las llamadas no seguras. Anterior a la solución, el objeto de servidor se limpiará en aproximadamente seis minutos por el proceso COM. Además, anteriores a la solución, el equipo cliente continuará enviar DCOM ping al servidor indefinidamente, incluso después de haber salido el proceso de cliente y servidor. La revisión resuelve ambos estos problema.

Solución

Windows NT Server 4.0 o Windows NT Workstation 4.0

Para resolver este problema, obtenga el último Service Pack para Windows NT 4.0 o la actualización de software correspondiente. Para obtener información acerca de cómo conseguir el último Service Pack, vaya a:
Para obtener información acerca de cómo obtener la actualización de software correspondiente, póngase en contacto con el Servicio de soporte técnico de Microsoft. Para ver una lista detallada de los números de teléfono de los Servicios de soporte técnico de Microsoft así como información de costos de soporte, visite la siguiente dirección Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Windows NT Server 4.0, Terminal Server Edition

Para resolver este problema, obtenga el service pack más reciente para Windows NT Server 4.0 Terminal Server. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
152734Cómo obtener el Service Pack más reciente de Windows NT 4.0

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo. Este problema se corrigió por primera vez en Windows NT Server 4.0, Terminal Server Edition Service Pack 6.

Propiedades

Id. de artículo: 224837 - Última revisión: viernes, 24 de enero de 2014 - Versión: 2.5
La información de este artículo se refiere a:
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kbhotfixserver kbqfe kbbug kbfix kbqfe KB224837 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 224837

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com