Máquina virtual Hyper-V no se inicia y recibe un "'General error de acceso denegado' (0 x 80070005)" mensaje de error

Seleccione idioma Seleccione idioma
Id. de artículo: 2249906 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Una máquina virtual Hyper-V puede no iniciarse y recibe un mensaje de error similar al siguiente:

Se ha producido un error al intentar iniciar las máquinas virtuales seleccionados.

'VMName' no se pudo iniciar.

Microsoft emulado controladora IDE (ID de instancia
{83F8638B-8DCA-4152-9EDA-2CA8B33039B4}): error al poder en ' General
error de acceso denegado '

IDE/ATAPI cuenta no tiene privilegios suficientes para abrir datos adjuntos
' E:\VMs\VMName\Disk0.vhd. Error: 'General error de acceso denegado'

Cuenta no tiene privilegios suficientes para abrir datos adjuntos
' E:\VMs\VMName\Disk0.vhd. Error: 'General error de acceso denegado'

Si hace clic en Ver detalles en la ventana del mensaje, se muestra la siguiente información:

'VMName' no se pudo iniciar. (ID de máquina Virtual
5FC5C385-BD98-451F-B3F3-1E50E06EE663)

'VMName' Microsoft emulado controladora IDE (ID de instancia
{83F8638B-8DCA-4152-9EDA-2CA8B33039B4}): error al poder en ' General
error de acceso denegado ' (0 x 80070005). (ID de máquina Virtual
5FC5C385-BD98-451F-B3F3-1E50E06EE663)

'VMName': IDE/ATAPI cuenta no tiene privilegios suficientes para abrir datos adjuntos
' E:\VMs\VMName\Disk0.vhd. Error: 'el acceso General denegado error' (0 x 80070005). (Virtual
5FC5C385-BD98-451F-B3F3-1E50E06EE663 de ID de máquina)

'VMName': cuenta no tiene privilegios suficientes para abrir datos adjuntos
' E:\VMs\VMName\Disk0.vhd. Error: 'el acceso General denegado error' (0 x 80070005). (Virtual
5FC5C385-BD98-451F-B3F3-1E50E06EE663 de ID de máquina)

Notas
  • Este mensaje de error hace referencia a la controladora IDE emulado de Microsoft o el controlador SCSI sintéticos de Microsoft.
  • Este mensaje de error hace referencia a un archivo de disco duro virtual (.vhd) o un archivo de instantáneas (.avhd).
  • El ID de máquina Virtual es único para cada máquina virtual.

Causa

Este problema se produce si los permisos en el archivo de disco duro virtual (.vhd) o el archivo de instantáneas (.avhd) son incorrectos.

Todas las máquinas virtuales Hyper-V tiene un ID de máquina Virtual único (SID). Si el SID de la máquina Virtual de los permisos de seguridad en el archivo .vhd o .avhd, la máquina virtual no se inicia y recibe el "'General error de acceso denegado' (0 x 80070005)" mensaje de error que se menciona en la sección "Síntomas".

Solución

Para resolver este problema, agregue al SID de la máquina Virtual para el archivo de disco duro virtual (.vhd) o para el archivo de instantáneas (.avhd).

Para agregar al SID de la máquina Virtual a un archivo .vhd o .avhd, siga estos pasos:
  1. Tenga en cuenta el ID de máquina Virtual que aparece en el "'General error de acceso denegado' (0 x 80070005)" mensaje de error.

    Por ejemplo, considere el siguiente mensaje de error:

    'VMName': IDE/ATAPI cuenta no tiene privilegios suficientes para abrir datos adjuntos
    ' E:\VMs\VMName\Disk0.vhd. Error: 'el acceso General denegado error' (0 x 80070005). (Virtual
    5FC5C385-BD98-451F-B3F3-1E50E06EE663 de ID de máquina)

    En este ejemplo, el ID de máquina Virtual es 5FC5C385-BD98-451F-B3F3-1E50E06EE663.
  2. Abra un símbolo del sistema con privilegios elevados.
  3. Para otorgar el acceso de ID de máquina Virtual (SID) para el archivo .vhd o .avhd, escriba el comando siguiente y, a continuación, presione ENTRAR:
    icacls <Path of .vhd or .avhd file> /grant "NT VIRTUAL MACHINE\<Virtual Machine ID from step 1>":(F)
    Por ejemplo, para utilizar el ID de máquina Virtual que anotó en el paso 1, escriba el comando siguiente y, a continuación, presione ENTRAR:
    icacls "E:\VMs\VMName\Disk0.vhd" /grant "NT VIRTUAL MACHINE\5FC5C385-BD98-451F-B3F3-1E50E06EE663":(F)
  4. Iniciar la máquina virtual.

Más información

Si no son correctos los permisos en el archivo de configuración de máquina virtual Hyper-V (archivo .xml), la máquina virtual no se inicia y devuelve el mensaje de error siguiente:

No se pudo inicializar 'VM sin nombre'.

Error al leer o actualizar la configuración de máquina virtual porque se denegó el acceso.

Si hace clic en Ver detalles en la ventana del mensaje, se muestra el mensaje de error siguiente:

No se pudo inicializar 'VM sin nombre'. (7E77503A-A26B-4BB5-9846-396F49A30141 de la máquina Virtual)

'Sin nombre VM' no se pudo leer o actualizar la configuración de máquina virtual porque se denegó el acceso: acceso General denegado error (0 x 80070005). Compruebe la configuración de seguridad de la carpeta donde se almacena la máquina virtual. (7E77503A-A26B-4BB5-9846-396F49A30141 de la máquina Virtual)

Para resolver este problema, realice los pasos en la sección "Solución" para agregar al SID de la máquina Virtual al archivo .xml. Por ejemplo, ejecute el comando siguiente:

icacls "E:\VMs\VMName\7E77503A-A26B-4BB5-9846-396F49A30141.xml" /grant "NT VIRTUAL MACHINE\7E77503A-A26B-4BB5-9846-396F49A30141":(F)

Referencias

Para obtener más información acerca de Hyper-V, consulte el siguiente sitio Web de Microsoft TechNet:
Hyper-V

Propiedades

Id. de artículo: 2249906 - Última revisión: miércoles, 26 de junio de 2013 - Versión: 5.0
La información de este artículo se refiere a:
  • Microsoft Hyper-V Server 2008
  • Microsoft Hyper-V Server 2008 R2
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Palabras clave: 
kbhyperv kbmt KB2249906 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2249906

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com