Identificativo articolo: 2258121 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di installare gli aggiornamenti per le applicazioni Microsoft Office tramite Windows Update o Microsoft Update, viene visualizzato uno dei seguenti codici di errore.

Errore 1
0x80070646

Errore 2
646

Errore 3
"Errore 1606 Impossibile accedere al percorso di rete %APPDATA%"

Cause

Questo problema si verifica a causa di un errore di Windows Installer. Il codice di errore 0x80070646 e il codice di errore 646 sono generati da Windows Installer. Questi errori generici indicano che Windows Installer ha riscontrato un problema. Quando si riscontrano gli errori descritti nella sezione "Sintomi", il problema può essere causato da un valore non corretto nel Registro di sistema.

Risoluzione

Per aggiornare automaticamente le relative chiavi del Registro di sistema, fare clic sul pulsante nella sezione "Correzione automatica". Per verificare e aggiornare autonomamente queste chiavi, andare alla sezione "Correzione manuale".


Correzione automatica


Correggi problema
Microsoft Fix it 50461

Nota Questa procedura guidata è disponibile solo in lingua inglese. Tuttavia la correzione automatica funziona anche per versioni di Windows in altre lingue.

Nota Se non si sta utilizzando il computer che presenta questo problema, è possibile salvare la soluzione automatica su un'unità flash o su un CD ed eseguirla successivamente sul computer in questione.


Correzione manuale

Per risolvere questo problema, verificare il valore della chiave AppData nel Registro di sistema. Per effettuare questa operazione, attenersi alla procedura che si applica al sistema operativo in uso:


Per utenti di Windows Vista e Windows 7
  1. Fare clic su Start, quindi nella casella Avvia ricerca digitare regedit.
  2. Nell'elenco Programmi fare clic con il pulsante destro su Regedit.exe, quindi scegliere Esegui come amministratore. Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Continua.
  3. Individuare e selezionare la seguente sottochiave del Registro di sistema:

    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
  4. Nel riquadro dei dettagli dell'editor del Registro di sistema, individuare AppData. Il valore di questa chiave deve essere %USERPROFILE%\AppData\Roaming.
  5. Se il valore non è impostato su %USERPROFILE%\AppData\Roaming, fare clic con il pulsante destro del mouse su AppData nel riquadro dei dettagli e quindi scegliere Modifica.
  6. Digitare %USERPROFILE%\AppData\Roaming nella casella Dati valore, quindi fare clic su OK.
  7. Chiudere l'editor del Registro di sistema.
  8. Provare a installare nuovamente l'aggiornamento. Se il problema persiste, ripetere questa procedura, utilizzando le seguenti sottochiavi del Registro di sistema anziché della sottochiave specificata al punto 3:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
Per utenti di Windows XP
  1. Fare clic sul pulsante Start, quindi scegliere Esegui.
  2. Nella casella Apri , digitare regedit, quindi scegliere OK.
  3. Nell'elenco Programmi, fare clic su Regedit.exe. Se viene chiesto di immettere la password di amministratore o di confermare, digitare la password o fare clic su Continua.
  4. Individuare e selezionare la seguente sottochiave del Registro di sistema:

    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
  5. Nel riquadro dei dettagli dell'editor del Registro di sistema, individuare AppData. Il valore di questa chiave deve essere %USERPROFILE%\Application Data.
  6. Se il valore non è impostato su %USERPROFILE%\Application Data, fare clic con il pulsante destro su AppData nel riquadro dei pannelli e quindi scegliere Modifica
  7. Nella casella Dati valore , digitare %USERPROFILE%\Application Data, quindi fare clic su OK.
  8. Chiudere l'editor del Registro di sistema.
  9. Provare a installare nuovamente l'aggiornamento. Se il problema persiste, ripetere questa procedura utilizzando le seguenti sottochiavi del Registro di sistema anziché la sottochiave specificata al punto 4:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Proprietà

Identificativo articolo: 2258121 - Ultima modifica: sabato 14 maggio 2011 - Revisione: 4.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Update
Chiavi: 
kbfixme kbmsifixme KB2258121
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com