Artikel ID: 2258121
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Wanneer u via Windows Update of Microsoft Update updates probeert te installeren voor toepassingen van Microsoft Office, kan een van de volgende foutcodes worden weergegeven.

Fout 1
0x80070646

Fout 2
646

Fout 3
Fout 1606. Kan geen toegang tot de netwerklocatie %APPDATA% krijgen.

Oorzaak

Dit probleem doet zich voor wanneer in Windows Installer een fout optreedt. De foutcodes 0x80070646 en 646 worden gegenereerd door Windows Installer. Deze algemene fouten geven aan dat in Windows Installer een probleem is opgetreden. Wanneer de fouten optreden die in de sectie 'Symptomen' worden beschreven, wordt het probleem mogelijk veroorzaakt door een onjuiste waarde in het register.

Oplossing

Als u de betreffende registersleutels automatisch wilt bijwerken, klikt u op de knop in de sectie Het probleem voor mij oplossen. Als u deze sleutels liever zelf wilt controleren en bijwerken, gaat u naar de sectie Dit probleem zelf oplossen.


Het probleem voor mij oplossen


Dit probleem oplossen
Microsoft Fix it 50461

Opmerking Deze wizard is mogelijk alleen beschikbaar in het Engels. De automatische correctie werkt echter ook voor andere taalversies van Windows.

Opmerking Als u op dit moment niet op de computer werkt waarop het probleem optreedt, kunt u de automatische correctie opslaan op een flashstation of een cd, zodat u de correctie later op de betreffende computer kunt uitvoeren.


Dit probleem zelf oplossen

Als u dit probleem wilt oplossen, controleert u de waarde van de sleutel AppData in het register. Hiertoe volgt u de stappen in de procedure die op uw besturingssysteem van toepassing is:


Voor gebruikers van Windows 7 en Windows Vista
  1. Klik op Start en typ vervolgens regedit in het vak Zoekopdracht starten.
  2. Klik in de lijst met Programma's met de rechtermuisknop op Regedit.exe en klik vervolgens op Als administrator uitvoeren. Als u naar een beheerderswachtwoord of om een bevestiging wordt gevraagd, typt u het wachtwoord of klikt u op Doorgaan.
  3. Zoek de volgende registersubsleutel en klik op deze sleutel:

    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
  4. Zoek AppData in het detailvenster van de Register-editor. De waarde van deze sleutel moet %USERPROFILE%\AppData\Roaming zijn.
  5. Als de waarde niet is ingesteld op %USERPROFILE%\AppData\Roaming, klikt u met de rechtermuisknop op AppData in het detailvenster en klikt u vervolgens op Wijzigen.
  6. Geef %USERPROFILE%\AppData\Roaming op in het vak Waardegegevens en klik vervolgens op OK.
  7. Sluit de Register-editor.
  8. Probeer de update opnieuw te installeren. Als het probleem zich blijft voordoen, herhaalt u deze stappen, maar gebruikt u de volgende registersubsleutels in plaats van de subsleutel die is opgegeven in stap 3:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
Voor gebruikers van Windows XP
  1. Klik op Start en vervolgens op Uitvoeren.
  2. Typ regedit in het vak Openen en klik op OK.
  3. Typ Regedit.exe in het vak Programma's. Als u naar een beheerderswachtwoord of om een bevestiging wordt gevraagd, typt u het wachtwoord of klikt u op Doorgaan.
  4. Zoek de volgende registersubsleutel en klik op deze sleutel:

    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
  5. Zoek AppData in het detailvenster van de Register-editor. De waarde van deze sleutel moet %USERPROFILE%\Application Data zijn.
  6. Als de waarde niet is ingesteld op %USERPROFILE%\Application Data, klikt u met de rechtermuisknop op AppData in het detailvenster en klikt u vervolgens op Wijzigen
  7. Voer in het vak Waardegegevens%USERPROFILE%\Application Data in en klik op OK.
  8. Sluit de Register-editor.
  9. Probeer de update opnieuw te installeren. Als het probleem zich blijft voordoen, herhaalt u deze stappen, maar gebruikt u de volgende registersubsleutels in plaats van de subsleutel die is opgegeven in stap 4

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Opmerking Dit is een artikel voor snelle publicatie dat rechtstreeks is gemaakt vanuit de ondersteuningsorganisatie van Microsoft. De informatie in dit artikel wordt in de huidige vorm aangeboden in reactie op nieuw geconstateerde problemen. Aangezien artikelen van dit type zeer snel moeten worden gepubliceerd, kan de inhoud typografische fouten bevatten en kan de inhoud zonder voorafgaande kennisgeving worden gewijzigd. Raadpleeg de Gebruiksrechtovereenkomst voor overige aandachtspunten.

Eigenschappen

Artikel ID: 2258121 - Laatste beoordeling: maandag 29 november 2010 - Wijziging: 2.0
Trefwoorden: 
kbfixme kbmsifixme KB2258121

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com