Sind keine Optionen zum Importieren, verknüpfen oder Exportieren der FoxPro-Dateityp in Access 2000 verfügbar

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 225861 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Eine Microsoft Access 2002-Version dieses Artikels finden Sie unter 286224.
Eine Microsoft Office Access 2003-Version dieses Artikels finden Sie unter 824264.
Dieser Artikel bezieht sich ausschließlich auf eine Microsoft Access-Datenbank (.mdb).

Moderat: Erfordert grundlegende Kenntnisse in den Bereichen Makros, Programmierung und Interoperabilität.

Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

In der Importieren , Exportieren und Verknüpfen der Dialogfelder in Microsoft Access 2000 ist FoxPro nicht als Option für den Dateityp aufgelistet.

Ursache

Der Microsoft FoxPro ISAM-Treiber ist nicht länger Bestandteil von Microsoft Access.

Lösung

Zum Importieren aus, verknüpfen und Exportieren nach Microsoft FoxPro, den Visual FoxPro ODBC-Treiber verwenden, wie in den folgenden Schritten gezeigt.

Importieren von FoxPro

  1. Klicken Sie auf Start , zeigen Sie auf Einstellungen und klicken Sie auf Systemsteuerung .
  2. Öffnen Sie in der Systemsteuerung das Programm <uiterm>ODBC Data Sources (32-bit)</uiterm> und fügen Sie eine neue ODBC-Datenquelle für Ihre FoxPro-Datenbank oder Ihre FoxPro-Tabellen hinzu, indem Sie den entsprechenden Microsoft Visual FoxPro-Treiber auswählen.
  3. Öffnen Sie die Access-Datenbank, in die Sie importieren möchten.
  4. Zeigen im Menü Datei auf Externe Daten , und klicken Sie dann auf Importieren .
  5. Klicken Sie im Dialogfeld Importieren auf ODBC-Datenbanken in der Liste Typ .
  6. Klicken Sie im Dialogfeld Datenquelle auswählen Wählen Sie die Visual FoxPro-Datenquelle, die Sie in Schritt 2 erstellt haben, und klicken Sie dann auf OK .
  7. Wählen Sie im Dialogfeld Objekte importieren die Tabellen, die Sie importieren möchten, und klicken Sie dann auf OK .

Verknüpfen mit FoxPro

  1. Klicken Sie auf Start , zeigen Sie auf Einstellungen und klicken Sie auf Systemsteuerung .
  2. Öffnen Sie in der Systemsteuerung das Programm <uiterm>ODBC Data Sources (32-bit)</uiterm> und fügen Sie eine neue ODBC-Datenquelle für Ihre FoxPro-Datenbank oder Ihre FoxPro-Tabellen hinzu, indem Sie den entsprechenden Microsoft Visual FoxPro-Treiber auswählen.
  3. Öffnen Sie die Access-Datenbank, in der Sie die Verknüpfung erstellen möchten.
  4. Im Menü Datei auf Externe Daten , und klicken Sie dann auf Tabellen verknüpfen .
  5. Klicken Sie im Dialogfeld Verknüpfung in der Liste Typ auf ODBC-Datenbanken .
  6. Klicken Sie im Dialogfeld Datenquelle auswählen Wählen Sie die Visual FoxPro-Datenquelle, die Sie in Schritt 2 erstellt haben, und klicken Sie dann auf OK .
  7. Klicken Sie im Dialogfeld Tabellen verknüpfen Wählen Sie die Tabellen, die Sie importieren möchten und klicken Sie dann auf OK .

Exportieren nach FoxPro

  1. Klicken Sie auf Start , zeigen Sie auf Einstellungen und klicken Sie auf Systemsteuerung .
  2. Öffnen Sie in der Systemsteuerung das Programm <uiterm>ODBC Data Sources (32-bit)</uiterm> und fügen Sie eine neue ODBC-Datenquelle für Ihre FoxPro-Datenbank oder Ihre FoxPro-Tabellen hinzu, indem Sie den entsprechenden Microsoft Visual FoxPro-Treiber auswählen.
  3. Öffnen Sie die Access-Datenbank, aus der Sie exportieren möchten.
  4. Klicken Sie im Menü Datei auf Exportieren .
  5. Klicken Sie im Dialogfeld Exporttabelle ' tablename ' zu in der Liste Typ auf ODBC-Datenbanken .
  6. Geben Sie in das Dialogfeld Exportieren die neue Tabelle und klicken Sie dann auf OK .
  7. Klicken Sie im Dialogfeld Datenquelle auswählen Wählen Sie die Visual FoxPro-Datenquelle, die Sie in Schritt 2 erstellt haben, und klicken Sie dann auf OK .

Weitere Informationen

Der Zugriff auf FoxPro über das Microsoft Jet-Datenbankmodul wurde in früheren Versionen von Microsoft Access und früheren Versionen des Microsoft Jet-Datenbankmoduls bereitgestellt. Mit Access 2000 ist jedoch Zugriff auf Microsoft FoxPro-Daten nur über die Microsoft Visual FoxPro ODBC-Treiber möglich. Der Zugriff auf FoxPro-Daten über das Microsoft Jet-Datenbankmodul wird nicht länger unterstützt.

Schritte zum Reproduzieren des Verhaltens

  1. Öffnen Sie eine Access-Datenbank.
  2. Zeigen im Menü Datei auf Externe Daten , und klicken Sie dann auf Importieren .
  3. Klicken Sie im Dialogfeld Importieren auf die Liste Typ .
Beachten Sie, dass FoxPro nicht aufgelistet ist.

Informationsquellen

Weitere Informationen zum Einrichten von ODBC-Datenquellen klicken Sie auf das Menü Hilfe auf Microsoft Access-Hilfe , geben Sie Setup von ODBC-Datenquellen in Office-Assistenten oder im Antwort-Assistenten und anschließend auf Suchen klicken, um das Thema anzuzeigen.

Informationen zum Konvertieren von Datenbanken, die FoxPro-Tabellen verknüpft sind, finden Sie unter den folgenden Artikel der Microsoft Knowledge Base:
200393ACC2000: Linked FoxPro Icon wird in konvertierten Datenbank abgeblendet
Weitere Informationen zu Problemen, die auftreten können finden beim Importieren, verknüpfen und Exportieren von FoxPro-Daten bitte die unten der Microsoft Knowledge Base:
237819ACC2000: "ODBC-Aufruf fehlgeschlagen" Fehlermeldung exportieren nach FoxPro
188401PRB: ACCESS nicht importieren-Verknüpfung Tabelle Wenn Index-Funktion enthält

Eigenschaften

Artikel-ID: 225861 - Geändert am: Dienstag, 10. August 2004 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Access 2000 Standard Edition
Keywords: 
kbmt kbexport kbimport kbprb KB225861 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 225861
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com