Hiçbir seçenek aldığınızda, bağlantı veya Access 2000'de FoxPro dosya türünü vermek kullanılabilir

Makale çevirileri Makale çevirileri
Makale numarası: 225861 - Bu makalenin geçerli olduğu ürünleri görün.
Bu makalenin Microsoft Access 2002 sürümü için bkz: 286224.
Bu makalenin Microsoft Office Access 2003 sürümü için bkz: 824264.
Bu makale yalnızca Microsoft Access veritabanı (.mdb) için geçerlidir.

Orta: temel makro, kodlama ve birlikte çalışabilirlik becerileri gerektirir.

Hepsini aç | Hepsini kapa

Bu Sayfada

Belirtiler

Alma, verme ve Microsoft Access 2000'de bağlantı iletişim kutusu içinde FoxPro dosya türü için bir seçenek olarak listelenmiyor.

Neden

Microsoft FoxPro ISAM sürücüsü, Microsoft Access ile artık bulunmaktadır.

Çözüm

Almak için bağlantı ve Microsoft FoxPro için verme, Visual FoxPro ODBC sürücüsü, aşağıdaki adımlarda gösterildiği gibi kullanın.

FoxPro Al

  1. Başlat ' ı tıklatın, Ayarlar ' ın üzerine gelin ve sonra Denetim Masası ' nı tıklatın.
  2. Denetim Masası'ndaki ODBC veri kaynakları (32-bit) aracını açın ve uygun Microsoft Visual FoxPro sürücüsü seçerek yeni bir ODBC veri kaynağı FoxPro veritabanı veya tablo ekleme.
  3. Almak istediğiniz Access veritabanını açın.
  4. Dosya menüsünden Dış Veri Al'ın üzerine gelin ve Al ' ı tıklatın.
  5. Al iletişim kutusunda Dosya türü listesinde ODBC veritabanı ' ni tıklatın.
  6. Veri Kaynağı Seç iletişim kutusunda, adım 2'de oluşturduğunuz Visual FoxPro veri kaynağını seçin ve Tamam ' ı tıklatın.
  7. Nesneleri Al iletişim kutusunda, almak istediğiniz tabloları seçin ve Tamam ' ı tıklatın.

FoxPro bağlantı

  1. Başlat ' ı tıklatın, Ayarlar ' ın üzerine gelin ve sonra Denetim Masası ' nı tıklatın.
  2. Denetim Masası'ndaki ODBC veri kaynakları (32-bit) aracını açın ve uygun Microsoft Visual FoxPro sürücüsü seçerek yeni bir ODBC veri kaynağı FoxPro veritabanı veya tablo ekleyin.
  3. Bağlantıyı oluşturmak istediğiniz Access veritabanını açın.
  4. Dosya menüsünden Dış Veri Al'ın üzerine gelin ve Tabloları Bağla</a1>'ı tıklatın.
  5. Bağlantı iletişim kutusunda Dosya türü listesinde ODBC veritabanı ' ni tıklatın.
  6. Veri Kaynağı Seç iletişim kutusunda, adım 2'de oluşturduğunuz Visual FoxPro veri kaynağını seçin ve Tamam ' ı tıklatın.
  7. Tabloları Bağla iletişim kutusunda, almak istediğiniz tabloları seçin ve Tamam ' ı tıklatın.

FoxPro için verme

  1. Başlat ' ı tıklatın, Ayarlar ' ın üzerine gelin ve sonra Denetim Masası ' nı tıklatın.
  2. Denetim Masası'ndaki ODBC veri kaynakları (32-bit) aracını açın ve uygun Microsoft Visual FoxPro sürücüsü seçerek yeni bir ODBC veri kaynağı FoxPro veritabanı veya tablo ekleyin.
  3. Verilecek istediğiniz Access veritabanını açın.
  4. Dosya menüsünde Ver ' i tıklatın.
  5. Tablo ver ' tablename ' Kime kutusunda Dosya türü listesinde ODBC veritabanı ' ni tıklatın.
  6. Ver iletişim kutusunda, yeni tablonun adını yazın ve Tamam ' ı tıklatın.
  7. Veri Kaynağı Seç iletişim kutusunda, adım 2'de oluşturduğunuz Visual FoxPro veri kaynağını seçin ve Tamam ' ı tıklatın.

Daha fazla bilgi

FoxPro verilerini Microsoft Jet veritabanı alt yapısı üzerinden erişimi, Microsoft Access'in önceki sürümlerinde ve Microsoft Jet Veritabanı Altyapısı'nün önceki sürümlerinde sağlanmadı. Ancak, Access 2000, Microsoft FoxPro verilere erişimi yalnızca Microsoft Visual FoxPro ODBC sürücüsü olasıdır. FoxPro verilerini Microsoft Jet veritabanı alt yapısı üzerinden erişimi artık desteklenmiyor.

Davranışı yeniden oluşturma adımları

  1. Herhangi bir Access veritabanını açın.
  2. Dosya menüsünden Dış Veri Al'ın üzerine gelin ve Al ' ı tıklatın.
  3. Al iletişim kutusunda Dosya türü listesinde tıklatın.
FoxPro olmadığını unutmayın.

Referanslar

ODBC veri kaynaklarını kurma hakkında daha fazla bilgi için Yardım menüsünden Microsoft Access Yardımı ' nı tıklatın, Office Yardımcısı'na veya Yanıt Sihirbazı ' ODBC veri kaynaklarını kurma kurulum yazın ve sonra döndürülen konuları görüntülemek için Ara ' yı tıklatın.

FoxPro tabloları bağladığınız veritabanı dönüştürme hakkında daha fazla bilgi için lütfen Microsoft Knowledge Base'de aşağıdaki makaleye bakın:
200393ACC2000: Bağlı bir FoxPro simge dönüştürülen veritabanında karartılmış olarak görünür
Karşılaşabileceğiniz sorunlar hakkında ek bilgi için alırken, bağlama ve FoxPro verileri verme Lütfen Microsoft Knowledge Base'deki makaleleri görüntülemek üzere aşağıdaki makale numaralarını tıklatın:
237819ACC2000: FoxPro için verme "ODBC araması başarısız oldu" hata iletisi
188401SORUN: Alma/bağlantı tablo dizin işlevi içeren, ACCESS başlatılamıyor

Özellikler

Makale numarası: 225861 - Last Review: 10 Ağustos 2004 Salı - Gözden geçirme: 2.0
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Access 2000 Standard Edition
Anahtar Kelimeler: 
kbmt kbexport kbimport kbprb KB225861 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:225861

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com