沒有選項可供匯入、 連結,或匯出至 FoxPro 檔案類型,在 Access 2000

文章翻譯 文章翻譯
文章編號: 225861 - 檢視此文章適用的產品。
本文章的有 Microsoft Access 2002] 版本請參閱 286224
本文章的有 Microsoft Office Access 2003] 版本請參閱 824264
本文只適用於 Microsoft Access 資料庫 (.mdb)。

中級使用者: 需要基本巨集]、 [程式碼撰寫,] 以及 [交互操作性技巧。

全部展開 | 全部摺疊

在此頁中

徵狀

匯入匯出,及 Microsoft Access 2000 中的 [連結] 對話方塊,FoxPro 不被列為檔案類型的選項。

發生的原因

Microsoft FoxPro ISAM 驅動程式已不再隨附於 Microsoft Access。

解決方案

從匯入連結至,和匯出至 Microsoft FoxPro,請使用該 Visual FoxPro ODBC 驅動程式,依照下列步驟所示。

從 FoxPro 匯入

  1. 按一下 [開始],指向 [設定],然後再按一下 [控制台]
  2. 在控制台中開啟 ODBC 資料來源 (32 位元) 工具,並透過選取適當的 Microsoft Visual FoxPro 驅動程式新增新的 ODBC 資料來源為您的 FoxPro 資料庫或資料表。
  3. 開啟您要匯入的 Access 資料庫。
  4. 在 [檔案] 功能表上指向 [取得外部資料],然後按一下 [匯入]。
  5. 在 [匯入] 對話方塊按一下 [檔案類型 清單中的 [ODBC 資料庫]。
  6. 在 [選取資料來源] 對話方塊選取在步驟 2,建立的 Visual FoxPro 資料來源],再按 [確定]
  7. 在 [匯入物件] 對話方塊選擇您想要匯入的資料表,再按 [確定]

連結 FoxPro

  1. 按一下 [開始],指向 [設定],然後再按一下 [控制台]
  2. 在控制台中開啟 ODBC 資料來源 (32 位元) 的工具],然後藉由選取適當的 Microsoft Visual FoxPro 驅動程式加入新的 ODBC 資料來源為您的 FoxPro 資料庫或資料表]。
  3. 開啟您想要建立中的連結的 Access 資料庫。
  4. 在 [檔案] 功能表上指向 [取得外部資料],然後按一下 [連線資料表]。
  5. 在 [連結] 對話方塊按一下 [檔案類型 清單中的 [ODBC 資料庫]。
  6. 在 [選取資料來源] 對話方塊選取在步驟 2,建立的 Visual FoxPro 資料來源],再按 [確定]
  7. 在 [連線資料表] 對話方塊選取您想要匯入],資料表],再按 [確定]

匯出至 FoxPro

  1. 按一下 [開始],指向 [設定],然後再按一下 [控制台]
  2. 在控制台中開啟 ODBC 資料來源 (32 位元) 的工具],然後藉由選取適當的 Microsoft Visual FoxPro 驅動程式加入新的 ODBC 資料來源為您的 FoxPro 資料庫或資料表]。
  3. 開啟您想要從匯出的 Access 資料庫。
  4. 在 [檔案] 功能表上按一下 [匯出]。
  5. 在 [匯出資料表 'tablename' 至] 對話方塊按一下 [檔案類型 清單中的 [ODBC 資料庫]。
  6. 在使用 [匯出] 對話方塊鍵入新的資料表名稱,然後按一下 [確定]。
  7. 在 [選取資料來源] 對話方塊選取在步驟 2,建立的 Visual FoxPro 資料來源],再按 [確定]

其他相關資訊

在較早版本的 Microsoft Access 及較早版本的 Microsoft Jet 資料庫引擎提供透過 Microsoft Jet 資料庫引擎的 FoxPro 資料的存取權。不過,與 Access 2000 中可資料的存取權也可以只透過 Microsoft Visual FoxPro ODBC 驅動程式。不再支援透過 Microsoft Jet 資料庫引擎的 FoxPro 資料的存取權。

重製行為的步驟

  1. 開啟任何的 Access 資料庫。
  2. 在 [檔案] 功能表上指向 [取得外部資料],然後按一下 [匯入]。
  3. 在 [匯入] 對話方塊按一下 [檔案類型 清單]。
請注意 FoxPro 並不存在。

?考

如需有關設定 ODBC 資料來源的詳細資訊,按一下 [說明] 功能表上的 [Microsoft Access 的 [說明],並在 「 Office 小幫手 」 或 「 解答精靈 」 中輸入 ODBC 資料來源的安裝程式 再按一下 [搜尋] 以檢視主題。

如需轉換連結 FoxPro 資料表的資料庫資訊,請參閱 「 Microsoft 知識庫 」 中下列文:
200393ACC2000: 連結的 FoxPro 圖示顯示成灰色中轉換的資料庫
如需其他有關資訊可能遇到的問題時匯入,連結,和 FoxPro 資料匯出請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中 「 文件:
237819正在匯出至 FoxPro ACC2000: 「 ODBC 呼叫失敗 」 錯誤訊息
188401PRB: 存取不能匯入/連結資料表如果索引中包含函式

屬性

文章編號: 225861 - 上次校閱: 2004年8月10日 - 版次: 2.0
這篇文章中的資訊適用於:
  • Microsoft Access 2000 Standard Edition
關鍵字:?
kbmt kbexport kbimport kbprb KB225861 KbMtzh
機器翻譯
重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,而非使用人工翻譯而成。Microsoft 同時提供使用者人工翻譯及機器翻譯兩個版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,機器翻譯的文章可能不盡完美。這些文章中也可能出現拼字、語意或文法上的錯誤,就像外國人在使用本國語言時可能發生的錯誤。Microsoft 不為內容的翻譯錯誤或客戶對該內容的使用所產生的任何錯誤或損害負責。Microsoft也同時將不斷地就機器翻譯軟體進行更新。
按一下這裡查看此文章的英文版本:225861
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com