ACC2000: Sie können nicht Unterdatenblatt anzeigen einer Tabelle erweitern, die Sie aus einer anderen Datenbank importiert

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 225862 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde archiviert. Er wird im vorliegenden Zustand bereitgestellt und nicht mehr aktualisiert.
Anfänger: Erfordert Kenntnisse der Benutzeroberfläche auf Einzelplatzrechnern.

Dieser Artikel bezieht sich ausschließlich auf eine Microsoft Access-Datenbank (.mdb).

Alles erweitern | Alles schließen

Problembeschreibung

Wenn Sie die Ansicht Unterdatenblatt einer Tabelle erweitern, erhalten Sie folgende Fehlermeldung:
Der Name Tabelle oder Abfrage ' TableName ', die Sie im entweder Eigenschaftenblatt eingegeben oder Makro ist falsch geschrieben oder bezieht sich auf einer Tabelle oder Abfrage, die nicht vorhanden ist.

Wenn der ungültige Name in einem Makro ist, wird ein Dialogfeld Aktion ist fehlgeschlagen den Makronamen und die Makroargumente anzeigen, nachdem Sie auf OK geklickt haben. Öffnen Sie im Makro, und geben Sie den richtigen Namen.

Ursache

Sie können nur anzeigen oder bearbeiten Sie Objekte direkt verknüpft oder in eine Datenbank importiert. Tabellen, die als Unterdatenblätter verwendet werden, werden nicht automatisch verknüpft oder importiert.

Lösung

Wählen Sie eine der folgenden Vorgehensweisen:
  • Importieren oder Verknüpfen der Tabelle, die für die Unterdatenblatt-Ansicht benötigt wird.

    -oder-
  • Entfernen des Verweis auf den Tabellennamen aus der Name des Unterdatenblattes -Eigenschaft.
Gehen Sie folgendermaßen vor um den Verweis auf den Tabellennamen aus der Eigenschaft Name des Unterdatenblattes zu entfernen:
  1. Öffnen Sie die Tabelle in der Entwurfsansicht.
  2. Klicken Sie im Menü Ansicht auf Eigenschaften .
  3. Legen Sie die Name des Unterdatenblattes -Eigenschaft auf keine .
  4. Speichern Sie und schließen Sie die Tabelle.

Weitere Informationen

Beim Importieren oder einer Tabelle aus einer Datenbank zu einem anderen verknüpfen wird nur die Tabelle, die Sie importiert, selbst wenn die Tabelle ein Unterdatenblatt verwendet. Wenn Sie angeben, dass eine Tabelle ein Unterdatenblatt anzeigen, aber dann importieren oder verknüpfen nur diese Tabelle zu einer anderen Datenbank ohne die Tabelle, die für die Unterdatenblatt-Ansicht benötigt wird sein sollte, wird im Abschnitt "Problembeschreibung" dieses Artikels beschriebene Fehlermeldung angezeigt.

Diese dasselbe Verhalten tritt auch auf, wenn Sie andere abhängigen Datenbankobjekte, wie z. B. ein Formular importieren, das ein Unterformular hat. Wenn Sie das Unterformular nicht auch importieren, erhalten Sie eine ähnliche Bindungsfehler.

Schritte zum Reproduzieren des Verhaltens

  1. Öffnen Sie die Beispieldatenbank "Nordwind.mdb".
  2. Öffnen Sie die Tabelle Kategorien in der Entwurfsansicht.
  3. Klicken Sie im Menü Ansicht auf Eigenschaften .
  4. Legen Sie die Name des Unterdatenblattes -Eigenschaft auf Table.Products .
  5. Speichern Sie und schließen Sie die Tabelle Kategorien.
  6. Erstellen Sie eine neue, leere Access-Datenbank.
  7. Zeigen im Menü Datei auf Externe Daten , und klicken Sie dann auf Importieren .
  8. Wechseln Sie im Feld Suchen in zu dem Ordner, in "Nordwind.mdb" gespeichert ist (Dies ist standardmäßig c:\Programme\Microsoft Office\Office\Samples), und wählen dann die Datei Nordwind.mdb.
  9. Klicken Sie auf Importieren .
  10. Klicken Sie im Dialogfeld Objekte importieren klicken Sie auf Kategorien , und klicken Sie dann auf OK .
  11. Öffnen Sie die Tabelle Kategorien in der Datenblattansicht, und wiederholen Sie die Unterdatenblatt eines beliebigen Datensatzes anzuzeigen durch Erweitern die Vorzeichen Pluszeichen (+) links vom Feld Kategorie-Nr. Beachten Sie, dass die im Abschnitt "Problembeschreibung" dieses Artikels beschriebenen Fehlermeldung angezeigt.

Informationsquellen

Weitere Informationen zu Unterdatenblättern klicken Sie auf das Menü Hilfe auf Microsoft Access-Hilfe , geben Sie den Office-Assistenten oder im Antwort-Assistenten Verwenden von Unterdatenblättern und anschließend auf Suchen klicken, um die zurückgegebenen Themen anzuzeigen.

Eigenschaften

Artikel-ID: 225862 - Geändert am: Mittwoch, 29. Januar 2014 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Access 2000 Standard Edition
Keywords: 
kbnosurvey kbarchive kbmt kbnofix kbprb KB225862 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 225862
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com