OLEXP: Error Message: MSIMN Caused an Invalid Page Fault in Module DIRECTDB.DLL

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Article ID: 225867
For information about the differences between Microsoft Outlook Express and Microsoft Outlook e-mail clients, click the following article number to view the article in the Microsoft Knowledge Base:
257824 OL2000: Differences Between Outlook and Outlook Express
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Symptoms

When you import e-mail messages from Microsoft Outlook Express 5, you may receive any of the following error messages:
MSIMN caused an invalid page fault in module DIRECTDB.DLL.
MSIMN caused an exception in module directdb.dll.
MSIMN caused an exception c0000006h in module directdb.dll.

Cause

This behavior can occur if the Messages.ods file is not in the folder that is specified for it in the Windows registry.

Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

To resolve this issue, use one of the following methods:

If You Do Not Want to Save Your E-Mail Messages

If you do not want to save your e-mail messages in Outlook Express 5, rename the Messages.ods file.

For information about how to rename a file, click Start, click Help, click the Index tab, type renaming, and then double-click the Renaming Files Help topic.

If You Want to Save Your E-Mail Messages

If you want to save your e-mail messages in Outlook Express 5:
  1. Find out which folders contain the Messages.ods file and the .dbx files:
    1. Click Start, point to Find, and then click Files or Folders.
    2. In the Named box, type messages.ods *.dbx, and then click Find Now.
  2. Move the Messages.ods file into the same folder that contains the .dbx files.

    For information about how to move files, click Start, click Help, click the Index tab, type moving files, and then click Display.
  3. Use Registry Editor to delete the ConvertedToDBX value in the registry:
    1. Click Start, click Run, type Regedt32, and then click OK.
    2. Double-click to expand the HKEY_CURRENT_USER folder, expand the Identities folder, and then expand the {clsid} folder.
    3. Expand the Software folder, expand the Microsoft folder, and then expand the Outlook Express folder.
    4. Expand the 5.0 folder, and then click the ConvertedToDBX value.
    5. On the Edit menu, click Delete, and then click OK.
    6. Quit Registry Editor.
  4. Restart your computer, and then start Outlook Express.

Properties

Article ID: 225867 - Last Review: June 22, 2014 - Revision: 6.0
Keywords: 
kbenv kberrmsg kbnetwork kbprb KB225867

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