Artigo: 225867 - Última revisão: quarta-feira, 24 de Janeiro de 2007 - Revisão: 4.3

OLEXP: Mensagem de erro: MSIMN causou um erro de página inválida no módulo DIRECTDB.DLL

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Para obter informações sobre as diferenças entre o Microsoft Outlook Express e clientes de correio electrónico do Microsoft Outlook, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
257824  (http://support.microsoft.com/kb/257824/EN-US/ ) OL2000: Diferenças entre o Outlook e o Outlook Express
Expandir tudo | Reduzir tudo

Sintomas

Quando importa mensagens de correio electrónico do Microsoft Outlook Express 5, poderá receber uma das seguintes mensagens de erro:
MSIMN causou um erro de página inválida no módulo DIRECTDB.DLL.
MSIMN causou uma excepção no módulo directdb.dll.
MSIMN causou uma excepção c0000006h no módulo directdb.dll.

Causa

Este comportamento pode ocorrer se o ficheiro messages.ods não está a ser a pasta especificada para o mesmo no registo do Windows.

Resolução

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows

Para resolver este problema, utilize um dos seguintes métodos:

Se a não pretende guardar as mensagens de correio electrónico

Se não pretender guardar as mensagens de correio electrónico no Outlook Express 5, mude o nome do ficheiro messages.ods .

Para obter informações sobre como mudar o nome de um ficheiro, clique em Iniciar , clique em Ajuda , clique no separador índice remissivo , escreva Mudar o nome e, em seguida, clique duas vezes no tópico de ajuda Ficheiros mudar o nome .

Se pretende guardar as mensagens de correio electrónico

Se pretender guardar as mensagens de correio electrónico no Outlook Express 5:
  1. Saber quais as pastas que contêm o ficheiro messages.ods e os ficheiros .dbx:
    1. Clique em Iniciar , aponte para Localizar e, em seguida, clique em ficheiros ou pastas .
    2. Na caixa com o nome , escreva messages.ods *.dbx e, em seguida, clique em Localizar agora .
  2. Mova o ficheiro messages.ods na mesma pasta que contém os ficheiros .dbx .

    Para obter informações sobre como mover ficheiros, clique em Iniciar , clique em Ajuda , clique no separador índice remissivo , escreva a movimentação de ficheiros e, em seguida, clique em Mostrar .
  3. Utilize o Editor de registo para eliminar o valor de ConvertedToDBX no registo:
    1. Clique em Iniciar , clique em Executar , escreva Regedt32 e, em seguida, clique em OK .
    2. Faça duplo clique para expandir a pasta HKEY_CURRENT_USER , expanda a pasta Identities e, em seguida, expanda a pasta de {clsid} .
    3. Expanda a pasta software , expanda a pasta Microsoft e, em seguida, expanda a pasta Outlook Express .
    4. Expanda a pasta 5.0 e, em seguida, clique no valor ConvertedToDBX .
    5. No menu Editar , clique em Eliminar e, em seguida, clique em OK .
    6. Saia do Editor de registo.
  4. Reinicie o computador e, em seguida, inicie o Outlook Express.

A informação contida neste artigo aplica-se a:
  • Microsoft Outlook Express 5.0
  • Microsoft Outlook Express 5.0
  • Microsoft Outlook Express 5.0
Palavras-chave: 
kbmt kbenv kberrmsg kbnetwork kbprb KB225867 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 225867  (http://support.microsoft.com/kb/225867/en-us/ )