ID do artigo: 225867 - Última revisão: terça-feira, 2 de março de 2004 - Revisão: 3.0

OLEXP: Mensagem de Erro: O MSIMN causou uma falha de página inválida no módulo DIRECTDB.DLL.

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Para obter informações sobre as diferenças entre os clientes de e-mail do Microsoft Outlook Express e do Microsoft Outlook, clique no número abaixo para exibir o artigo na Base de Dados de Conhecimento da Microsoft:
257824  (http://support.microsoft.com/kb/257824/PT-BR/ ) OL2000: Diferenças Entre o Outlook e o Outlook Express
IMPORTANTE: Este artigo contém informações sobre como modificar o registro. Antes de modificar o registro, verifique se possui um backup e se sabe como restaurar o registro caso ocorra algum problema. Para obter informações sobre como fazer backup, restaurar e editar o registro, clique no número abaixo para consultar o artigo na Base de Dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/PT-BR/ ) Descrição do Registro do Microsoft
Expandir tudo | Recolher tudo

Sintomas

Ao importar mensagens do Outlook Express 5 Beta 2, você pode receber uma das seguintes mensagens de erro:
O MSIMN causou uma falha de página inválida no módulo DIRECTDB.DLL.
O MSIMN causou uma exceção no módulo directdb.dll.
O MSIMN causou uma exceção c0000006h no módulo directdb.dll.

Causa

Esse comportamento pode ocorrer se o arquivo Messages.ods não está na pasta para o qual está especificado no registro do Windows:

Resolução

AVISO: Se você usar o Editor do registro incorretamente, poderá causar problemas graves que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você conseguirá solucionar os problemas resultantes do uso incorreto do Editor do registro. Use o Editor do registro por sua conta e risco.

Para resolver esse problema, use um dos seguintes métodos:

Caso não deseje salvar suas mensagens de email

Caso não deseje salvar suas mensagens de email no Outlook Express 5 Beta 2, renomeie o arquivo Messages.ods.

Para obter informações sobre como renomear arquivos, clique em Iniciar, em Ajuda, clique na guia Índice, digite renomeando e clique duas vezes no tópico de Ajuda "Renomeando arquivos".

Caso deseje salvar suas mensagens de email

Se deseja salvar suas mensagens de email no Outlook Express 5 Beta 2:
  1. Descubra quais pastas contêm o arquivo Messages.ods e os arquivos .dbx:
    1. Clique em Iniciar, aponte para Localizar e clique em Arquivos ou pastas.
    2. Na caixa Nome, digite messages.ods*.mbx e clique em Localizar agora.
  2. Mova o ar quivo Messages.ods para a mesma pasta que contêm os arquivos .dbx.

    Para obter informações sobre como localizar arquivos, clique em Iniciar, em Ajuda, clique na guia Índice, digite movendo arquivos e clique duas vezes em Exibir.
  3. Use o Editor de registros para excluir o valor ConvertedToDBX no registro:
    1. Clique em Iniciar e em Executar, digite Regedt32 e clique em OK.
    2. Clique duas vezes para expandir a pasta HKEY_CURRENT_USER, a pasta Identidades e a pasta {clsid}.
    3. Expanda a pasta Software, a pasta Microsoft e a pasta Outlook Express.
    4. Expanda a pasta 5.0 e clique no valor ConvertedToDBX.
    5. No menu Editar, clique em Excluir e em OK.
    6. Feche o Editor do registro.
  4. Reinicie seu computador, e inicie o Outlook Express.

A informação contida neste artigo aplica-se a:
  • Microsoft Outlook Express 5.0
  • Microsoft Outlook Express 5.0
  • Microsoft Outlook Express 5.0
Palavras-chave: 
kberrmsg kbenv kbnetwork kbprb KB225867