Mensaje de error al instalar SQL Server 2008 R2 antes de ejecutar la herramienta PreRequisiteInstaller.exe

Seleccione idioma Seleccione idioma
Id. de artículo: 2261507 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Considere el siguiente escenario:
  • Instalar Microsoft SQL Server 2008 R2 (incluido el motor de base de datos de SQL Server y Analysis Services de SQL Server).
  • Ejecutar la herramienta PreRequisitesInstaller.exe desde el medio de Microsoft SharePoint Server 2010.
  • Instalar SharePoint Server 2010 Enterprise Edition. A continuación, se ejecuta de nuevo el programa de instalación de SQL Server 2008 R2.
  • Continúa con la instalación y, a continuación, tener acceso a un cuadro de diálogo que necesita elIntegración de SharePoint de servicios de análisiscaracterística para instalarse.
En este escenario, el instalación se produce un error y se recibe el mensaje de error siguiente:
No se pudo cargar el ensamblado ? Microsoft.AnalysisServices.SharePoint.Integration.dll ?

Nota
Este problema se produce en las nuevas instalaciones de servidor y las instalaciones de conjunto de servidores existente.

Causa

Este problema se produce porque el orden de instalación produce un conflicto con uno de los componentes de SQL Server. El componente hace referencia al ensamblado de la Microsoft.AnalysisServices.SharePoint.Integration.dll antes de que el componente está instalado en el equipo. Cuando se instala el componente, se produce un conflicto y el sistema almacena en caché el error, aunque existe el archivo.

Solución

Para solucionar temporalmente este problema, siga estos métodos:

NotaAntes de seguir alguno de estos métodos, guarde el código siguiente en un archivo que se denomina Setup100.exe.config.
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  <runtime>
    <disableCachingBindingFailures enabled="1" />
  </runtime>
</configuration>

Método 1

Si tiene la PowerPivot para componentes de SharePoint en un equipo, siga estos pasos:
  1. El PowerPivot de desinstalar la instancia de Analysis Services. Esta acción también desinstala PowerPivot para componentes de SharePoint.
  2. Reinicie el equipo.
  3. Ejecutar las secuencias de comandos para volver a habilitar la característica de PremiumSite. Para obtener más información acerca de cómo habilitar la característica de PremiumSite, haga clic en el vínculo siguiente para verlo en Microsoft Knowledge Base:
    2261512Reparar la característica de sitio post-Uninstall Premium
  4. Reinicie el equipo.
  5. Copiar el archivo Setup100.exe.config a la siguiente ruta de acceso:
    Bootstrap\SQLServer2008R2\x64 Server\100\Setup de %programfiles%\Microsoft SQL
  6. Reinstalar el PowerPivot para componentes de SharePoint.

Método 2

Si no tiene el PowerPivot para componentes de SharePoint en un equipo, siga estos pasos:
  1. Asegúrese de que el directorio siguiente existe en el equipo:
    Bootstrap\SQLServer2008R2\x64 Server\100\Setup de %programfiles%\Microsoft SQL
  2. Si existe el directorio, siga estos pasos:
    1. Copie el archivo setup100.exe.config para el directorio.
    2. Instalar PowerPivot para componentes de SharePoint.
  3. Si el directorio no existe, siga estos pasos:
    1. Ejecutar el archivo de instalación hasta que llegue laArchivos de soporte técnico de la instalaciónventana . A continuación, haga clic enInstalar.
    2. Una vez finalizada la instalación de los archivos de compatibilidad, haga clic enCancelar. Ahora debe existir el directorio en el equipo.
    3. Copie el archivo Setup100.exe.config para el directorio.
    4. Reinicie el equipo.
    5. Volver a ejecutar el archivo de instalación.

Propiedades

Id. de artículo: 2261507 - Última revisión: lunes, 09 de agosto de 2010 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft SQL Server 2008 R2 Analysis Services
  • Microsoft SQL Server 2008 R2 Datacenter
  • Microsoft SQL Server 2008 R2 Developer
  • Microsoft SQL Server 2008 R2 Enterprise
Palabras clave: 
kbsurveynew kbexpertiseadvanced kbprb kbmt KB2261507 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2261507

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com