เกิดข้อผิดพลาดเมื่อคุณติดตั้ง SQL Server 2008 R2 ก่อนที่จะเรียกใช้เครื่องมือ PreRequisiteInstaller.exe

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 2261507 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

พิจารณาสถานการณ์สมมติต่อไปนี้:
  • คุณติดตั้ง Microsoft SQL Server 2008 R2 (รวมทั้งโปรแกรมฐานข้อมูลของเซิร์ฟเวอร์ SQL และการบริการการวิเคราะห์เซิร์ฟเวอร์ SQL)
  • คุณเรียกใช้เครื่องมือ PreRequisitesInstaller.exe จากสื่อ 2010 เซิร์ฟเวอร์ SharePoint Microsoft
  • ที่คุณติดตั้ง Edition องค์กรของ 2010 เซิร์ฟเวอร์ SharePoint เรียกแล้ว โปรแกรมติดตั้ง SQL Server 2008 R2 ไม่ใช้อีกครั้ง
  • จะดำเนินการติดตั้ง และจากนั้น คุณไปถึงกล่องโต้ตอบที่ต้องการการรวม SharePoint Services การวิเคราะห์คุณลักษณะที่จะติดตั้ง
ในนี้ สถานการณ์สมมติ,, ล้มเหลวของการติดตั้ง และคุณได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้:
ไม่สามารถโหลดแอสเซมบลี ‘ Microsoft.AnalysisServices.SharePoint.Integration.dll ’

หมายเหตุ
ปัญหานี้เกิดขึ้นในทั้งการติดตั้งเซิร์ฟเวอร์ใหม่และที่มีอยู่ฟาร์มติดตั้ง

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากใบสั่งการติดตั้งทำให้เกิดความขัดแย้งกับคอมโพเนนต์ของ SQL Server อย่างใดอย่างหนึ่ง คอมโพเนนต์อ้างอิงแอสเซมบลี Microsoft.AnalysisServices.SharePoint.Integration.dll ก่อนที่คอมโพเนนต์มีการติดตั้งในคอมพิวเตอร์ เมื่อมีการติดตั้งคอมโพเนนต์ ข้อขัดแย้งเกิดขึ้น และระบบเก็บข้อผิดพลาดถึงแม้ว่าแฟ้มมีอยู่

การหลีกเลี่ยงปัญหา

เพื่อหลีกเลี่ยงปัญหานี้ ทำตามวิธีการเหล่านี้:

หมายเหตุก่อนที่คุณทำตามวิธีการเหล่านี้ ใด ๆ บันทึกรหัสต่อไปนี้ไปยังแฟ้มที่มีชื่อว่า Setup100.exe.config
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  <runtime>
    <disableCachingBindingFailures enabled="1" />
  </runtime>
</configuration>

วิธีที่ 1

ถ้าคุณมี PowerPivot สำหรับคอมโพเนนต์ของ SharePoint ที่ติดตั้งในคอมพิวเตอร์ของคุณ ทำตามขั้นตอนเหล่านี้:
  1. อินสแตนซ์ ถอนการติดตั้งแบบ PowerPivot Analysis Services การดำเนินการนี้ยัง uninstalls PowerPivot สำหรับคอมโพเนนต์ของ SharePoint
  2. รีสตาร์ทเครื่องคอมพิวเตอร์ของคุณ
  3. เรียกใช้สคริปต์เพื่อเปิดใช้งานลักษณะการทำงานในการ PremiumSite สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการเปิดใช้งานลักษณะการทำงานในการ PremiumSite คลิกลิงค์ต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
    2261512การซ่อมแซมคุณลักษณะไซต์ค่า post-Uninstall
  4. รีสตาร์ทเครื่องคอมพิวเตอร์ของคุณ
  5. คัดลอกแฟ้ม Setup100.exe.config เส้นทางต่อไปนี้:
    Bootstrap\SQLServer2008R2\x64 Server\100\Setup SQL %ProgramFiles%\Microsoft
  6. ติดตั้งใหม่ PowerPivot สำหรับคอมโพเนนต์ของ SharePoint

วิธีที่ 2

หากคุณไม่มี PowerPivot สำหรับคอมโพเนนต์ของ SharePoint ที่ติดตั้งในคอมพิวเตอร์ของคุณ ทำตามขั้นตอนเหล่านี้:
  1. ยืนยันที่ไดเรกทอรีดังต่อไปนี้อยู่ในคอมพิวเตอร์ของคุณ:
    Bootstrap\SQLServer2008R2\x64 Server\100\Setup SQL %ProgramFiles%\Microsoft
  2. ถ้าอยู่ในไดเรกทอรี ทำตามขั้นตอนเหล่านี้:
    1. คัดลอกแฟ้ม setup100.exe.config ไปยังไดเรกทอรี
    2. ติดตั้ง PowerPivot สำหรับคอมโพเนนต์ SharePoint
  3. ถ้าไม่มีไดเรกทอรี ทำตามขั้นตอนเหล่านี้:
    1. เรียกใช้แฟ้มการติดตั้งจนถึงการการตั้งค่าแฟ้มการสนับสนุนหน้าต่าง จากนั้น คลิกติดตั้ง
    2. เมื่อการติดตั้งของแฟ้มสนับสนุนเสร็จสมบูรณ์ คลิกยกเลิก ไดเรกทอรีควรมีอยู่ในคอมพิวเตอร์ของคุณในขณะนี้
    3. คัดลอกแฟ้ม Setup100.exe.config ไปยังไดเรกทอรี
    4. รีสตาร์ทเครื่องคอมพิวเตอร์ของคุณ
    5. rerun แฟ้มติดตั้ง

คุณสมบัติ

หมายเลขบทความ (Article ID): 2261507 - รีวิวครั้งสุดท้าย: 9 สิงหาคม 2553 - Revision: 1.0
ใช้กับ
  • Microsoft SQL Server 2008 R2 Analysis Services
  • Microsoft SQL Server 2008 R2 Datacenter
  • Microsoft SQL Server 2008 R2 Developer
  • Microsoft SQL Server 2008 R2 Enterprise
Keywords: 
kbsurveynew kbexpertiseadvanced kbprb kbmt KB2261507 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:2261507

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com