Parches de Microsoft Framework pueden fallar con acceso denegado o un archivo de error de uso

Seleccione idioma Seleccione idioma
Id. de artículo: 2263996 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Si ha sido un archivo de ensamblado en la GAC (caché de acceso Global)bloqueadoo es"en uso"se puede producir.NET Framework parches a un error. Este problema se puede agudizar por un error en el modo de fusión controla la operación de deshacer y puede hacer que los archivos que desea eliminar. Esto dará como resultado aplicaciones administradas (es decir, aquellas aplicaciones que dependen de los ensamblados de framework) para producir un error. Para obtener más información, visite el siguiente sitio Web de Microsoft:
2260913Archivos en uso o bloqueos de archivo puede dar lugar a que se está eliminando los archivos de ensamblado de Framework
La revisión de la falta de registro MSI detallado podría contener algo similar a esto:

>>
'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\system.dll' por error del sistema:Acceso denegado.

22/06/10 11:57:26 DDSet_Status: en modo de suspensión 100ms...
MSI (s) (54! 70) [11:57:26:738]: productos: Microsoft.NET Framework 2.0 Service Pack 2: hay un problema con este paquete de Windows Installer. Consulte el registro de instalación para obtener más información.
Hay un problema con este paquete de Windows Installer. Consulte el registro de instalación para obtener más información.
22/06/10 11:57:26 DDSet_CARetVal: 0
22/06/10 11:57:26 DDSet_Exit: InstallAssembly terminó con el valor devuelto 1603
MSI (s) (54:94) [11:57:26:758]: valor 'disablerollback' de la directiva de usuario es 0
MSI (s) (54:94) [11:57:26:758]: valor 'disablerollback' de la directiva de equipo es 0
La acción terminó a 11:57:26: InstallExecute. Valor devuelto 3.


O

>>
02/22/10 08:38:32 DDSet_Status: en modo de suspensión 100ms...
02/22/10 08:38:32 DDSet_Error: no se pudo instalar el ensamblado C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.EnterpriseServices.dll. IAssemblyCache->InstallAssembly() devolvió -2147024864.
02/22/10 08:38:32 DDSet_Error: no se pudo instalar el ensamblado 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.EnterpriseServices.dll' por error del sistema: el proceso no puede tener acceso al archivo porque está siendo utilizado por otro proceso.

Causa

Si los ensamblados son"enusar"o bloqueadosCuando se aplica una revisión, se producirá un error en la revisión.

Solución

Este problema puede evitarse asegurándose de procesos son no en ejecución que puede colocar un bloqueo en los ensamblados.

Para detectar si se utilizan los ensamblados, siga estos pasos:
  1. Descargarprocexp.exepara descubrir el proceso que se bloqueen los ensamblados.
  2. Lanzamientoprocexp.exey, a continuación, presioneCTRL+FPara abrir la ventana de búsqueda del explorador de procesos.
  3. En elSubcadena de identificador o una DLLcuadro de texto, tipoEnsambladoy, a continuación, haga clic enBúsqueda.
    Contraer esta imagenAmpliar esta imagen
    2525714
  4. Todos los archivos enumerados podrían tener un impacto en la instalación de la revisión. Terminar todos los procesos enumerados o cerrar las aplicaciones asociadas. Para ello, siga estos pasos:
    1. Haga clic en elNombre del procesodesea terminar en elBúsqueda del explorador de procesosventana para localizar el proceso.
    2. Haga clic con elNombre del procesoen elProcesopanel.
    3. Haga clic enEliminar procesoPara terminar el proceso.

    Contraer esta imagenAmpliar esta imagen
    2526333

Propiedades

Id. de artículo: 2263996 - Última revisión: viernes, 25 de marzo de 2011 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft .NET Framework 2.0
  • Microsoft .NET Framework 2.0 Service Pack 1 (x86)
  • Microsoft .NET Framework 2.0 Service Pack 2
  • Microsoft .NET Framework 3.0
  • Microsoft .NET Framework 3.0 Service Pack 1
  • Microsoft .NET Framework 3.0 Service Pack 2
  • Microsoft .NET Framework 3.5
  • Microsoft .NET Framework 3.5 Service Pack 1
Palabras clave: 
kbmt KB2263996 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2263996

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com