A Windows Server 2003-based TS Licensing server does not renew new versions of TS Per Device CALs or of RDS Per Device CALs when the CALs expire

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Article ID: 2276913 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You have a terminal server that is running Windows Server 2003.
  • You configure the terminal server to contact a Windows Server 2003-based Terminal Services (TS) Licensing server to request or renew TS client access licenses (CALs).
  • You try to start a terminal server session to the terminal server from a client computer. The client computer has an expired Per Device license that is for Windows Server 2008 or for Windows Server 2008 R2.
In this scenario, the terminal server session fails, and you receive the following error message:
The remote session was disconnected because there were no terminal server license server available to provide a License.

CAUSE

This issue occurs because the Windows Server 2003-based TS Licensing server does not recognize new versions of TS Per Device CALs or of Remote Desktop Services (RDS) Per Device CALs. Therefore, the TS Licensing server does not respond to the request or renewal of the CAL.

RESOLUTION

To resolve this issue, install this hotfix on the Windows Server 2003 Service Pack 2 (SP2)-based TS Licensing server.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KB2276913.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lserver.exe5.2.3790.4789349,69619-Oct-201013:06x86
For all supported x64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lserver.exe5.2.3790.4789538,11220-Oct-201007:53x64
For all supported IA-64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lserver.exe5.2.3790.4789995,32820-Oct-201007:53IA-64

WORKAROUND

Workaround for Windows Server 2003

To work around this issue, delete all registry hives that are located under the following registry subkey on the client computer:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about TS Licensing, visit the following Microsoft webpage.
Introduction to TS Licensing

Properties

Article ID: 2276913 - Last Review: June 20, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows Server 2003 Service Pack 2, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter KB2276913

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