Al intentar recuperar caracteres de árabes especiales de las columnas de DB2 mediante el uso de SQL Server Reporting Services, se muestran los caracteres ilegibles en 2009 de Host Integration Server

Seleccione idioma Seleccione idioma
Id. de artículo: 2278243 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

En un entorno de Microsoft Host Integration Server 2009, al intentar recuperar las columnas de una tabla DB2 con el proveedor de OLE DB para DB2, Microsoft SQL Server Reporting Services puede mostrar caracteres de la basura en las columnas.

Este problema se produce si las columnas contienen los caracteres de árabes especiales siguientes:
  • Dhad: ?
  • Saad: ?
  • Brillo: ?
  • Ver: ?

Causa

Este problema se produce porque los caracteres que se mencionan en la sección "Síntomas" se representan como dos caracteres de EBCDIC. Sin embargo, estos caracteres se representan como un único carácter en ANSI. Debido a que se inicializa el búfer de datos mediante el uso de valores NULL, el búfer de datos tiene caracteres adicionales de NULL cuando el búfer de datos que recupera las columnas de DB2 que contienen dichos caracteres árabes. Por lo tanto, SQL Server Reporting Services muestra caracteres ilegibles.

Solución

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a sistemas que experimenten el problema descrito en este artículo. Esta revisión es posible que realicen pruebas adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a que la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, no hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece en esta sección, póngase en contacto con el servicio de cliente de Microsoft y soporte técnico para obtener la revisión.

NotaSi se producen problemas adicionales o si necesita solucionar un problema, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión en cuestión. Para obtener una lista completa de los números de teléfono del servicio de cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
NotaEl formulario "Descarga de revisión disponibles" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

La versión de inglés (Estados Unidos) de esta revisión usa un paquete de Microsoft Windows Installer para instalar la revisión. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC) en la tabla siguiente. Al ver la información de archivo, la fecha se convierte en hora local. Para ver la diferencia entre hora UTC y la hora local, utilice elZona horariaen el elemento de fecha y hora en el panel de control de ficha.

Microsoft Host Integration Server 2009 edición de 32 bits
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
trnsbidi.dll8.0.3763.261,26407-Jul-201013: 53x 86
Microsoft Host Integration Server 2009 edición de 64 bits
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
trnsbidi.dll8.0.3763.267,40807-Jul-201013: 59x 64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Propiedades

Id. de artículo: 2278243 - Última revisión: viernes, 5 de noviembre de 2010 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Host Integration Server 2009
Palabras clave: 
kbautohotfix kbqfe kbHotfixServer kbfix kbexpertiseadvanced kbsurveynew kbfont kbmt KB2278243 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2278243

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com