La modifica di una partizione attiva potrebbe non consentire pi¨ l'avvio del sistema

Traduzione articoli Traduzione articoli
Identificativo articolo: 228004 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Quando si utilizza lo snap-in Gestione disco di Windows per contrassegnare la partizione primaria come attiva, il computer potrebbe non avviarsi se la partizione contrassegnata come attiva non contiene i file di avvio di Windows o i file di avvio per un altro sistema operativo.

NOTA: quando si verifica questa evenienza, potrebbe essere visualizzato il messaggio di errore indicato di seguito quando si tenta di avviare il computer:
NTLDR mancante.

Cause

Questo problema si verifica perchÚ nei computer basati su processori Intel la partizione di sistema deve essere una partizione primaria contrassegnata come attiva per l'esecuzione automatica. Questa partizione deve essere presente nel disco a cui il computer accede all'avvio. Pu˛ essere presente una sola partizione di sistema attiva per volta. Se si desidera utilizzare un altro sistema operativo, Ŕ innanzitutto necessario contrassegnare la relativa partizione di sistema come attiva prima di riavviare il computer.

Risoluzione

Per risolvere il problema, effettuare una delle seguenti operazioni:
  • Potrebbe essere possibile modificare la partizione attiva eseguendo l'avvio da un disco floppy e utilizzando le utilitÓ dei dischi per effettuare manualmente la modifica. Oppure

  • Se Ŕ disponibile spazio su disco sufficiente, Ŕ possibile installare Windows in una directory parallela. Al termine di questa installazione parallela Ŕ possibile utilizzare lo snap-in Gestione disco per modificare la partizione attiva.

    I nomi comunemente utilizzati per le partizioni contenenti i file di esecuzione automatica e del sistema operativo sono rispettivamente sistema e partizioni di avvio. Oppure

  • Se la partizione erroneamente contrassegnata come attiva Ŕ una partizione FAT, FAT32 o NTFS, potrebbe essere possibile risolvere il problema mediante la Console di ripristino di emergenza di Windows.

    Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
    229716 Descrizione della Console di ripristino di emergenza di Windows 2000

    NOTA: in Windows la partizione attiva Ŕ sempre l'unitÓ C, pertanto le lettere di unitÓ nelle partizioni del disco rigido potrebbero essere state modificate rispetto all'orientamento originale.
    Mediante la Console di ripristino di emergenza Ŕ necessario copiare i file riportati di seguito dalla directory principale della partizione del sistema di origine nella directory principale della partizione attualmente attiva, che Ŕ ora l'unitÓ C:
    NTLDR
    NTDETECT.COM
    BOOT.INI
    Se la partizione non Ŕ stata formattata mediante Windows, potrebbe anche essere necessario eseguire il comando FIXBOOT della Console di ripristino di emergenza per rendere avviabile la partizione attiva.

    Quando Ŕ possibile eseguire l'avvio a Windows, Ŕ consigliabile utilizzare lo snap-in Gestione disco di Windows per reimpostare la partizione di sistema originale come partizione attiva e riavviare il computer. In questo modo la partizione di sistema corretta verrÓ ripristinata come unitÓ C:.

ProprietÓ

Identificativo articolo: 228004 - Ultima modifica: venerdý 15 giugno 2007 - Revisione: 3.2
Le informazioni in questo articolo si applicano a
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Datacenter Server
Chiavi:á
kbprb KB228004
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com