メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。
英語
申し訳ございません。この記事は、ご利用の言語では用意されていません。

Symptoms

You have a client computer that is running Windows 7 or Windows Server 2008 R2. When you try to print to a non-Windows-based Internet Printing Protocol (IPP) server, the print job fails.

This issue occurs if the following conditions are true:

  • The IPP server requires Basic authentication.

  • The print job is large.

Cause

This issue occurs because Windows does not correctly listen for replies from the IPP server when a print job is spanned over multiple TCP packets. Some IPP implementations reply to IPP job requests after they receive the first packet. However, Windows listens for the job status message only after it sends all the packets in the print job. Therefore, if the print job is large, the operating system does not receive Access Denied responsesin a timely manner and resends the print job with authentication.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows Server 2008 R2.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notes


Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are very important for maintaining the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Inetpp.dll

6.1.7600.20757

125,440

17-Jul-2010

07:24

x86

Inetppui.dll

6.1.7600.16385

18,944

14-Jul-2009

01:15

x86

Wpnpinst.exe

6.1.7600.16385

39,424

14-Jul-2009

01:14

x86

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Inetpp.dll

6.1.7600.20757

165,376

17-Jul-2010

08:05

x64

Inetppui.dll

6.1.7600.16385

22,528

14-Jul-2009

01:41

x64

Wpnpinst.exe

6.1.7600.16385

48,640

14-Jul-2009

01:39

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Inetpp.dll

6.1.7600.20757

396,288

17-Jul-2010

06:42

IA-64

Inetppui.dll

6.1.7600.16385

51,712

14-Jul-2009

01:46

IA-64

Wpnpinst.exe

6.1.7600.16385

127,488

14-Jul-2009

01:45

IA-64

Workaround

To work around this issue, disable Basic authentication on the IPP server.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about IPP, visit the following Microsoft website:

Internet Printing Protocol (IPP)For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File name

X86_60b5b9e4fedcedb55cf70b52ffbe7089_31bf3856ad364e35_6.1.7600.20757_none_b0f4331760e5ee92.manifest

File version

Not applicable

File size

720

Date (UTC)

19-Jul-2010

Time (UTC)

13:13

Platform

Not applicable

File name

X86_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.1.7600.20757_none_8b54cea642ba45cd.manifest

File version

Not applicable

File size

5,259

Date (UTC)

19-Jul-2010

Time (UTC)

13:17

Platform

Not applicable

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

Amd64_791ba12cb5d4c75efb2dbfdabbc769dd_31bf3856ad364e35_6.1.7600.20757_none_d0ab81e39833c3ed.manifest

File version

Not applicable

File size

724

Date (UTC)

19-Jul-2010

Time (UTC)

13:13

Platform

Not applicable

File name

Amd64_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.1.7600.20757_none_e7736a29fb17b703.manifest

File version

Not applicable

File size

5,263

Date (UTC)

19-Jul-2010

Time (UTC)

13:20

Platform

Not applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File name

Ia64_be1ce4f00e932b133309f5253148c503_31bf3856ad364e35_6.1.7600.20757_none_2dcd5bf5c91e5e6d.manifest

File version

Not applicable

File size

722

Date (UTC)

19-Jul-2010

Time (UTC)

13:13

Platform

Not applicable

File name

Ia64_microsoft-windows-p..rnetprinting-client_31bf3856ad364e35_6.1.7600.20757_none_8b56729c42b84ec9.manifest

File version

Not applicable

File size

5,261

Date (UTC)

19-Jul-2010

Time (UTC)

13:13

Platform

Not applicable

ヘルプを表示

その他のオプションが必要ですか?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

この情報は役に立ちましたか?

どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×