FIX: Error message when you try to establish a security context between a server and a remote client in a Host Integration Server 2006 SP1 or Host Integration Server 2010 environment: "Insufficient memory"

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Article ID: 2281720 - View products that this article applies to.
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SYMPTOMS

In a Microsoft Host Integration Server 2006 Service Pack 1 (SP1) environment or in a Microsoft Host Integration Server 2010 environment, you try to establish a security context between a server and a remote client. When you use Kerberos authentication, the operation may fail. Additionally, you may receive the following error message:
Insufficient memory

CAUSE

This problem may occur when the security token is larger than 32 kilobytes (KB).

RESOLUTION

Hotfix information

Microsoft Host Integration Server 2010

The hotfix that resolves this issue is included in cumulative update package 2 for Host Integration Server 2010.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2616519 Cumulative update package 2 for Host Integration Server 2010

Microsoft Host Integration Server 2006

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites
You must have Microsoft Host Integration Server 2006 Service Pack 1 (SP1) installed to apply this hotfix.

For more information about how to obtain the service pack, click the following article number to view the article in the Microsoft Knowledge Base:
979497 How to obtain the latest Host Integration Server 2006 service pack

Restart information
You may have to restart the computer after you apply this hotfix.

Replacement information
This hotfix does not replace a previously released hotfix.

File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Microsoft Host Integration Server 2006, 32-bit Edition
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mmcsna.dll7.0.4224.0324,94407-Nov-201120:09x86
Mngagent.exe7.0.4224.0129,87207-Nov-201120:09x86
Mngcli.exe7.0.4224.0129,36007-Nov-201120:09x86
Snadmod.dll7.0.4224.0825,16807-Nov-201120:09x86
Snaip.dll7.0.4224.0107,85607-Nov-201120:09x86
Snalm.dll7.0.4224.060,24007-Nov-201120:09x86
Snamanag.dll7.0.4224.0127,82407-Nov-201120:09x86
Microsoft Host Integration Server 2006, 64-bit Edition
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mmcsna.dll7.0.4224.0441,68007-Nov-201120:14x64
Mngagent.exe7.0.4224.0176,46407-Nov-201120:14x64
Mngcli.exe7.0.4224.0175,95207-Nov-201120:14x64
Snadmod.dll7.0.4224.01,035,08807-Nov-201120:14x64
Snaip.dll7.0.4224.0129,87207-Nov-201120:14x64
Snalm.dll7.0.4224.072,52807-Nov-201120:14x64
Snamanag.dll7.0.4224.0191,82407-Nov-201120:14x64
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about security context, visit the following Microsoft Developer Network (MSDN) website:
security context
For more information about how to establish a security context between the server and a remote client, visit the following MSDN website:
AcceptSecurityContext (Negotiate) function
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 2281720 - Last Review: February 6, 2012 - Revision: 3.0
APPLIES TO
  • Microsoft Host Integration Server 2010
  • Microsoft Host Integration Server 2006
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbbug kbexpertiseinter kbsurveynew KB2281720

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