BUG: CIS (DCOM su HTTP) interrotti in SP4 quando tunneling tramite Microsoft Proxy Server 2.0

Traduzione articoli Traduzione articoli
Identificativo articolo: 228393 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato archiviato. L?articolo, quindi, viene offerto ?così come è? e non verrà più aggiornato.
Espandi tutto | Chiudi tutto

Sintomi

Quando si utilizza Microsoft servizi Internet COM (CIS), noto anche come DCOM su HTTP, in un computer basato su Windows NT per tunnel attraverso Microsoft Proxy Server 2.0, si potrebbe visualizzato un messaggio di errore che il server RPC (Remote Procedure Call) non è disponibile.

Cause

Durante una sequenza di CONNECT HTTP, RPC invia un "CONNECT server: 80 HTTP/1.1" stringa, dove server è il nome (o l'indirizzo TCP/IP) del server proxy. Questo viene rifiutato dal proxy server 2.0 come una "richiesta non valida" perché non è una richiesta valida per HTTP 1.1. La richiesta RPC corretta dovrebbe essere: "CONNECT server: 80 HTTP/1.0", dove server è il nome (o indirizzo TCP/IP) del server proxy.

Risoluzione

Per risolvere il problema, procurarsi l'ultimo service pack per Windows NT 4.0. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
152734Come ottenere il più recente di Windows NT 4.0 Service Pack

Status

Microsoft ha confermato che questo un bug nei prodotti Microsoft elencati all'inizio di questo articolo. Questo problema è stato corretto per la prima volta nel Service Pack 5 per Windows NT 4.0.

Proprietà

Identificativo articolo: 228393 - Ultima modifica: giovedì 30 gennaio 2014 - Revisione: 3.2
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Chiavi: 
kbnosurvey kbarchive kbmt kbbug kbfaq kbpending KB228393 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 228393
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com