REVISIÓN: Tarda mucho tiempo para abrir una asignación de BizTalk en Microsoft Visual Studio 2005 si se hace referencia a los esquemas del mapa desde otro proyecto de BizTalk en BizTalk Server 2006 R2 o en BizTalk Server 2009

Seleccione idioma Seleccione idioma
Id. de artículo: 2285536 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Considere el siguiente escenario:
  • Abra un proyecto de BizTalk mediante el uso de Microsoft Visual Studio 2005 en un equipo que ejecuta Microsoft BizTalk Server 2006 R2.
  • El proyecto de BizTalk contiene una asignación de BizTalk. El esquema de origen y el esquema de destino de la asignación proceden de un proyecto independiente.
  • El proyecto independiente que contiene los esquemas se agrega como una referencia de tipo de proyecto en el proyecto de BizTalk que contenga la asignación de BizTalk. O bien, el ensamblado de la generación de desarrollo del proyecto de esquema se agrega como una referencia en el proyecto de mapa.
  • Intente abrir el mapa en Microsoft Visual Studio 2005.
En este escenario, el mapa tarda mucho tiempo en Abrir. Además, Visual Studio 2005 puede responden peor mientras se abre el mapa.

NotaEl problema no ocurre si los esquemas y el mapa que se encuentran dentro del mismo proyecto de BizTalk. Si utiliza BizTalk Server 2009, la categoría de sucesos en por encima de los eventos y el origen de eventos son "2009 de BizTalk Server".

Causa

El problema se produce debido a un error en el archivo Microsoft.BizTalk.ArtifactBrowser.dll.

Solución

Información de actualización acumulativa

BizTalk Server 2009

La revisión que resuelve este problema se incluye en el paquete de actualización acumulativa 2 para BizTalk Server 2009.

Para obtener más información acerca de cómo obtener el paquete de actualización acumulativa, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

2497794Paquete 2 de la actualización acumulativa para BizTalk Server 2009

La revisión que resuelve este problema se incluye en el paquete de actualización acumulativa 3 para BizTalk Server 2006 R2 SP1.

Para obtener más información acerca de cómo obtener el paquete de actualización acumulativa, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2286501Paquete de actualización acumulativa 3 para Service Pack 1 de BizTalk Server 2006 R2
Para obtener más información acerca de las revisiones de BizTalk Server 2006 R2 SP1, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
974563Lista de correcciones urgentes de Microsoft BizTalk Server que se incluyen en el Service Pack 1 de BizTalk Server 2006 R2
Para obtener más información acerca de las revisiones de BizTalk Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2003907Información de las revisiones de BizTalk Server

Solución

Para evitar este problema, agregue una referencia al ensamblado de generación de la implementación del proyecto de esquema en el proyecto de mapa.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de cómo probar una asignación, visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
Probar una asignación

Propiedades

Id. de artículo: 2285536 - Última revisión: viernes, 18 de marzo de 2011 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft BizTalk Server 2006 R2 Branch
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
Palabras clave: 
kbqfe kbfix kbexpertiseadvanced kbsurveynew kbbiztalk2009presp1fix kbmt KB2285536 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2285536

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com