OFF2000: Errore interno 2343 durante l'installazione

Traduzione articoli Traduzione articoli
Identificativo articolo: 228668 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo Ŕ stato precedentemente pubblicato con il codice di riferimento I228668
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si installa Office Ŕ possibile che venga visualizzato il seguente messaggio di errore:

Errore interno 2343: per ottenere assistenza tecnica, contattare il Servizio Supporto Tecnico Clienti.
seguito da:
L'installazione Ŕ stata interrotta a causa di un errore.

Cause

IMPORTANTE: in questo articolo vengono fornite informazioni relative alla modifica del Registro di configurazione. Prima di apportare modifiche al Registro di configurazione, Ŕ tuttavia fondamentale assicurarsi di sapere come ripristinarlo qualora si verifichi un problema. Per informazioni su come ripristinare il Registro di configurazione, vedere l'argomento "Ripristino del Registro di configurazione" nella Guida in linea di Regedit.exe oppure "Ripristino di una chiave di registro" nella Guida in linea di Regedt32.exe.
Tale comportamento pu˛ verificarsi per le seguenti ragioni:
  • Lotus Notes Ŕ stato disinstallato. -oppure-

  • -oppure- Lotus Notes Ŕ installato nel computer, ma nel Registro di configurazione di Windows o nel file Win.ini sono contenute voci non corrette relative a Lotus Notes.
Quando si disinstalla Lotus Notes, alcune voci nel Registro di configurazione di Windows e nel file Win.ini non vengono rimosse.

Questo problema si verifica solo se Ŕ stato disinstallato Lotus Notes oppure se Lotus Notes non Ŕ stato installato correttamente. L'installazione di Office non presenterÓ problemi se Lotus Notes Ŕ stato installato correttamente e non Ŕ stato rimosso.

Risoluzione

Come alternativa, Microsoft dispone di un programma di utilitÓ che consente di aggirare temporaneamente il problema. Per ulteriori informazioni su tale utilitÓ, vedere il seguente articolo della Microsoft Knowledge Base (informazioni in lingua inglese): ATTENZIONE: l'utilizzo scorretto dell'Editor del registro pu˛ causare seri problemi che potrebbero richiedere la reinstallazione dell'intero sistema operativo. Microsoft non pu˛ garantire che i problemi derivanti dall'utilizzo scorretto dell'Editor del registro possano essere risolti. L'Editor del registro viene pertanto utilizzato a proprio rischio e pericolo.

Per informazioni sulla modifica del Registro di configurazione, vedere l'argomento "Modifica di chiavi e valori" nella Guida in linea dell'Editor del registro (Regedit.exe) oppure "Aggiunta ed eliminazione di informazioni nel Registro di configurazione" e "Modifica dei dati del Registro di configurazione" nella Guida in linea di Regedt32.exe. Si raccomanda di eseguire una copia di backup del Registro di configurazione prima di modificarlo. Se si esegue Windows NT o Windows 2000, si consiglia di aggiornare anche il Disco di ripristino.

NOTA: potrebbe essere necessario rinominare temporaneamente il file Notes.ini una volta eseguita l'utilitÓ.

  • In Windows 95 e Windows 98 questo file si trova nella seguente cartella:
    %systemroot%\system
    dove %systemroot% Ŕ l'unitÓ e il percorso in cui Ŕ installato il sistema.
  • In Windows NT questo file si trova nella seguente cartella:
    %systemroot%\system32
    dove %systemroot% Ŕ l'unitÓ e il percorso in cui Ŕ installato il sistema.
Rinominando il file Notes.ini si rende inutilizzabile Lotus Notes. Una volta installato Office 2000, sarÓ pertanto necessario ripristinare il nome originale del file Notes.ini.

Se si sceglie di non utilizzare questa utilitÓ, sarÓ possibile utilizzare uno dei metodi descritti di seguito per aggirare temporaneamente il problema.

Metodo 1: se Lotus Notes non Ŕ installato nel computer

Il primo passo consiste nell'eliminare le restanti voci di Lotus Notes dal file Win.ini. Prima di eseguire queste operazioni, si raccomanda di fare una copia di backup del file Win.ini, che si trova nella cartella Windows.

Per modificare il file Win.ini, attenersi alla procedura seguente:
  1. Fare clic sul pulsante Start ( Avvio ) in Windows 95), quindi scegliere Esegui. Nella finestra di dialogo Esegui digitare Win.ini.
  2. Scegliere OK.
  3. Trovare la sezione [Extensions] del file Win.ini ed eliminare le seguenti voci dalla sezione:
    nsf=c:\notes\Notes.exe ^.nsf
    ns3=c:\notes\Notes.exe ^.ns3
    nsg=c:\notes\Notes.exe ^.nsg
    nsh=c:\notes\Notes.exe ^.nsh
    ns2=c:\notes\Notes.exe ^.ns2
    ntf=c:\notes\Notes.exe ^.ntf
    NOTA: se Lotus Notes era stato installato in una cartella diversa da quella predefinita (c:\notes), le voci rifletteranno il percorso di installazione di Notes.

  4. : se Lotus Notes era stato installato in una cartella diversa da quella predefinita (c:\notes), le voci rifletteranno il percorso di installazione di Notes. Trovare la sezione [LotusMail] del file Win.ini ed eliminare le seguenti voci dalla sezione:
    Application=Notes
    Program=c:\notes\Notes.exe NoDialogs
    NOTA: se Lotus Notes era stato installato in una cartella diversa da quella predefinita (c:\notes), le voci rifletteranno il percorso di installazione di Notes.

  5. : se Lotus Notes era stato installato in una cartella diversa da quella predefinita (c:\notes), le voci rifletteranno il percorso di installazione di Notes. Scegliere Salva dal menu File.
  6. : se Lotus Notes era stato installato in una cartella diversa da quella predefinita (c:\notes), le voci rifletteranno il percorso di installazione di Notes. Scegliere Esci dal menu File.
ATTENZIONE: l'utilizzo scorretto dell'Editor del registro pu˛ causare seri problemi che potrebbero richiedere la reinstallazione dell'intero sistema operativo. Microsoft non pu˛ garantire che i problemi derivanti dall'utilizzo scorretto dell'Editor del registro possano essere risolti. L'Editor del registro viene pertanto utilizzato a proprio rischio e pericolo.

Per informazioni sulla modifica del Registro di configurazione, vedere l'argomento "Modifica di chiavi e valori" nella Guida in linea dell'Editor del registro (Regedit.exe) oppure "Aggiunta ed eliminazione di informazioni nel Registro di configurazione" e "Modifica dei dati del Registro di configurazione" nella Guida in linea di Regedt32.exe. Si raccomanda di eseguire una copia di backup del Registro di configurazione prima di modificarlo. Se si esegue Windows NT o Windows 2000, si consiglia di aggiornare anche il Disco di ripristino.


Il passaggio successivo consiste nell'eliminare le chiavi di Lotus Notes dal Registro di configurazione. Per fare questo, attenersi alla seguente procedura:
  1. Chiudere tutti i programmi in esecuzione.
  2. Fare clic sul pulsante Start ( Avvio in Windows 95), scegliere Esegui e digitare regedit.
  3. Scegliere OK.
  4. Nell'Editor del registro passare alla chiave seguente:
    HKEY_CLASSES_ROOT\.nsf
    Eliminare la chiave .nsf e tutte le relative sottochiavi.

  5. Eliminare la chiave .nsf e tutte le relative sottochiavi. Ripetere il passaggio 4 per le seguenti chiavi:
    HKEY_CLASSES_ROOT\.nsh
    HKEY_CLASSES_ROOT\.ntf
    HKEY_CLASSES_ROOT\.nsg
    HKEY_CLASSES_ROOT\.ns3
    HKEY_CLASSES_ROOT\.ns2
    HKEY_CLASSES_ROOT\.ndl
    Se non si dispone di alcune delle chiavi elencate, passare a quella successiva dell'elenco.

  6. Eliminare la chiave .nsf e tutte le relative sottochiavi. Passare alla sottochiave
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes
    e verificare che non esista alcune sottochiave .nsf. Se sono presenti sottochiavi .nsf, eliminarle assieme a tutte le relative sottochiavi.
  7. Eliminare la chiave .nsf e tutte le relative sottochiavi. Ripetere il passaggio 6 per ciascuna delle seguenti sottochiavi:
    .nsh
    .ntf
    .nsg
    .ns3
    .ns2
    .ndl
    Se non si dispone di alcune delle sottochiavi elencate, passare a quella successiva dell'elenco.

  8. Eliminare la chiave .nsf e tutte le relative sottochiavi. Scegliere Esci dal menu Registro di configurazione.

Metodo 2: se Lotus Notes Ŕ attualmente installato nel computer

Il primo passo consiste nel verificare le voci di Lotus Notes presenti nel file Win.ini. Prima di eseguire queste operazioni, si raccomanda di fare una copia di backup del file Win.ini, che si trova nella cartella Windows.

Per verificare il file Win.ini, attenersi alla procedura seguente:
  1. Fare clic sul pulsante Start ( Avvio in Windows 95), quindi scegliere Esegui. Nella finestra Esegui digitare Win.ini.
  2. Scegliere OK.
  3. Trovare la sezione [Extensions] del file Win.ini e verificare i percorsi elencati nelle voci riportate di seguito:
    nsf=c:\notes\Notes.exe ^.nsf
    ns3=c:\notes\Notes.exe ^.ns3
    nsg=c:\notes\Notes.exe ^.nsg
    nsh=c:\notes\Notes.exe ^.nsh
    ns2=c:\notes\Notes.exe ^.ns2
    ntf=c:\notes\Notes.exe ^.ntf
    NOTA: se Lotus Notes era stato installato in una cartella diversa da quella predefinita (c:\notes), utilizzare il percorso di installazione di Notes.

  4. : se Lotus Notes era stato installato in una cartella diversa da quella predefinita (c:\notes), utilizzare il percorso di installazione di Notes. Trovare la sezione [LotusMail] del file Win.ini e verificare i percorsi elencati nelle voci riportate di seguito:
    Application=Notes
    Program=c:\notes\Notes.exe NoDialogs
    NOTA: se Lotus Notes era stato installato in una cartella diversa da quella predefinita (c:\notes), utilizzare il percorso di installazione di Notes.

  5. : se Lotus Notes era stato installato in una cartella diversa da quella predefinita (c:\notes), utilizzare il percorso di installazione di Notes. Scegliere Salva dal menu File.
  6. : se Lotus Notes era stato installato in una cartella diversa da quella predefinita (c:\notes), utilizzare il percorso di installazione di Notes. Scegliere Esci dal menu File.
Microsoft conferma che si tratta di un problema che riguarda solo i prodotti elencati all'inizio del presente articolo.

Il passaggio successivo consiste nel verificare le chiavi di Lotus Notes nel Registro di configurazione.
  1. Chiudere tutti i programmi in esecuzione.
  2. Fare clic sul pulsante Start ( Avvio in Windows 95), scegliere Esegui e digitare regedit.
  3. Scegliere OK.
  4. Nell'Editor del registro passare alla chiave seguente:
    HKEY_CLASSES_ROOT\.nsf\Shell\Open\Command
  5. Fare doppio clic su (Default) nella colonna Name.
  6. Verificare il percorso di Notes.exe elencato nella casella Value data. Modificare tale percorso, se necessario, quindi scegliere OK.
  7. Ripetere i passaggi da 4 a 6 per le seguenti chiavi:
    HKEY_CLASSES_ROOT\.nsh\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ntf\Shell\Open\Command
    HKEY_CLASSES_ROOT\.nsg\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ns3\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ns2\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ndl\Shell\Open\Command
    Se non si dispone di alcune delle chiavi elencate, passare a quella successiva dell'elenco.

  8. Se non si dispone di alcune delle chiavi elencate, passare a quella successiva dell'elenco. Passare alla seguente chiave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsf\Shell\Open\Command
  9. Se non si dispone di alcune delle chiavi elencate, passare a quella successiva dell'elenco. Fare doppio clic su (Default) nella colonna Name.
  10. Se non si dispone di alcune delle chiavi elencate, passare a quella successiva dell'elenco. Verificare il percorso di Notes.exe elencato nella casella Value data. Modificare tale percorso, se necessario, quindi scegliere OK.
  11. Se non si dispone di alcune delle chiavi elencate, passare a quella successiva dell'elenco. Ripetere i passaggi da 8 a 10 per ciascuna delle seguenti sottochiavi:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsh\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ntf\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsg\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ns3\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ns2\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ndl\Shell\Open\Command
    Se non si dispone di alcune delle chiavi elencate, passare a quella successiva dell'elenco.

  12. Se non si dispone di alcune delle chiavi elencate, passare a quella successiva dell'elenco. Scegliere Esci dal menu Registro.
NOTA: questo problema pu˛ essere risolto anche rinominando temporaneamente il file Notes.ini. In Windows 95 e Windows 98 il file si trova nella cartella \windows\system, mentre in Windows NT nella cartella \winnt\system32. Rinominando il file Notes.ini si rende inutilizzabile Lotus Notes, pertanto una volta installato Office 2000, sarÓ necessario ripristinare il nome originale del file Notes.ini.

Status

I prodotti di terze parti discussi in questo articolo sono realizzati da produttori indipendenti. Microsoft non fornisce pertanto alcuna garanzia, implicita o esplicita, relativa alle prestazioni o all'affidabilitÓ di tali prodotti.

Riferimenti

Per ulteriori articoli relativi alla risoluzione di errori specifici nell'installazione di Office, fare clic sul collegamento riportato di seguito:
Windows Installer Errors for Office 2000 (informazioni in lingua inglese)
Per ulteriori articolo contenenti informazioni generali sulla risoluzione degli errori di Office, fare clic sul collegamento riportato di seguito:
Troubleshooting Office 2000 (informazioni in lingua inglese)

ProprietÓ

Identificativo articolo: 228668 - Ultima modifica: martedý 17 ottobre 2006 - Revisione: 4.1
Le informazioni in questo articolo si applicano a
  • Microsoft Office 2000 Premium Edition
  • Microsoft Office 2000 Professional Edition
  • Microsoft Office 2000 Standard Edition
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Developer Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Word 2000 Standard Edition
Chiavi:á
kberrmsg xlwinsetup KB228668
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com