Recebe uma mensagem de erro "Erro interno 2343" depois de remover do Lotus Notes e, em seguida, instalar o Office 2000

Traduções de Artigos Traduções de Artigos
Artigo: 228668 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando instala o Office, poderá receber a seguinte mensagem de erro:
Erro interno 2343: Contacte o suporte técnico para assistência.
seguido de:
Instalação terminou prematuramente devido a um erro.

Causa

Este comportamento pode ocorrer pelas seguintes razões:
  • Removida (desinstalada) do Lotus Notes. - ou -

  • O Lotus Notes está instalado, mas existem entradas incorrectas para o Lotus Notes no registo do Windows ou no ficheiro Win.ini.
Quando remove o Lotus Notes, o programa de desinstalação não remove determinadas entradas no registo do Windows e o ficheiro Win.ini.

Este problema só ocorre se tiver removido do Lotus Notes ou se o Lotus Notes não estiver correctamente instalado. O Office é instalado com êxito se o sistema tiver uma instalação intacta do Lotus Notes está instalado correctamente.

Resolução

Para resolver este problema, obtenha o produto completo do Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a).

Um conjunto de CD-ROM que contém a versão completa do Microsoft Office 2000 SR-1/SR-1a pode ser encomendado um custo mínimo mais expedição e tratamento. Para encomendar este conjunto de CDs, contacte a subsidiária Microsoft (800) 360-7561. Será necessário fornecer provas da propriedade de um pacote de revenda do Microsoft Office 2000 para encomendar estes CDs.

Em alternativa, pode utilizar um dos seguintes métodos.

Método 1: Mudar o nome Notes.ini

Pode temporariamente mudar o nome do ficheiro Notes.ini para evitar esta mensagem de erro.
  • No Microsoft Windows 95, Microsoft Windows 98 ou Microsoft Windows Millennium Edition (Me), este ficheiro pode ser localizado na pasta seguinte
    %systemroot%\system
    em que %systemroot% é a unidade e caminho em que o sistema está instalado.

  • No Microsoft Windows NT 4.0, Microsoft Windows 2000 ou Microsoft Windows 2000 Professional, este ficheiro pode ser localizado na pasta seguinte
    %systemroot%\System32
    em que %systemroot% é a unidade e caminho em que o sistema está instalado.
Se o método 1 não funcionar, tente os métodos seguintes.

Nota : mudar o nome ao ficheiro Notes.ini compõe o Lotus Notes deixe de funcionar. Depois de instalar o Office 2000, não se esqueça de restaurar o ficheiro Notes.ini para o nome original.

Método 2: Transferir e executar o utilitário de erro 2343 interno

A Microsoft tem um utilitário para resolver temporariamente este problema. Para obter informações adicionais sobre este utilitário, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
234435OFF2000: Utilitário para reparar o erro interno 2343 disponíveis
Se optar por não utilizar este utilitário, pode utilizar um dos seguintes métodos para resolver temporariamente este problema.

Método 3: Se o Lotus Notes não estiver instalado

Em primeiro lugar, terá de eliminar as restantes entradas do Lotus Notes no ficheiro Win.ini. Antes de seguir estes passos, efectuar uma cópia do Win.ini ficheiro que é armazenado na pasta do Windows.

Para modificar o Win.ini ficheiro, siga estes passos:
  1. Clique em Iniciar e, em seguida, clique em Executar . Na caixa Abrir , escreva Win.ini .
  2. Clique em OK .
  3. Localize a secção [Extensions] do ficheiro Win.ini. Elimine as seguintes entradas na secção [Extensions]:
    NSF=c:\notes\Notes.exe ^ .nsf
    ns3=c:\notes\Notes.exe ^ .ns3
    nsg=c:\notes\Notes.exe ^ .nsg
    nsh=c:\notes\Notes.exe ^ .nsh
    ns2=c:\notes\Notes.exe ^ .ns2
    ntf=c:\notes\Notes.exe ^ .ntf
    Nota : Se o Lotus Notes foi instalado numa pasta diferente da predefinida (c:\notes), estas entradas reflectirão o caminho onde o Lotus Notes foi instalado.

  4. Localize a secção [LotusMail] do ficheiro Win.ini. Elimine as seguintes entradas na secção [LotusMail]:
    Aplicação = notas
    Program=c:\notes\Notes.exe NoDialogs
    Nota : Se o Lotus Notes foi instalado numa pasta diferente da predefinida (c:\notes), estas entradas reflectirão o caminho onde o Lotus Notes foi instalado.

  5. No menu ficheiro , clique em Guardar .
  6. No menu ficheiro , clique em Sair .
importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows


Também tem de eliminar as chaves do registo do Lotus Notes. Para eliminar as chaves, siga estes passos:
  1. Saia dos programas que estiverem a executar.
  2. Clique em Iniciar e, em seguida, clique em Executar . Na caixa Abrir , escreva regedit .
  3. Clique em OK .
  4. No Editor de registo (Registry Editor), navegue para a seguinte chave:
    HKEY_CLASSES_ROOT\.nsf
    Elimine a chave .nsf e todas as subchaves.

  5. Repita o passo 4 para as seguintes chaves:
    .nsh HKEY_CLASSES_ROOT\
    HKEY_CLASSES_ROOT\.ntf
    HKEY_CLASSES_ROOT\.nsg
    HKEY_CLASSES_ROOT\.ns3
    HKEY_CLASSES_ROOT\.ns2
    HKEY_CLASSES_ROOT\.NDL
    Se não tiver qualquer uma destas chaves, ignore essa chave.

  6. Navegue para a seguinte chave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes
    Verifique não se existe nenhuma chave .nsf. Se um, elimine- e todas as subchaves.
  7. Repita o passo 6 para cada uma das seguintes chaves:
    .nsh
    .ntf
    .nsg
    .ns3
    .ns2
    .NDL
    Se não tiver qualquer uma destas chaves, ignore essa chave.

  8. No menu registo , clique em Sair .

Método 4: Se o Lotus Notes actualmente está instalado

Em primeiro lugar, tem de verificar as entradas do Lotus Notes o Win.ini ficheiro. Antes de seguir estes passos, efectue uma cópia do ficheiro Win.ini armazenado na pasta do Windows.

Para verificar as entradas no ficheiro Win.ini, siga estes passos:
  1. Clique em Iniciar e, em seguida, clique em Executar . Na caixa Abrir , escreva Win.ini .
  2. Clique em OK .
  3. Localize a secção [Extensions] do ficheiro Win.ini. Verifique se os caminhos listados nas seguintes entradas na secção [Extensions]:
    NSF=c:\notes\Notes.exe ^ .nsf
    ns3=c:\notes\Notes.exe ^ .ns3
    nsg=c:\notes\Notes.exe ^ .nsg
    nsh=c:\notes\Notes.exe ^ .nsh
    ns2=c:\notes\Notes.exe ^ .ns2
    ntf=c:\notes\Notes.exe ^ .ntf
    Nota : Se o Lotus Notes foi instalado numa pasta diferente da predefinida (c:\notes), utilize o caminho em que o Lotus Notes está instalado.

  4. Localize a secção [LotusMail] do ficheiro Win.ini. Verifique se os caminhos listados nas seguintes entradas na secção [LotusMail]:
    Aplicação = notas
    Program=c:\notes\Notes.exe NoDialogs
    Nota : Se o Lotus Notes foi instalado numa pasta diferente da predefinida (c:\notes), utilize o caminho em que o Lotus Notes está instalado.

  5. No menu ficheiro , clique em Guardar .
  6. No menu ficheiro , clique em Sair .
importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows


Também tem de verificar as chaves do Lotus Notes no registo.
  1. Saia dos programas que estiverem a executar.
  2. Clique em Iniciar e clique em Executar . Na caixa Abrir , escreva regedit .
  3. Clique em OK .
  4. No Editor de registo (Registry Editor), navegue para a seguinte chave:
    HKEY_CLASSES_ROOT\.nsf\Shell\Open\Command
  5. Faça duplo clique (predefinição) na coluna Nome .
  6. Verifique se que o caminho para Notes.exe listado na caixa dados do valor . Alterar o caminho se necessário e, em seguida, clique em OK .
  7. Repita os passos 4 a 6 para as seguintes chaves:
    HKEY_CLASSES_ROOT\.nsh\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ntf\Shell\Open\Command
    HKEY_CLASSES_ROOT\.nsg\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ns3\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ns2\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ndl\Shell\Open\Command
    Se não tiver qualquer uma destas chaves, ignore essa chave.

  8. Navegue para a seguinte chave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsf\Shell\Open\Command
  9. Faça duplo clique (predefinição) na coluna Nome .
  10. Verifique se que o caminho para Notes.exe listado na caixa dados do valor . Alterar o caminho se necessário e, em seguida, clique em OK .
  11. Repita os passos 8 a 10 para cada uma das seguintes chaves:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsh\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ntf\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsg\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ns3\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ns2\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ndl\Shell\Open\Command
    Se não tiver qualquer uma destas chaves, ignore essa chave.

  12. No menu registo , clique em Sair .
Nota : este problema também pode ser resolvido mudando temporariamente o ficheiro Notes.ini. No Windows 95 e Windows 98, este ficheiro está localizado na pasta \windows\system. No Windows NT, este ficheiro está localizado na pasta \winnt\system32. Tenha em atenção que mudar o nome do ficheiro Notes.ini compõe Lotus Notes deixe de funcionar. Depois de instalar o Office 2000, não se esqueça de restaurar o ficheiro Notes.ini para o nome original.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no início deste artigo. Este problema foi corrigido no Microsoft Office 2000 SR-1/SR-1a.

Mais Informação

Os produtos de outros fabricantes que são discutidos neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não oferece nenhuma garantia, expressa ou implícita, relativamente ao desempenho ou fiabilidade destes produtos.

Referências

Para obter mais artigos sobre como resolver erros específicos no programa de configuração do Office:
Click here to view a list of Windows Installer Errors for Office 2000 articles
Para obter mais artigos com informações gerais sobre como resolver erros do Office:
Click here to view a list of Office 2000 Troubleshooting articles

Propriedades

Artigo: 228668 - Última revisão: 24 de janeiro de 2007 - Revisão: 4.3
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Office 2000 Premium Edition
  • Microsoft Office 2000 Professional Edition
  • Microsoft Office 2000 Standard Edition
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Developer Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2000
Palavras-chave: 
kbmt kbtshoot kbprb kberrmsg kbpending kbsetup KB228668 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 228668

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com