OFF2000: Erro Interno 2343 Durante a Instalação

Traduções deste artigo Traduções deste artigo
ID do artigo: 228668 - Exibir os produtos aos quais esse artigo se aplica.
IMPORTANTE: Este artigo contém informações sobre como modificar o registro. Antes de modificar o registro, certifique-se de ter um backup e de saber como restaurar o registro caso ocorra algum problema. Para obter informações sobre como fazer backup, restaurar e editar o registro, clique no número abaixo para consultar o artigo na Base de Dados de Conhecimento da Microsoft:
256986 Descrição do Registro do Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Ao instalar o Office, você pode receber a seguinte mensagem de erro:
Erro Interno 2343: Por favor contate o suporte do produto para obter assistência.
seguido por:
A instalação foi finalizada prematuramente devido a um erro.

Causa

Este comportamento pode ocorrer devido às seguintes razões:
  • Você removeu (desinstalou) o Lotus Notes. -ou-

  • O Lotus Notes está instalado, mas há entradas incorretas para ele no registro do Windows ou no arquivo Win.ini.
Ao remover o Lotus Notes, o programa de desinstalação não remove certas entradas do registro do Windows e do arquivo Win.ini.

Esse problema apenas ocorre se você removeu o Lotus Notes ou se ele não estiver instalado corretamente. O Office é instalado com êxito se o sistema tiver uma instalação intacta do Lotus Notes que esteja instalada corretamente.

Resolução

Para resolver esse problema, obtenha o produto completo Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a).

Um CD-ROM que contém a versão completa do Microsoft Office 2000 SR-1/SR-1a pode ser pedido com um valores mínimos de manuseio e envio. Para pedi-lo, ligue para a Microsoft Order Desk em (800) 360-7561. Você precisará fornecer informações que comprovem a sua propriedade em relação ao pacote de varejo do Microsoft Office 2000 para poder pedir esses CDs.

Para fazer isso, você pode usar um dos seguintes métodos.

Método 1: Renomear Notes.ini

Você pode renomear temporariamente o arquivo Notes.ini a fim de evitar essa mensagem de erro.
  • No Microsoft Windows 95, Microsoft Windows 98 ou Microsoft Windows Millennium Edition (Me), esse arquivo pode estar na seguinte pasta
    %systemroot%\system
    , em que%systemroot% é a unidade e o caminho em que o sistema está instalado.

  • No Microsoft Windows NT 4.0, Microsoft Windows 2000 ou Microsoft Windows 2000 Professional, esse arquivo pode estar na seguinte pasta
    %systemroot%\system32
    em que%systemroot% é a unidade e o caminho em que o sistema está instalado.
Se o Método 1 não funcionar, tente os seguintes métodos.

NOTA: Renomear o arquivo Notes.ini torna o Lotus Notes inoperante. Após instalar o Office 2000, certifique-se de restaurar o nome original do arquivo Notes.ini.

Método 2: Faça o Download do Utilitário do Erro Interno 2343 e Instale-o

A Microsoft tem um utilitário que soluciona esse problema temporariamente. Para obter mais informações sobre ele, clique no número abaixo para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:
234435 OFF2000: Utility to Repair Internal Error 2343
Se optar por não usar esse utilitário, você poderá usar um dos métodos a seguir para solucionar temporariamente esse problema.

Método 3: Se o Lotus Notes Não Estiver Instalado

Primeiro, você deve excluir as entradas remanescentes do Lotus Notes no arquivo Win.ini. Antes de seguir estes passos, crie uma cópia de backup do arquivo Win.ini armazenado na pasta Windows.

Para modificar o arquivo Win.ini, siga estes passos:
  1. Clique em Iniciar e em Executar. Na caixa Abrir, digite Win.ini.
  2. Clique em OK.
  3. Localize a seção [Extensions] no arquivo Win.ini. Exclua as seguintes entradas nessa seção:
    nsf=c:\notes\Notes.exe ^.nsf
    ns3=c:\notes\Notes.exe ^.ns3
    nsg=c:\notes\Notes.exe ^.nsg
    nsh=c:\notes\Notes.exe ^.nsh
    ns2=c:\notes\Notes.exe ^.ns2
    ntf=c:\notes\Notes.exe ^.ntf
    NOTA: Se o Lotus Notes estava instalado em uma pasta diferente da padrão (c:\notes), essas entradas refletirão o caminho onde o Lotus Notes estava instalado.

  4. Localize a seção [LotusMail] no arquivo Win.ini. Exclua as seguintes entradas nessa seção:
    Application=Notes
    Program=c:\notes\Notes.exe NoDialogs
    NOTA: Se o Lotus Notes estava instalado em uma pasta diferente da padrão (c:\notes), essas entradas refletirão o caminho onde o Lotus Notes estava instalado.

  5. No menu Arquivo, clique em Salvar.
  6. No menu Arquivo, clique em Sair.
ATENÇÃO: Se usar o Editor do Registro incorretamente, você pode causar problemas graves que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você conseguirá solucionar os problemas resultantes do uso incorreto do Editor do Registro. Use o Editor do Registro por sua conta e risco.


Você deve também excluir as chaves do Lotus Notes no registro. Para excluí-las, siga estes passos:
  1. Feche todos os programas em execução.
  2. Clique em Iniciar e em Executar. Na caixaAbrir, digite regedit.
  3. Clique em OK.
  4. No Editor do Registro, vá até a seguinte chave:
    HKEY_CLASSES_ROOT\.nsf
    Exclua a chave .nsf e todas as suas subchaves.

  5. Repita o passo 4 para as seguintes chaves:
    HKEY_CLASSES_ROOT\.nsh
    HKEY_CLASSES_ROOT\.ntf
    HKEY_CLASSES_ROOT\.nsg
    HKEY_CLASSES_ROOT\.ns3
    HKEY_CLASSES_ROOT\.ns2
    HKEY_CLASSES_ROOT\.ndl
    Se não existir nenhuma dessas chaves, pule essa chave.

  6. Navegue para a seguinte chave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes
    Verifique se há alguma chave .nsf. Se houver, exclua-a, excluindo também todas as suas subchaves.
  7. Repita o passo 6 para cada uma das seguintes chaves:
    .nsh
    .ntf
    .nsg
    .ns3
    .ns2
    .ndl
    Se não existir nenhuma dessas chaves, pule essa chave.

  8. No menu Registro, clique em Sair.

Método 4: Se o Lotus Notes Estiver Instalado

Primeiro, você deve verificar as entradas do Lotus Notes no arquivo Win.ini. Antes de seguir estes passos, crie uma cópia de backup do arquivo Win.ini armazenado na pasta Windows.

Para modificar as entradas no arquivo Win.ini, siga estes passos:
  1. Clique em Iniciar e em Executar. Na caixa Abrir, digite Win.ini.
  2. Clique em OK.
  3. Localize a seção [Extensions] no arquivo Win.ini. Verifique os caminhos listados nas seguintes entradas na seção [Extensions]:
    nsf=c:\notes\Notes.exe ^.nsf
    ns3=c:\notes\Notes.exe ^.ns3
    nsg=c:\notes\Notes.exe ^.nsg
    nsh=c:\notes\Notes.exe ^.nsh
    ns2=c:\notes\Notes.exe ^.ns2
    ntf=c:\notes\Notes.exe ^.ntf
    NOTA: Se o Lotus Notes estava instalado em uma pasta diferente da padrão (c:\notes), use o caminho onde o Lotus Notes estava instalado.

  4. Localize a seção [LotusMail] no arquivo Win.ini. Verifique os caminhos listados nas seguintes entradas na seção [LotusMail]:
    Application=Notes
    Program=c:\notes\Notes.exe NoDialogs
    NOTA: Se o Lotus Notes estava instalado em uma pasta diferente da padrão (c:\notes), use o caminho onde o Lotus Notes estava instalado.

  5. No menu Arquivo, clique em Salvar.
  6. No menu Arquivo, clique em Sair.
ATENÇÃO: Se usar o Editor do Registro incorretamente, você pode causar problemas graves que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você conseguirá solucionar os problemas resultantes do uso incorreto do Editor do Registro. Use o Editor do Registro por sua conta e risco.


Você deve também verificar as chaves do Lotus Notes no registro.
  1. Feche todos os programas em execução.
  2. Clique em Iniciar e depois em Executar. Na caixaAbrir, digite regedit.
  3. Clique em OK.
  4. No Editor do Registro, vá até a seguinte chave:
    HKEY_CLASSES_ROOT\.nsf\Shell\Open\Command
  5. Clique duas vezes em (Padrão) na coluna Nome.
  6. Verifique o caminho para Notes.exe que aparece na caixa Dados do valor. Altere o caminho se necessário e clique em OK.
  7. Repita os passos 4 a 6 para as seguintes chaves:
    HKEY_CLASSES_ROOT\.nsh\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ntf\Shell\Open\Command
    HKEY_CLASSES_ROOT\.nsg\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ns3\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ns2\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ndl\Shell\Open\Command
    Se não existir nenhuma dessas chaves, pule essa chave.

  8. Navegue para a seguinte chave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsf\Shell\Open\Command
  9. Clique duas vezes em (Padrão) na coluna Nome.
  10. Verifique o caminho para Notes.exe que aparece na caixa Dados do valor. Altere o caminho se necessário e clique em OK.
  11. Repita os passos 8 a 10 para cada uma das seguintes chaves:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsh\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ntf\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsg\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ns3\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ns2\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ndl\Shell\Open\Command
    Se não existir nenhuma dessas chaves, pule essa chave.

  12. No menu Registro, clique em Sair.
NOTA: Esse problema pode também ser resolvido renomeando-se temporariamente o arquivo Notes.ini. No Windows 95 e no Windows 98, esse arquivo está na pasta \windows\system. No Windows NT, esse arquivo está na pasta \winnt\system32. Observe que a renomeação do arquivo Notes.ini torna o Lotus Notes inoperante. Após instalar o Office 2000, certifique-se de restaurar o nome original do arquivo Notes.ini.

Situação

A Microsoft informa que este problema pode ocorre em seu(s) produto(s) listado(s) na secção "Aplica-se" deste artigo. Esse problema foi corrigido no Microsoft Office 2000 SR-1/SR-1a.

Mais Informações

Os produtos de terceiros mencionados neste artigo são produzidos por empresas independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.

Referências

Para mais artigos sobre como solucionar problemas de erros específicos na instalação do Office:
Clique aqui para visualizar a lista de Erros do Windows Installer para os artigos Office 2000
Para obter mais artigos com informações gerais sobre como solucionar problemas de erros do Office:
Clique aqui para visualizar uma lista de artigos de Solução de Problemas do Office 2000

Propriedades

ID do artigo: 228668 - Última revisão: terça-feira, 17 de outubro de 2006 - Revisão: 5.1
A informação contida neste artigo aplica-se a:
  • Microsoft Office 2000 Premium Edition
  • Microsoft Office 2000 Professional Edition
  • Microsoft Office 2000 Standard Edition
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Developer Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Word 2000 Standard Edition
Palavras-chave: 
kbbug kberrmsg kbpending kbsetup KB228668

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com