在删除 Lotus Notes 然后安装 Office 2000 时收到错误消息“Internal Error 2343”(内部错误 2343)

文章翻译 文章翻译
文章编号: 228668 - 查看本文应用于的产品
本文的发布号曾为 CHS228668
重要说明:本文包含有关修改注册表的信息。修改注册表之前,一定要先备份注册表,并且一定要知道在发生问题时如何还原注册表。有关如何备份、还原和编辑注册表的信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
256986 Microsoft Windows 注册表说明
展开全部 | 关闭全部

本文内容

症状

当您安装 Office 时,您可能会收到以下错误消息:
Internal Error 2343: Please contact product support for assistance.
后面是:
Installation ended prematurely because of an error.

原因

发生这种现象的原因有下面几个:
  • 删除(卸载)了 Lotus Notes。- 或 -

  • 已安装 Lotus Notes,但在 Windows 注册表或 Win.ini 文件中有不正确的 Lotus Notes 项。
在删除 Lotus Notes 时,卸载程序没有删除它在 Windows 注册表和 Win.ini 文件中的某些项。

仅当您删除了 Lotus Notes 或没有正确安装 Lotus Notes 时,才会发生此问题。如果系统中有完整无缺且正确安装的 Lotus Notes,则会成功地安装 Office。

解决方案

要解决此问题,请获得 Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a) 的完整产品。

您可以最低价(另加运费和手续费)订购包含 Microsoft Office 2000 SR-1/SR-1a 完整版的 CD-ROM 集。要订购此 CD 集,请与 Microsoft 订购部门联系 (800) 360-7561。您需要提供 Microsoft Office 2000 零售包的所有权证明才能订购这些 CD。

或者,您可以使用以下方法之一。

方法 1:重命名 Notes.ini

可暂时重命名 Notes.ini 文件以避免出现此错误消息。
  • 在 Microsoft Windows 95、Microsoft Windows 98 或 Microsoft Windows Millennium Edition (Me) 中,此文件可能位于以下文件夹中:
    %systemroot%\system
    其中,%systemroot% 是您安装系统的驱动器和路径。

  • 在 Microsoft Windows NT 4.0、Microsoft Windows 2000 或 Microsoft Windows 2000 Professional 中,此文件可能位于以下文件夹中:
    %systemroot%\system32
    其中,%systemroot% 是您安装系统的驱动器和路径。
如果方法 1 不能解决问题,请尝试使用以下方法。

注意:重命名 Notes.ini 文件,将导致 Lotus Notes 无法运行。安装 Office 2000 后,一定要将 Notes.ini 文件恢复其原始文件名。

方法 2:下载并运行内部错误 2343 实用程序

Microsoft 提供了一个可暂时解决此问题的实用程序。 有关此实用程序的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
234435 OFF2000:修复内部错误 2343 的实用程序可用
如果您选择不使用此实用程序,则可以使用以下两种方法之一来暂时解决此问题。

方法 3:如果未安装 Lotus Notes

首先,必须删除 Win.ini 文件中剩余的 Lotus Notes 项。执行这些步骤之前,先为 Windows 文件夹中存储的 Win.ini 文件创建备份副本。

要修改 Win.ini 文件,请按照下列步骤操作:
  1. 单击“开始”,然后单击“运行”。在“打开”框中,键入 Win.ini
  2. 单击“确定”。
  3. 定位到 Win.ini 文件中的 [Extensions] 节。删除 [Extensions] 节中的以下项:
    nsf=c:\notes\Notes.exe ^.nsf
    ns3=c:\notes\Notes.exe ^.ns3
    nsg=c:\notes\Notes.exe ^.nsg
    nsh=c:\notes\Notes.exe ^.nsh
    ns2=c:\notes\Notes.exe ^.ns2
    ntf=c:\notes\Notes.exe ^.ntf
    注意:如果 Lotus Notes 没有安装在默认文件夹 (c:\notes) 中,这些项将反映 Lotus Notes 的安装路径。

  4. 定位到 Win.ini 文件中的 [LotusMail] 节。删除 [LotusMail] 节中的以下项:
    Application=Notes
    Program=c:\notes\Notes.exe NoDialogs
    注意:如果 Lotus Notes 没有安装在默认文件夹 (c:\notes) 中,这些项将反映 Lotus Notes 的安装路径。

  5. 在“文件”菜单上,单击“保存”。
  6. 在“文件”菜单上,单击“退出”。
警告:注册表编辑器使用不当可导致严重问题,可能需要重新安装操作系统。Microsoft 不能保证您可以解决因注册表编辑器使用不当而导致的问题。使用注册表编辑器需要您自担风险。


还必须删除注册表中的 Lotus Notes 项。要删除这些项,请按照下列步骤操作:
  1. 退出正在运行的所有程序。
  2. 单击“开始”,然后单击“运行”。在“打开”框中,键入 regedit
  3. 单击“确定”。
  4. 在注册表编辑器中,导航到以下项:
    HKEY_CLASSES_ROOT\.nsf
    删除 .nsf 项及其所有子项。

  5. 对于以下项,请重复步骤 4:
    HKEY_CLASSES_ROOT\.nsh
    HKEY_CLASSES_ROOT\.ntf
    HKEY_CLASSES_ROOT\.nsg
    HKEY_CLASSES_ROOT\.ns3
    HKEY_CLASSES_ROOT\.ns2
    HKEY_CLASSES_ROOT\.ndl
    如果您不具有这些项中的任何一项,则可以跳过该项。

  6. 导航到以下项:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes
    验证是否已不存在 .nsf 项。如果存在,则删除该项及其所有子项。
  7. 对于以下各项,请重复步骤 6:
    .nsh
    .ntf
    .nsg
    .ns3
    .ns2
    .ndl
    如果您不具有这些项中的任何一项,则可以跳过该项。

  8. 在“注册表”菜单上,单击“退出”。

方法 4:如果当前安装了 Lotus Notes

首先,必须验证 Win.ini 文件中的 Lotus Notes 项。执行这些步骤之前,先为 Windows 文件夹中存储的 Win.ini 文件创建备份副本。

要验证 Win.ini 文件中的项,请按照下列步骤操作:
  1. 单击“开始”,然后单击“运行”。在“打开”框中,键入 Win.ini
  2. 单击“确定”。
  3. 定位到 Win.ini 文件中的 [Extensions] 节。检查在 [Extensions] 节的以下项中列出的路径:
    nsf=c:\notes\Notes.exe ^.nsf
    ns3=c:\notes\Notes.exe ^.ns3
    nsg=c:\notes\Notes.exe ^.nsg
    nsh=c:\notes\Notes.exe ^.nsh
    ns2=c:\notes\Notes.exe ^.ns2
    ntf=c:\notes\Notes.exe ^.ntf
    注意:如果 Lotus Notes 没有安装在默认文件夹 (c:\notes) 中,则使用 Lotus Notes 的安装路径。

  4. 定位到 Win.ini 文件中的 [LotusMail] 节。检查在 [LotusMail] 节的以下项中列出的路径:
    Application=Notes
    Program=c:\notes\Notes.exe NoDialogs
    注意:如果 Lotus Notes 没有安装在默认文件夹 (c:\notes) 中,则使用 Lotus Notes 的安装路径。

  5. 在“文件”菜单上,单击“保存”。
  6. 在“文件”菜单上,单击“退出”。
警告:注册表编辑器使用不当可导致严重问题,可能需要重新安装操作系统。Microsoft 不能保证您可以解决因注册表编辑器使用不当而导致的问题。使用注册表编辑器需要您自担风险。


还必须验证注册表中的 Lotus Notes 项。
  1. 退出正在运行的所有程序。
  2. 单击“开始”,然后单击“运行”。在“打开”框中,键入 regedit
  3. 单击“确定”。
  4. 在注册表编辑器中,导航到以下项:
    HKEY_CLASSES_ROOT\.nsf\Shell\Open\Command
  5. 双击“名称”列中的“(默认)”。
  6. 验证 Notes.exe 的路径是否列出在“数值数据”框中。如有必要,请更改路径,然后单击“确定”。
  7. 对于以下各项,请重复步骤 4 至步骤 6:
    HKEY_CLASSES_ROOT\.nsh\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ntf\Shell\Open\Command
    HKEY_CLASSES_ROOT\.nsg\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ns3\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ns2\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ndl\Shell\Open\Command
    如果您不具有这些项中的任何一项,则可以跳过该项。

  8. 导航到以下项:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsf\Shell\Open\Command
  9. 双击“名称”列中的“(默认)”。
  10. 验证 Notes.exe 的路径是否列出在“数值数据”框中。如有必要,请更改路径,然后单击“确定”。
  11. 对于以下项中的每一项,请重复步骤 8 至步骤 10:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsh\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ntf\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsg\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ns3\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ns2\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ndl\Shell\Open\Command
    如果您不具有这些项中的任何一项,则可以跳过该项。

  12. 在“注册表”菜单上,单击“退出”。
注意:通过临时重命名 Notes.ini 文件,也可以解决此问题。在 Windows 95 和 Windows 98 中,此文件位于 \windows\system 文件夹中。在 Windows NT 中,此文件位于 \winnt\system32 文件夹中。请注意,重命名 Notes.ini 文件会导致 Lotus Notes 无法运行。安装 Office 2000 后,一定要将 Notes.ini 文件恢复其原始文件名。

状态

Microsoft 已经确认这是在本文开头列出的 Microsoft 产品中存在的问题。 此问题已在 Microsoft Office 2000 SR-1/SR-1a 中得到更正。

更多信息

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。对于这些产品的性能或可靠性,Microsoft 不作任何暗示保证或其他形式的保证。

参考

更多有关 Office 安装程序中特定错误疑难解答的文章:
单击此处可查看用于 Office 2000 的 Windows 安装程序错误文章列表
更多包含有关 Office 错误疑难解答的一般信息的文章:
单击此处可查看 Office 2000 疑难解答文章列表

属性

文章编号: 228668 - 最后修改: 2006年10月17日 - 修订: 4.1
这篇文章中的信息适用于:
  • Microsoft Office 2000 优惠版
  • Microsoft Office 2000 中文专业版
  • Microsoft Office 2000 标准版
  • Microsoft Office 2000 中小企业版
  • Microsoft Office 2000 Developer Edition
  • Microsoft Access 2000 标准版
  • Microsoft Excel 2000 标准版
  • Microsoft FrontPage 2000 标准版
  • Microsoft Outlook 2000 标准版
  • Microsoft PowerPoint 2000 标准版
  • Microsoft Word 2000 标准版
关键字:?
kberrmsg kbtshoot kbsetup kbprb kbpending KB228668
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com