Risoluzione dell'errore "STOP 0x00000077" o "KERNEL_STACK_INPAGE_ERROR"

Traduzione articoli Traduzione articoli
Identificativo articolo: 228753 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si esegue Windows, potrebbe essere visualizzato uno dei seguenti messaggi di errore:
  • Stop 0x00000077
    KERNEL_STACK_INPAGE_ERROR
In questo articolo viene descritto come risolvere i problemi relativi a questi messaggi di errore.

Cause

Questo problema può verificarsi se è stata richiesta una pagina di dati del kernel che non può essere letta in memoria dal file di paging o se il record di avvio principale è stato infettato da un virus. Per individuare la possibile causa è necessario interpretare correttamente il messaggio di errore. Se il primo e il terzo parametro sono uguali a zero, i quattro parametri sono definiti come segue:
  1. 0 (zero)
  2. Valore PTE (Page Table Entry, voce della tabella pagine) al verificarsi dell'errore
  3. 0 (zero)
  4. Indirizzo dell'identificativo nello stack del kernel
Se il primo o il terzo parametro non è uguale a zero, si applicano le seguenti definizioni:
  1. Codice di stato
  2. Codice di stato I/O
  3. Numero del file di paging
  4. Offset nel file di paging
In questo caso, la causa del problema può essere individuata in base al secondo parametro (codice di stato I/O) utilizzando le informazioni seguenti elencate nel formato "valore del secondo parametro" seguito da "causa generale":

0xC000000E o STATUS_NO_SUCH_DEVICE: l'unità è divenuta indisponibile, forse per un errore del disco rigido, dell'array di dischi e/o della scheda del controller.

0xC000009A o STATUS_INSUFFICIENT_RESOURCES: risorse della riserva non di paging insufficienti.

0xC000009C o STATUS_DEVICE_DATA_ERROR: blocchi danneggiati sul disco rigido.

0xC000009D o STATUS_DEVICE_NOT_CONNECTED: cavi o collegamenti difettosi, terminazione mancante o controller non in grado di ottenere l'accesso al disco rigido.

0xC000016A o STATUS_DISK_OPERATION_FAILED: blocchi danneggiati sul disco rigido.

0xC0000185 o STATUS_IO_DEVICE_ERROR: errore di terminazione o cavi o collegamenti difettosi di periferiche SCSI o tentativo di utilizzare lo stesso IRQ da parte di due periferiche.

Risoluzione

Per risolvere il problema, utilizzare il metodo appropriato:

Virus del settore di avvio

Per verificare l'eventuale presenza di un virus del settore di avvio, eseguire un programma antivirus aggiornato e, se necessario, eliminare il virus dal computer.

Causa diversa da un virus del settore di avvio

Esaminare il registro eventi di sistema nel Visualizzatore eventi per verificare l'eventuale presenza di ulteriori messaggi di errore che consentano di determinare la periferica che causa l'errore.

Blocco danneggiato. L'errore irreversibile 0x77 è causato dalla presenza di un blocco danneggiato in un file di paging, da un errore del controller del disco o, in casi estremamente rari, dall'insufficienza di risorse della riserva non di paging.

Se il primo e il secondo parametro sono uguali a zero, significa che nello stack del kernel non è stato trovato l'identificativo dello stack. Questo problema è causato da hardware difettoso. Se il codice di stato I/O è C0000185 e il file di paging è su un disco rigido SCSI, verificare cavi e collegamenti del disco e la terminazione SCSI.

Invece, un codice di stato I/O 0xC000009C o 0xC000016A indica, in genere, che non è stato possibile leggere i dati dal disco a causa di un blocco danneggiato.

Se è possibile riavviare il computer dopo la visualizzazione del messaggio di errore, verrà eseguito automaticamente Autochk per tentare di rilevare i settori danneggiati. Se per qualche motivo non viene eseguita l'analisi Autochk del disco rigido per la rilevazione degli errori, avviare l'analizzatore del disco manualmente. Se il computer è formattato con il file system NTFS, eseguire Chkdsk /f /r sulla partizione di sistema. Riavviare il computer prima di iniziare l'analisi. Se non è possibile avviare il computer a causa del problema stesso, utilizzare la console dei comandi ed eseguire Chkdsk /r.

Un'altra causa comune di questo problema è lo stato difettoso o inaffidabile della memoria RAM (Random Access Memory).

Verificare che tutte le schede siano correttamente inserite nel computer.

Verificare che tutti i contatti delle schede siano puliti.

Provare a risolvere l'errore disattivando la cache di sistema del BIOS.

Se il problema persiste, è possibile che la scheda madre del computer sia danneggiata.

Per ulteriori informazioni sugli argomenti correlati, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
130801 Cause comuni dei messaggi di errore irreversibile 0x00000077 e 0x0000007A

Proprietà

Identificativo articolo: 228753 - Ultima modifica: venerdì 3 marzo 2006 - Revisione: 2.2
Le informazioni in questo articolo si applicano a
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Chiavi: 
kbenv kberrmsg kbprb kbui KB228753
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com