ID do artigo: 228985 - Última revisão: sexta-feira, 19 de janeiro de 2007 - Revisão: 36.3

Mensagem de erro ou o jogo pára de responder na tela "Carregando" ao iniciar um jogo da Microsoft: "Insira o CD-ROM correto"

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Este artigo foi publicado anteriormente em BR228985

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Ao tentar iniciar um dos programas listados na seção "Aplica-se a", você talvez enfrente um dos seguintes sintomas quando a mensagem "Carregando" ou "Aguarde enquanto o CD donome_do_programa é verificado" são exibidas na tela:
  • O programa pode parar de responder (travar).
  • O jogo pode fechar e você retorna à área de trabalho.
  • Uma das seguintes mensagens de erro pode ser exibida:
    Insira o CD-ROM correto, clique em OK e reinicie o aplicativo.
    nome_do_programa causou uma falha de página inválida no módulonome_do_programa.icd
    nome_do_programa causou uma falha de página inválida no módulo dplayerx.dll
    IRQL_NOT_LESS_OR_EQUAL, ADDRESS 8000741A tem base em 80001000 - hal.dll
    nome_do_programa causou um erro em ~DF394B.tmp
    Rukshuk causou uma falha de página inválida no módulo rukshuk.exe
    EMPIRES2 causou uma falha de página inválida em Empires2.exe
    Clokspl causou uma falha de página inválida no módulo Clokspl.exe.
    Não é possível localizar o CD-ROM. Insira o Disco 4 do FS2004, selecione OK e reinicie o aplicativo.
    Nome_do_jogo encontrou um problema e precisa ser fechado. Lamentamos o inconveniente.
    Ao clicar no link da caixa de diálogo, a seguinte assinatura de erro será exibida:
    Appname:program.icd, appver:x.x.x.xxx, modname: program.icd
Além disso, caso tente instalar um dos jogos listados na seção "Aplica-se a", uma das seguintes mensagens de erro pode ser exibida:
Falha ao verificar a mídia. Instalação cancelada.
Falha de autenticação da mídia.

Causa

O problema pode ocorrer se uma das seguintes condições for verdadeira:
  • Você não está usando o disco do jogo para iniciar o programa.
  • A unidade de CD não é compatível com o programa.
  • Você está usando uma cópia do CD do programa.
  • Você não está conectado ao computador como Administrador.
  • O programa ou os programas estão interferindo no início do jogo que está sendo executado, mas estão invisíveis para você.
  • Você está executando uma conta do Microsoft Windows XP Home que usa a "troca rápida de usuário".
  • A unidade de CD está usando drivers desatualizados.
Observação O problema ocorre nos computadores executando o Microsoft Windows XP Home e o Microsoft Windows XP Professional. Quando ocorre em um computador com o Windows XP Professional, este problema não ocorre por conta de uma "troca rápida de usuário", mas devido a uma das outras condições relacionadas anteriormente.

Resolução

Método 1: limpar o disco

Limpe o CD ou o DVD. Para fazer isto, use um kit de limpeza de disco. Ou, gentilmente, passe um pano de algodão macio no lado prateado do disco. Não use toalha de papel. Ela pode arranhar o plástico e deixar riscos. Ao limpar o disco, limpe-o do centro para fora. Não faça movimentos circulares. Se o problema continuar ocorrendo, limpe o disco com um pano ou uma solução de limpeza de CD ou DVD comercial. Seque-o totalmente antes de inseri-lo na unidade. Se o problema persistir, vá para o próximo método.

Método 2: verificar se o CD do jogo está na unidade de CD

Verifique se o disco do jogo está na unidade de CD. Insira o disco original do jogo na unidade de CD e reinicie o programa.
  • Microsoft Combat Flight Simulator 2:

    Se estiver jogando o Combat Flight Simulator 2, use o CD número 2.
  • Microsoft Mech Warrior 4: Inner Sphere Mech Pak:

    Caso esteja tentando jogar o Mech Warrior 4: Inner Sphere Mech Pak, insira o disco do Mech Warrior Vengeance 4 (disco 1) ou do Black Knight, antes de iniciar o jogo.
  • Microsoft Flight Simulator 2004: A Century of Flight

    Se estiver tentando jogar o Flight Simulator 2004: A Century of Flight, insira o disco 4.
  • Microsoft Zoo Tycoon: Complete Collection

    Se estiver tentando jogar o Zoo Tycoon: Complete Collection, insira o disco 2.
Se o problema continuar, vá para o próximo método.

Método 3: instalar atualizações do SafeDisc

Para ver se você precisa das atualizações instaladas, execute as seguintes etapas:
  1. Insira o disco do jogo.
  2. Clique em Iniciar, em Executar, digite cmd e clique em OK.
  3. Digite a letra do CD e dois pontos, e pressione ENTER.

    Por exemplo, na maioria dos computadores, a letra da unidade de CD será D. Por isso você digitará D: e pressionará ENTER.
  4. Digite dir /a:h e pressione ENTER.
Isso exibirá todos os arquivos ocultos no disco. Caso haja um arquivo chamado "SSIFSDAT.SYS", não será necessário ter as atualizações instaladas para o jogo que está usando. No entanto, a instalação delas pode ajudar em outros jogos.

Correção do SafeDisc Windows XP para jogos da Microsoft

Caso esteja usando o Windows XP e a opção troca de usuário rápida esteja ativada, talvez seja necessário ter um arquivo de atualização.

Para obter a atualização, visite o seguinte site da Microsoft (em inglês):
http://www.microsoft.com/downloads/details.aspx?familyid=eae20f0f-c41c-44fe-84ce-1df707d7a2e9 (http://www.microsoft.com/downloads/details.aspx?familyid=eae20f0f-c41c-44fe-84ce-1df707d7a2e9)
Observação Para instalar a atualização, é necessário fazer logon no Microsoft Windows com uma conta que tenha direitos de administração. O arquivo não é necessário para o Microsoft Windows 2000 ou anterior.

Correção de driver do SafeDisc

A atualização foi criada para o Microsoft Windows NT, o Windows 2000 e o Windows XP. É necessário fazer logon como administrador para instalá-la. Caso continue tendo problemas na verificação do CD, está disponível uma atualização de aprimoramento de compatibilidade.

Para baixar a atualização, visite o seguinte site da Macrovision (em inglês):
http://www.macrovision.com/products/safedisc/downloads.shtml (http://www.macrovision.com/products/safedisc/downloads.shtml)
A Microsoft fornece informações para contato com terceiros para ajudá-lo a encontrar suporte técnico. Estas informações podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão destas informações. Se o problema continuar, vá para o próximo método.

Método 4: Você consultou os Termos de Licença para Software Microsoft?

Depois de instalar o jogo com êxito, é necessário consultar os Termos de Licença para Software Microsoft. O jogo está tentando verificar o disco. Este processo é chamado de ?Verificação de CD?. O processo normalmente ocorre antes de aceitar os termos de licença. Caso não tenha consultado os termos de licença depois de instalar o jogo, a unidade não consegue ignorar o processo de verificação do CD. O processo de verificação de CD verifica se você está usando um disco original, e não uma cópia. Em alguns computadores, os drivers de CD não ignoram o processo de verificação de CD.

Importante Alguns jogos listados na seção "Aplica-se a" exibem a tela Termos de Licença para Software Microsoft durante a instalação. Caso tenha aceitado os termos de licença durante a instalação, mas ainda esteja enfrentando os sintomas descritos na seção "Sintoma", execute as orientações do artigo. Caso não se lembre se consultou os Termos de Licença para Software Microsoft, ou caso não queira remover e, em seguida, reinstalar o jogo, é possível determinar se você aceitou os termos de licença. Para fazer isto, execute as seguintes etapas:
  1. Clique em Iniciar aponte para Executar e digite regedit.
  2. Expanda HKEY_CURRENT_USER.
  3. Expanda Software.
  4. Expanda Microsoft e Jogos Microsoft.
  5. Expanda a pasta do jogo e clique na pasta localizada na pasta do jogo.
A pasta no nome do jogo deve ter um número. Por exemplo, 01, 02, 03 ou termos de licença.

Anote o que vê ao lado de FIRSTRUN no painel à direita. Caso veja o número 0x00000001, você aceitou os Termos de Licença para Software Microsoft, e esse não é o problema. Caso veja o número 0x00000000 em que o último número é zero, a unidade de CD apresenta problemas durante a verificação do disco do jogo.

Para resolver esse problema, use os seguintes métodos na ordem em que são apresentados.

Método 5: desabilitar ou alterar o modo de compatibilidade

  1. Clique com o botão direito do mouse no ícone de atalho do programa e clique em Propriedades.
  2. Na guia Compatibilidade, desmarque a caixa de seleção Executar este programa em modo de compatibilidade.

    Como alternativa, na guia Compatibilidade, selecione o modo de compatibilidade Windows 2000.
  3. Clique em OK.
  4. Inicie o programa usando o atalho modificado.
Recolher esta imagemExpandir esta imagem
Desabilitar ou alterar o modo de
		  compatibilidade

Se o problema continuar, vá para o próximo método.

Método 6: esvaziar a pasta Temporária

Para esvaziar a pasta Temporária, execute as etapas correspondentes à versão do Microsoft Windows.

Windows 98 ou Windows Millennium Edition (Me)

  1. Clique em Iniciar e em Executar, digite temp na caixa Abrir e clique em OK.
  2. No menu Editar, clique em Selecionar tudo.
  3. No menu Arquivo, clique em Excluir e em Sim para todos.

Windows XP ou Windows 2000

Observação A pasta Temporária do Windows XP, que o programa de Instalação do jogo está tentando usar, está localizada em uma pasta específica do usuário, comoUnidade\Documents and Settings\Usuário Nome\Local Settings\Temp.
  1. Clique em Iniciar e em Executar, digite %temp% na caixa Abrir e clique em OK.
  2. No menu Editar, clique em Selecionar tudo.
  3. No menu Arquivo, clique em Excluir e em Sim para todos.
Se o problema persistir, vá para o próximo método.

Método 7: reiniciar o computador usando um procedimento de inicialização simples

Ao iniciar o Microsoft Windows, normalmente há vários programas que iniciam automaticamente e executam em segundo plano, o que pode interferir no jogo. Entre eles podem estar programas antivírus e utilitários do sistema. Ao executar a inicialização simples, você impede que estes programas sejam iniciados automaticamente. É necessário fazer logon como administrador ou como membro do grupo Administradores para completar este procedimento. Caso o computador esteja conectado a uma rede, as configurações da diretiva de rede também poderão impedir a conclusão do procedimento.

Para reiniciar o computador usando uma inicialização simples, execute as seguintes etapas ao usar o Windows XP.

Observação É possível que você enfrente uma perda temporária da funcionalidade de alguns serviços ao executar as seguintes etapas. A restauração das configurações recupera a funcionalidade, mas pode causar o retorno da mensagem de erro ou do comportamento original.
  1. Clique em Iniciar, em Executar, digite msconfig na caixa Abrir e clique em OK.
  2. Na guia Geral, clique em Inicialização seletiva.
  3. Em Inicialização seletiva, desmarque as seguintes caixas de seleção:
    • Processar o arquivo SYSTEM.INI
    • Processar o arquivo WIN.INI
    • Carregar itens de inicialização
  4. Na guia Serviços, marque a caixa de seleção Ocultar todos os serviços Microsoft, e clique em Desativar tudo.
  5. Clique em OK e depois clique em Reiniciar.
Para realizar um procedimento de inicialização simples, clique em Executar para exibir a demonstração em em mídia de fluxo contínuo.
Para retornar a uma inicialização regular depois que você realiza um procedimento de inicialização simples, clique em Executar para exibir a demonstração em mídia de fluxo contínuo.
Para obter mais informações ou para visualizar as etapas para outros sistemas operacionais, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
331796  (http://support.microsoft.com/kb/331796/ ) Como realizar um procedimento de inicialização simples para impedir que programas em segundo plano interfiram em um jogo ou em um programa que você está usando atualmente
Se o problema persistir, vá para o próximo método.

Método 8: instalar e iniciar o jogo por uma unidade de CD ou de DVD diferente

Caso o problema continue ocorrendo, a unidade de CD talvez não consiga ler o CD do jogo corretamente.

Tente instalar o jogo por outra unidade de CD ou DVD no mesmo computador ou em um diferente. Se a instalação for feita com êxito e for possível iniciar o jogo no teste, o problema pode estar na unidade de CD ou DVD original que não consegue ler o disco do jogo.

Método 9: procure os emuladores de CD (CD virtual) instalados no computador

Um emulador de CD cria unidades de disco virtuais nos sistemas do Windows. É possível consultá-las na janela Meu computador ou usando o Microsoft Windows Explorer. Embora as unidades de CD virtuais possam ser semelhantes às unidades de CD físicas dentro do sistema operacional, há algumas diferenças significativas de uma unidade de CD ou de DVD real. Em vez de ser uma parte do hardware físico instalado no computador, um emulador de CD copia CDs como um arquivo de imagem no disco rígido.

Como posso reconhecer se há uma unidade de CD virtual instalada em um computador?

Abra Meu computador e conte o número das unidades de CD, DVD e CDRW. Conte o número de unidades de CD fisicamente instaladas no computador. Também é possível expandir a janela Gerenciador de dispositivos para exibir quantos dispositivos de CD estão instalados.

Para fazer isto, execute as seguintes etapas:
  1. Clique em Iniciar, aponte para Configurações e clique em Painel de controle.
  2. Clique duas vezes em Sistema.
  3. Se estiver usando um computador com o Microsoft Windows 98 ou o Microsoft Windows Millennium (Me), clique na guia Gerenciador de dispositivos.

    Se estiver usando um computador com o Microsoft Windows 2000 ou o Microsoft Windows XP, clique na guia Hardware e em Gerenciador de dispositivos.
  4. Expanda Unidades de CD ou DVD-ROM.
  5. Conte quantas unidades estão listadas.
  6. Feche todas as janelas abertas na área de trabalho.
Depois que souber quantas unidades há no Gerenciador de Dispositivos, verifique o computador e conte quantas unidades de CD há, observando a caixa.

Não se esqueça de que pode haver uma porta na frente do computador que precisa ser aberta para ver as unidades físicas instaladas. Também é possível que haja unidades externas conectadas por USB ou SCSI. Se houver mais de uma unidade de CD listada em Meu computador do que as conectadas ou instaladas no computador, há chances de que haja uma unidade de CD virtual ou emulador instalados.

Método 10: fazer logon como Administrador (apenas para o Microsoft Windows NT, o Microsoft Windows 2000 e o Microsoft Windows XP)

Se estiver usando o Windows NT, o Windows 2000 ou o Windows XP, faça logoff no computador e depois logon como usuário com direitos de Administrador.

Se o problema continuar, vá para o próximo método.

Método 11: alterar o modo de transferência DMA para o modo PIO (Windows XP)

  1. No Windows XP, clique em Iniciar e em Painel de controle.
  2. Clique duas vezes em Sistema, clique em Hardware e em Gerenciador de dispositivos

    Se você não vir Sistema, clique em Alternar para o modo de exibição clássico no painel à esquerda.
  3. Clique duas vezes em Controladores IDE ATA/ATAPI, em Canal IDE secundário e clique na guia Configurações avançadas.

    Observação Se você não vir a guia Configurações avançadas, o computador poderá ter uma unidade SCSI. As opções do modo de transferência DMA não estão disponíveis para as unidades SCSI.
  4. Em Dispositivo 0, selecione Somente PIO na caixa Modo de transferência. Se houver mais de uma unidade de CD ou DVD, também selecione Somente PIO na caixa Modo de transferência em Dispositivo 1.

    Observação Se o Modo de transferência atual em Dispositivo 0 ou em Dispositivo 1 indicar Não aplicável, é sinal de que o dispositivo não está sendo usado. Altere apenas os Dispositivos que não informam Não aplicável. Se ambos os dispositivos informarem Não aplicável, a unidade de CD ou DVD estará no Canal IDE primário.
  5. Clique duas vezes em Canal IDE primário.
  6. Na guia Configurações avançadas, em Dispositivo 1, selecione DMA se disponível na caixa Modo de transferência.

    ObservaçãoDispositivo 0 é a unidade de disco rígido mais provável e não deve ser alterada.
  7. Clique em OK.
  8. Reinicie o computador.
Recolher esta imagemExpandir esta imagem
Altere o modo de transferência DMA para
		  PIO

Método 12: examinar o computador em busca de vírus

O jogo talvez seja fechado, gere uma mensagem de erro ou pare de responder durante a inicialização ou quando ao jogar o jogo, caso o computador esteja infectado por vírus.

Importante Caso já haja um programa antivírus instalado no computador, atualize o programa com os arquivos de assinatura mais recentes antes de examinar o computador em busca de vírus. A maioria das empresas de software criadoras de programas antivírus libera um novo arquivo de assinatura por mês. Após a obtenção dos arquivos de assinatura mais recentes, examine o computador. Para obter ajuda sobre os arquivos de assinatura de antivírus, contate o fabricante do software antivírus.

Caso não haja nenhum software antivírus instalado, exiba uma lista dos fornecedores de software antivírus. Para obter mais informações, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
49500  (http://support.microsoft.com/kb/49500/ ) Lista de fornecedores de software antivírus
Há vários programas grátis online de verificadores de vírus disponíveis que podem ser usados no exame do sistema em busca de vírus ? por exemplo, visite o seguinte site da Symantec (em inglês):
http://security.symantec.com (http://security.symantec.com)
É possível impedir que os vírus infectem o computador ou se espalhem para outros computadores. Para obter mais informações sobre as formas que podem ser usadas para inocular o computador em relação a vírus de computador, visite o seguinte site da Microsoft (em inglês):
http://www.microsoft.com/athome/security/viruses/default.mspx (http://www.microsoft.com/athome/security/viruses/default.mspx)
Caso o problema continue ocorrendo, vá para o próximo método.

Método 13: remover o spyware

O spyware é um software que coleta informações pessoais sem o seu consentimento ou permissão. É possível ser alvo de spyware ou de outros softwares indesejados ao baixar música de programas de compartilhamento de arquivo, jogos gratuitos de sites que não confia ou outros softwares de origem desconhecida. O spyware pode afetar a jogabilidade e o processo de inicialização.

Para saber mais sobre sintomas de spyware e de outros softwares indesejados, como removê-lo e como é possível ajudar a proteger o computador, visite o seguinte site da Microsoft (em inglês):
http://www.microsoft.com/athome/security/spyware/default.mspx (http://www.microsoft.com/athome/security/spyware/default.mspx)

Método 14: configurar o McAfee nuts e bolts

  1. Maximize Bomb Shelter.
  2. Na caixa de diálogo Bomb Shelter, clique em Properties.
  3. No grupo Error Protection, clique em Advanced.
  4. Na guia Advanced Properties, desmarque a caixa de seleção Write Protect VMM.
  5. Clique em Apply ou OK e em OK em todas as telas seguintes.
Se o problema persistir, vá para o próximo método.

Método 15: baixar a versão mais recente do firmware da unidade de CD/DVD

Contate o fabricante do hardware da unidade de CD para obter e instalar a versão mais recente do firmware. Para obter informações sobre como contatar o fabricante do hardware da unidade de CD, clique no número correspondente na seguinte lista para ler o artigo na Base de Dados de Conhecimento Microsoft (alguns sites podem estar em inglês):
65416  (http://support.microsoft.com/kb/65416/ ) Informações para contato com fornecedores de hardware e software, de A a K

60781  (http://support.microsoft.com/kb/60781/ ) Informações para contato com fornecedores de hardware e software, de L a P

60782  (http://support.microsoft.com/kb/60782/ ) Informações para contato com fornecedores de hardware e software, de Q a Z
A Microsoft fornece informações para contato com terceiros para ajudá-lo a encontrar suporte técnico. Estas informações podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão destas informações.

Para saber se as atualizações aplicáveis da unidade estão disponíveis, visite o seguinte site do Microsoft Windows Update:Clique em Executar para exibir uma demonstração em mídia de fluxo contínuo.

Mais Informações

Como os Microsoft games listados na seção "Aplica-se a" são programas protegidos contra cópia, é necessário inserir o CD do jogo na unidade para executar o programa.

Isso também é válido ao copiar o conteúdo do CD do jogo para o disco rígido, servidor ou outro dispositivo de armazenamento e instalá-lo por esse dispositivo de armazenamento.

Para obter mais informações sobre como solucionar erros de leitura de CD no Windows 95, Windows 98 e Windows Millennium Edition (Me), clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
218617  (http://support.microsoft.com/kb/218617/ ) Como solucionar problemas de leitura do CD ou DVD-ROM

A informação contida neste artigo aplica-se a:
  • Microsoft Age of Empires II: The Age of Kings
  • Microsoft Age of Empires II: The Conquerors Expansion
  • Microsoft Age of Empires II Gold Edition
  • Microsoft Age of Empires III
  • Microsoft Age of Empires III : The WarChiefs
  • Microsoft Age of Mythology
  • Microsoft Age of Mythology: The Titans
  • Microsoft Age of Mythology Gold
  • Microsoft Baseball 2001
  • Microsoft Casino
  • Microsoft Classic Board Games 1.0
  • Microsoft Combat Flight Simulator 2: WWII Pacific Theater
  • Microsoft Combat Flight Simulator 3: Battle for Europe
  • Microsoft Crimson Skies
  • Microsoft Dungeon Siege
  • Microsoft Dungeon Siege: Legends of Aranna
  • Microsoft Dungeon Siege II
  • Fable: The Lost Chapters PC
  • Microsoft Flight Simulator 2000 Standard Edition
  • Microsoft Flight Simulator 2000 Professional Edition
  • Microsoft Flight Simulator 2002 Standard Edition
  • Microsoft Flight Simulator 2002 Professional Edition
  • Microsoft Flight Simulator 2004 Century of Flight
  • Microsoft Freelancer
  • Microsoft Golf 2001
  • Microsoft Halo PC 1.0
  • Microsoft Impossible Creatures
  • Microsoft Links LS 2000
  • Microsoft Links 2001 Standard Edition
  • Microsoft MechCommander 2
  • Microsoft MechWarrior 4: Vengeance
  • Microsoft MechWarrior 4: Mercenaries
  • Microsoft Metal Gear Solid
  • Microsoft Midtown Madness
  • Microsoft Midtown Madness 2.0
  • Microsoft Motocross Madness 2
  • Microsoft NBA Inside Drive 2000
  • Microsoft NFL Fever 2000
  • Microsoft Pandora's Box
  • Microsoft Rise of Nations
  • Microsoft Rise of Nations: Gold Edition
  • Microsoft Rise of Nations: Rise of Legends
  • Microsoft Rise of Nations: Thrones and Patriots
  • Microsoft Starlancer
  • Microsoft eMbedded Visual C++ 4.0
  • Microsoft Zoo Tycoon 1.0
  • Microsoft Zoo Tycoon 2
  • Microsoft Zoo Tycoon Complete Collection
  • Microsoft Zoo Tycoon: Dinosaur Digs 1.0
  • Microsoft Zoo Tycoon: Marine Mania
  • Microsoft Zoo Tycoon 2: African Adventure
  • Microsoft Zoo Tycoon 2: Dino Danger
  • Microsoft Zoo Tycoon 2: Endangered Species
  • Microsoft Zoo Tycoon 2: Marine Mania
Palavras-chave: 
kbhowto kbarttypeshowme kberrmsg kbfaq kbprb kbsetup KB228985