การแก้ไข: ปัญหาต่าง ๆ เกิดขึ้นได้เมื่อคุณใช้ตัวปรับต่อ BizTalk สำหรับการ EnterpriseOne Edwards JD หรือตัวปรับต่อ BizTalk สำหรับ JD การข้อมูล XE OneWorld Edwards ใน BizTalk Server 2006 R2 หรือ ใน 2009 ในเซิร์ฟเวอร์ BizTalk

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 2291479 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

พิจารณาสถานการณ์สมมติต่อไปนี้:
  • คุณมีคอมพิวเตอร์ที่กำลังเรียกใช้ Microsoft BizTalk Server 2006 R2 หรือ 2009 เซิร์ฟเวอร์ของ Microsoft BizTalk
  • คุณใช้อะแดปเตอร์ที่ต่อไปนี้อย่างใดอย่างหนึ่งเพื่อแลกเปลี่ยน ฟังก์ชันทางธุรกิจ ข้อความระหว่าง BizTalk Server และระบบการ EnterpriseOne Edwards JD:
    • อะแดปเตอร์ของ Microsoft BizTalk สำหรับ JD Edwards EnterpriseOne
    • อะแดปเตอร์ของ Microsoft BizTalk สำหรับ JD Edwards OneWorld ที่ข้อมูล XE
ในสถานการณ์สมมตินี้ ปัญหาต่าง ๆ ต่อไปนี้อย่างน้อยหนึ่งอาจเกิดขึ้น

ฉบับที่ 1

หลังจากที่คุณพยายามที่จะส่งข้อความ โดยใช้อะแดปเตอร์ อะแดปเตอร์ที่ไม่ได้ใช้งานสำหรับการสัก และคุณพยายามที่จะส่งข้อความอื่น ในสถานการณ์สมมตินี้ อะแดปเตอร์ไม่ส่งข้อความแรก อย่างไรก็ตาม อะแดปเตอร์ส่งข้อความสอง นอกจากนี้ เหตุการณ์ที่มีลักษณะต่อไปนี้ถูกบันทึกไว้ในแฟ้มบันทึกของโปรแกรมประยุกต์:

ชนิดเหตุการณ์: ข้อผิดพลาด
แหล่งที่มาของเหตุการณ์: อะแด็ปเตอร์ Microsoft Biztalk สำหรับโปรแกรมประยุกต์ระดับองค์การ
ประเภทเหตุการณ์: ไม่มี
รหัสเหตุการณ์: 0
คำอธิบาย:
ข้อผิดพลาดขณะทำงาน: ไม่สามารถสร้างการเชื่อมได้เนื่องจากเครื่องเป้าหมายปฏิเสธมัน 127.0.0.1:15000

ปัญหาที่ 2

เมื่อคุณตั้งค่า โทรศัพท์ที่เกิดขึ้นพร้อมกันมากที่สุด คุณสมบัติเป็นค่าที่มากกว่า 1 สำหรับอะแดปเตอร์ ข้อความหลายอินสแตนซ์ที่ dehydrate และไม่ได้มีการประมวลผล การขนส่ง

ประเด็นที่ 3

เป็นระยะ ๆ ข้อความเป็นงาน นอกจากนี้ บางรายการเหตุการณ์ที่คล้ายกับต่อไปนี้ถูกบันทึกไว้ในบันทึกของโปรแกรมประยุกต์:

เหตุการณ์ที่ 1

ชนิดเหตุการณ์: ข้อผิดพลาด
แหล่งที่มาของเหตุการณ์: อะแด็ปเตอร์ Microsoft BizTalk สำหรับโปรแกรมประยุกต์ระดับองค์การ
ประเภทเหตุการณ์: ไม่มี
รหัสเหตุการณ์: 0
คำอธิบาย:
เป้าหมายไม่ถูกต้อง: X0010GetNextNumber@JDE://CALLBSFN/

เหตุการณ์ 2

ชนิดเหตุการณ์: ข้อผิดพลาด
แหล่งที่มาของเหตุการณ์: อะแด็ปเตอร์ Microsoft Biztalk สำหรับโปรแกรมประยุกต์ระดับองค์การ
ประเภทเหตุการณ์: ไม่มี
รหัสเหตุการณ์: 0
คำอธิบาย: transmitting ข้อผิดพลาด:<soap-env:fault></soap-env:fault>
ENV = "http://schemas.xmlsoap.org/soap/envelope/

" ><faultcode>SOAP-ENV:Client</faultcode><faultstring>การร้องขอหมายเลข: ที่ไม่รู้จัก</faultstring>

ชนิดของข้อยกเว้น: วิธีการไม่มีอยู่
รายละเอียดข้อยกเว้น:
เกิดข้อยกเว้น:
เป้าหมายไม่ถูกต้อง: X0010GetNextNumber@JDE://CALLBSFN/X0010>

เหตุการณ์ 3

ชนิดเหตุการณ์: คำเตือน
แหล่งที่มาของเหตุการณ์: 2009 การเซิร์ฟเวอร์ BizTalk
ประเภทเหตุการณ์: 2009 การเซิร์ฟเวอร์ BizTalk
รหัสเหตุการณ์: 5743
คำอธิบาย: อะแดปเตอร์ที่ล้มเหลวในการส่งผ่านข้อความที่กำลังส่งพอร์ต "<send port="">" กับ URL "<url>" มันจะ retransmitted หลังจากช่วงเวลาระบุไว้สำหรับพอร์ตส่งนี้ รายละเอียด: "เกิดข้อผิดพลาดข้อความที่ transmitting:<soap-env:fault xmlns:soap-env=" xmlns:soap-env=""></soap-env:fault xmlns:soap-env="></url></send>http://schemas.xmlsoap.org/soap/envelope/

" ><faultcode>SOAP-ENV:Client</faultcode><faultstring>การร้องขอหมายเลข: ที่ไม่รู้จัก</faultstring>

ชนิดของข้อยกเว้น: วิธีการไม่มีอยู่
รายละเอียดข้อยกเว้น:
เกิดข้อยกเว้น:
เป้าหมายไม่ถูกต้อง: X0010GetNextNumber@JDE://CALLBSFN/X0010>".

สาเหตุ

ปัญหาเหล่านี้เกิดขึ้นเนื่องจากการมีข้อผิดพลาดในตัวปรับต่อ BizTalk สำหรับโปรแกรมประยุกต์ระดับองค์การ

การแก้ไข

ข้อมูลโปรแกรมแก้ไขด่วน

มีโปรแกรมแก้ไขด่วนที่ได้รับการสนับสนุนจาก Microsoft อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มุ่งหวังเพื่อการแก้ไขปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น ใช้ hotfix นี้เฉพาะกับระบบที่พบปัญหาอธิบายไว้ในบทความนี้ โปรแกรมแก้ไขด่วนนี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น ถ้าคุณจะไม่ได้รับความเสียหายรุนแรงผลจากปัญหานี้ เราขอแนะนำให้ คุณรอการปรับปรุงซอฟต์แวร์ถัดไปที่ประกอบด้วยโปรแกรมแก้ไขด่วนนี้

หากโปรแกรมแก้ไขด่วนพร้อมใช้งานสำหรับการดาวน์โหลด จะเห็นส่วน "โปรแกรมแก้ไขด่วนพร้อมใช้งานดาวน์โหลด" ที่ด้านบนของบทความฐานความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น ติดต่อ Microsoft ฝ่ายบริการสนับสนุนลูกค้าเพื่อขอรับโปรแกรมแก้ไขด่วน

หมายเหตุ ถ้าปัญหาอื่น ๆ เกิดขึ้น หรือการแก้ไขปัญหาใด ๆ จำเป็น คุณอาจต้องสร้างการร้องขอบริการแยกต่างหาก ค่าใช้จ่ายในการสนับสนุนปกติจะใช้คำถามเพิ่มเติมและเรื่องที่ไม่สามารถจัดหาโปรแกรมแก้ไขด่วนนี้เฉพาะ สำหรับรายการทั้งหมด ของหมายเลขโทรศัพท์ของฝ่ายบริการลูกค้าของ Microsoft สนับสนุน หรือเมื่อต้อง การสร้างการร้องขอบริการแยกต่างหาก แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/contactus/?ws=support
หมายเหตุ "โปรแกรมแก้ไขด่วนพร้อมใช้งานดาวน์โหลด" แบบฟอร์มแสดงภาษาโปรแกรมแก้ไขด่วนจะพร้อมใช้งาน ถ้าคุณไม่เห็นภาษาของคุณ ไม่ได้เนื่องจากไม่มีโปรแกรมแก้ไขด่วนพร้อมใช้งานสำหรับภาษานั้น

ข้อกำหนดเบื้องต้น

เมื่อต้องการใช้โปรแกรมแก้ไขด่วนนี้ คุณต้องมีการ์ด BizTalk สำหรับโปรแกรมประยุกต์ระดับองค์การ (เรียกอีกอย่างว่า BizTalk LOB การ์ด) ติดตั้งอยู่ นอกจากนี้ เครื่องคอมพิวเตอร์ควรใช้ BizTalk Server 2006 R2 Service Pack 1 (SP1) หรือ 2009 ในเซิร์ฟเวอร์ BizTalk

ความต้องการเริ่มต้นใหม่

คุณไม่มีการเริ่มระบบของคอมพิวเตอร์ใหม่หลังจากที่คุณนำโปรแกรมแก้ไขด่วนนี้

ข้อมูลการแทนที่โปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนนี้ไม่แทนการแก้ไขด่วนอื่น ๆ

แฟ้มข้อมูล

เวอร์ชันภาษาอังกฤษของโปรแกรมแก้ไขด่วนนี้มีแอตทริบิวต์ของแฟ้ม (หรือแอตทริบิวต์ของแฟ้มที่ใหม่กว่า) ซึ่งแสดงอยู่ในตารางต่อไปนี้ วันและเวลาของแฟ้มเหล่านี้จะแสดงรายการในรูปแบบเวลา (UTC) เมื่อคุณดูข้อมูลแฟ้มข้อมูล จะถูกแปลงเป็นเวลาท้องถิ่น เมื่อต้องการค้นหาความแตกต่างระหว่างเวลา UTC และเวลาท้องถิ่น ใช้ โซนเวลา แท็บใน วันและเวลา สินค้าใน'แผงควบคุม'
สำหรับ BizTalk Server 2006 R2 SP1
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดของแฟ้มวันเวลาแพลตฟอร์ม
Microsoft.biztalk.adapters.bizutil.dll1.0.5022.13164,23208-Aug-201116:47x 86
สำหรับ 2009 ในเซิร์ฟเวอร์ BizTalk
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดของแฟ้มวันเวลาแพลตฟอร์ม
Microsoft.biztalk.adapters.bizutil.dll1.0.5102.2156,040วันที่ 28-ก.ค.-201010:30x 86

วิธีการใช้โปรแกรมแก้ไขด่วนนี้

เมื่อต้องการใช้โปรแกรมแก้ไขด่วนนี้หลังจากที่คุณติดตั้งเรียบร้อยแล้ว ทำต่อไปนี้:
  1. ลงทะเบียนแฟ้ม Microsoft.BizTalk.Adapters.BizUtil.dll ด้วยตนเองในแคชของแอสเซมบลีส่วนกลาง (GAC) เมื่อต้องการทำเช่นนี้ ให้ทำตามขั้นตอนเหล่านี้

    1. เปิดตัว หน้าจอพร้อมรับคำสั่ง Studio visual หรือ หน้าจอพร้อมรับคำสั่งของ SDK หน้าต่าง เปลี่ยนไดเรกทอรีปัจจุบันดังต่อไปนี้:
      %ProgramFiles%\Common Files\Microsoft ตัวปรับต่อ BizTalk สำหรับเว็บไซต์องค์กร Applications\Bin
      สิ่งสำคัญ เมื่อต้องการเปิดตัว หน้าจอพร้อมรับคำสั่ง Studio visual หน้าต่าง คุณต้องมี Microsoft Visual Studio 2008 หรือ Microsoft Visual Studio 2005 ติดตั้ง เมื่อต้องการเปิดตัว หน้าจอพร้อมรับคำสั่งของ SDK หน้าต่าง คุณต้องมี MicrosoftNET Framework 2.0 SDK ติดตั้ง
    2. หน้าจอพร้อมรับคำสั่ง Studio visual หรือ หน้าจอพร้อมรับคำสั่งของ SDK หน้าต่าง พิมพ์คำสั่งต่อไปนี้ และกด Enter:
      gacutil /i Microsoft.BizTalk.Adapters.BizUtil.dll
  2. สร้างคีย์ย่อยใหม่ในรีจิสทรี เมื่อต้องการทำเช่นนี้ ให้ทำตามขั้นตอนเหล่านี้:

    คำเตือน ปัญหาร้ายแรงอาจเกิดขึ้นได้ถ้าคุณเปลี่ยนแปลงรีจิสทรีอย่างไม่ถูกต้อง โดยใช้ตัวแก้ไขรีจิสทรี หรือ โดยใช้วิธีอื่น ปัญหาเหล่านี้อาจต้องให้คุณติดตั้งระบบปฏิบัติการใหม่ Microsoft ไม่สามารถรับประกันว่า ปัญหาเหล่านี้จะสามารถแก้ไข การเปลี่ยนแปลงรีจิสทรีในความเสี่ยงของคุณเอง
    1. คลิก เริ่มการทำงานคลิก Run ชนิด regeditแล้ว คลิก ตกลง.
    2. ค้นหา และเลือกคีย์รีจิสทรีต่อไปนี้:
      สำหรับระบบปฏิบัติการแบบ 32 บิต
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalkAdapters
      สำหรับระบบปฏิบัติการแบบ 64 บิต
      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\BizTalkAdapters
    3. บนเครื่อง แก้ไข เมนู การชี้ไปที่ ใหม่แล้ว คลิก ค่า DWORD.
    4. ชนิด AgentOutboundTimeoutแล้ว กด Enter
    5. บนเครื่อง แก้ไข เมนู คลิก การปรับเปลี่ยน.
    6. เลือก เลขฐานสิบชนิด 60000แล้ว คลิก ตกลง.
    ที่ AgentOutboundTimeout ค่าใช้ถัง RunTimeAgent กระบวนการหลังจากช่วงเวลาของการไม่มีผลงาน เราขอแนะนำให้ คุณตั้งค่าเพื่อที่จะเพิ่มเติมนอกเหนือจากเวลาที่จำเป็นสำหรับการดำเนินการให้เสร็จสมบูรณ์ได้บนเซิร์ฟเวอร์ Oracle โดยค่าเริ่มต้น ค่าเป็น 60000 มิลลิวินาที (1 นาที)

สถานะ

Microsoft ยืนยันว่า ปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน"ใช้งาน"

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับตัวปรับต่อ BizTalk สำหรับการ EnterpriseOne Edwards JD แวะไปที่เว็บไซต์ของ Microsoft สำหรับนักพัฒนาเครือข่าย (MSDN) ต่อไปนี้: สำหรับข้อมูลเพิ่มเติมเกี่ยวกับตัวปรับต่อ BizTalk สำหรับข้อมูล XE OneWorld ของ JD Edwards แวะไปที่เว็บไซต์ต่อไปนี้ของ MSDN: สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการ หน้าจอพร้อมรับคำสั่ง Studio visual หน้าต่าง การเยี่ยมชมเว็บไซต์ต่อไปนี้ของ MSDN:สำหรับข้อมูลเพิ่มเติมเกี่ยวกับโปรแกรมแก้ไขด่วนที่ BizTalk Server คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base:
2003907 รายละเอียดเกี่ยวกับโปรแกรมแก้ไขด่วนที่ BizTalk Server

คุณสมบัติ

หมายเลขบทความ (Article ID): 2291479 - รีวิวครั้งสุดท้าย: 19 สิงหาคม 2554 - Revision: 3.0
ใช้กับ
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
  • Microsoft BizTalk Server 2006 R2 Service Pack 1 เมื่อใช้กับ:
    • Microsoft BizTalk Server 2006 R2 Branch
    • Microsoft BizTalk Server 2006 R2 Developer Edition
    • Microsoft BizTalk Server 2006 R2 Enterprise Edition
    • Microsoft BizTalk Server 2006 R2 Standard Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbexpertiseadvanced kbsurveynew kbbiztalk2009presp1fix kbbtsadapters kbmt KB2291479 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:2291479

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com