Usunięte hiperłącze pozostaje w źródle HTML wiadomości e-mail, jeśli utworzyć wiadomość e-mail za pomocą programu OWA w środowisku Exchange Server 2007

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 2292150 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Rozważmy następujący scenariusz:
  • Tworzenie wiadomości e-mail przy użyciu programu Outlook Web Access (OWA) w środowisku Microsoft Exchange Server 2007.
  • Treść wiadomości e-mail zawiera hiperłącze.
  • Zaznacz hiperłącze, a następnie kliknięciu prawym przyciskiem myszy, aby otworzyć menu skrótów.
  • Kliknij Wytnij lub kliknąć przycisk Usuń w menu skrótów a następnie wyślij wiadomość e-mail do adresata.
  • Adresat przegląda kod źródłowy HTML wiadomości e-mail.
W tym scenariuszu usunięte hiperłącze jest nadal widoczny w kodzie źródłowym HTML. Na przykład Usuń hiperłącze someone@123.com w wiadomości e-mail, treść wiadomości, a następnie wyślij wiadomość e-mail. Hiperłącze, które pozostaje w elemencie zakotwiczenia w kodzie źródłowym HTML podobna do następującej:
<a href="mailto:someone@123.com""></a>

Uwaga Ten problem występuje w przeglądarkach innych firm, takich jak Firefox.

Przyczyna

Przyczyną występowania tego problemu jest w programie Microsoft Internet Explorer.

Rozwiązanie

Aby rozwiązać ten problem, należy zainstalować następujące pakietu zbiorczego aktualizacji:
2602324 Opis pakietu zbiorczego aktualizacji 5 dla Exchange Server 2007 Z dodatkiem Service Pack 3
Ważne Niniejszej sekcji, metodzie lub zadania zawiera kroki, które informacje dotyczące modyfikowania rejestru. Jednak niepoprawne zmodyfikowanie rejestru może spowodować poważne problemy. Należy zatem upewnić się, wykonaj następujące kroki ostrożnie. Zapewnia dodatkową ochronę kopii zapasowej rejestru przed przystąpieniem do modyfikacji. Następnie można przywrócić rejestr w przypadku wystąpienia problemu. Aby uzyskać więcej informacji dotyczących sposobu wykonywania kopii zapasowej i przywracania rejestru kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322756 Sposób wykonywania kopii zapasowej i przywracanie rejestru w systemie Windows
Po zainstalowaniu pakietu poprawki, wykonaj następujące kroki, aby wyłączyć Wytnij a Usuń w menu skrótów:
  1. Kliknij przycisk Start
    Zwiń ten obrazekRozwiń ten obrazek
    przycisk Start
    , typ regedit w Rozpocznij wyszukiwanie a następnie naciśnij klawisz ENTER.
  2. Zlokalizuj i kliknij następujący klucz rejestru:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchange OWA
  3. Na Edycja menu, wskaż Nowy, kliknij przycisk DWORDWartość, typ DisableCutAndDeleteMenu, a następnie naciśnij klawisz ENTER.
  4. Kliknij prawym przyciskiem myszy DisableCutAndDeleteMenu, a następnie kliknij przycisk Modyfikowanie.
  5. W Wartość dane pole typu 1, a następnie kliknij przycisk OK.
  6. Zamknij Edytor rejestru.

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji "Dotyczy".

Obejście problemu

Aby obejść ten problem, rozszerzył zaznaczenie hiperłącza jeden znak więcej, a następnie usuń znak przed wysłaniem wiadomości e-mail.

Więcej informacji

Produkty omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, dorozumianych, odnośnie do wydajności lub niezawodności tych produktów.

Właściwości

Numer ID artykułu: 2292150 - Ostatnia weryfikacja: 27 września 2011 - Weryfikacja: 1.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Exchange Server 2007 Service Pack 3 na następujących platformach
    • Microsoft Exchange Server 2007 Standard Edition
    • Microsoft Exchange Server 2007 Enterprise Edition
Słowa kluczowe: 
kbqfe kbfix kbsurveynew kbexpertiseinter kbmt KB2292150 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to:2292150

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com