Si è verificato un errore durante l'utilizzo di Windows Internet Explorer 8 o Windows Internet Explorer 7 per la visualizzazione di un sito Web: "Internet Explorer: impossibile visualizzare la pagina Web".

Traduzione articoli Traduzione articoli
Identificativo articolo: 2293762 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Quando si utilizza Windows Internet Explorer 8 o Windows Internet Explorer 7 per accedere a un sito Web, nel browser Web potrebbe essere ricevuto un messaggio di errore simile al seguente:


Internet Explorer: impossibile visualizzare la pagina Web.


Questo problema potrebbe verificarsi quando si accede a un sito Web che utilizza sia IPv4 che IPv6 come versione IP (Internet Protocol).




Cause

Quando Internet Explorer si connette a un server Web e l'elenco indirizzi IP restituito dai server DNS contiene più indirizzi IP, Internet Explorer tenta di creare una connessione TCP utilizzando tali indirizzi IP nell'ordine in cui sono stati ricevuti. Una volta impostata correttamente una connessione TCP, Internet Explorer utilizza tale indirizzo IP per l'invio della richiesta HTTP.

Per impostazione predefinita, tuttavia, Internet Explorer tenta di utilizzare solo i primi cinque indirizzi IP ricevuti dal DNS nel tentativo di stabilire una connessione TCP. Se non riesce a creare una connessione a tutti e cinque gli indirizzi IP, potrebbe verificarsi il problema indicato nella sezione Sintomi.


Risoluzione

Per risolvere automaticamente il problema, andare alla sezione "Correzione automatica". Per risolvere autonomamente il problema, andare alla sezione "Correzione manuale".

Correzione automatica



Per risolvere il problema automaticamente, fare clic sul collegamento o sul pulsante Risolvi. Nella finestra di dialogo Download file, fare clic su Esegui, quindi attenersi alla procedura guidata Fix it.


Correggi problema
Microsoft Fix it 50672

Note
  • Questa soluzione Fixit imposta il valore di ConnectRetries su 10per il primo utilizzo.
  • Questa procedura guidata è disponibile solo in lingua inglese. La correzione automatica, tuttavia, funziona anche per versioni di Windows in altre lingue.
  • Se non si sta utilizzando il computer che presenta il problema, è possibile salvare la soluzione Fix it su un'unità di memoria flash o su un CD ed eseguirla sul computer interessato dal problema.

Quindi consultare la sezione "Verifica della risoluzione del problema".



Correzione manuale

Per risolvere questo problema, aggiungere la chiave seguente al Registro di sistema per cambiare il numero di tentativi di connessione eseguiti da Internet Explorer.

Importante In questa sezione, metodo o attività, viene spiegato come modificare il Registro di sistema. Un'errata modifica del Registro di sistema può causare seri problemi. Attenersi, quindi, scrupolosamente alla procedura indicata. Per una maggiore sicurezza, eseguire una copia di backup del Registro di sistema prima di modificarlo. In questo modo, in caso di problemi sarà possibile ripristinare il registro. Per ulteriori informazioni sull'esecuzione del backup e del ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:


Come eseguire il backup e il ripristino del Registro di sistema in Windows


Nota
La modifica di questi valori si ripercuote sui tentativi di connessione eseguiti da tutte le applicazioni che utilizzano WinInet.dll.

1. Fare clic su Start e digitare regedit nella casella di testo Cerca programmi e file.

2. Se si riceve una richiesta tramite una finestra di dialogo Controllo account utente, fare clic su .

3. Nel riquadro sinistro della finestra Editor del Registro di sistema, accedere a una delle chiavi seguenti del Registro di sistema:



Per computer x86:

Per modificare i tentativi di connessione per l'intera macchina:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings



Per modificare i tentativi di connessione specifici dell'utente:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings



Per computer x64:


Per modificare i tentativi di connessione per l'intera macchina con Internet Explorer a 32 bit:

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings



Per modificare i tentativi di connessione specifici dell'utente con Internet Explorer a 32 bit:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings





Per modificare i tentativi di connessione per l'intera macchina con Internet Explorer a 64 bit:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings



Per modificare i tentativi di connessione specifici dell'utente con Internet Explorer a 64 bit:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings




4. Fare clic con il pulsante destro del mouse sulla chiave Internet Settings, scegliereNuovo, quindi Valore DWORD (32 bit).

5. Nella casella Nuovo valore, digitare ConnectRetries e premere INVIO.

6. Fare clic su ConnectRetries e scegliere Modifica.

7. Fare clic su Decimale nell'area Base. Nella casella Dati valore, digitare 10, quindi fare clic su OK.

Nota A seconda dell'ambiente di rete utilizzato, l'impostazione 10 potrebbe non avere effetto. In tal caso, aumentare il valore fino a eliminare l'errore.

8. Per chiudere l'editor del Registro di sistema, scegliere Esci dal menu File.

9. Per applicare la modifica, riavviare Internet Explorer.



IMPORTANTE: A seconda dell'ambiente di rete, la scelta di un numero molto grande per il valore di ConnectRetries può influire negativamente sulle prestazioni.




Verifica della risoluzione del problema

  • Verificare se il problema è stato risolto. Se il problema è stato risolto, è possibile interrompere la lettura di questa sezione. Se il problema persiste, è possibile rivolgersi al supporto tecnico.
  • Invio di commenti. Per fornire commenti o segnalare problemi relativi a questa soluzione, lasciare un commento nel blog "Correzione automatica" o inviare un messaggio di posta elettronica a Microsoft.

Informazioni

Per aggirare questo meccanismo, aggiornare la pagina Web in Internet Explorer.


Nota: questo è un articolo a "PUBBLICAZIONE RAPIDA", creato direttamente all'interno dell'organizzazione di supporto Microsoft. Le informazioni contenute nel presente documento vengono fornite "così come sono" in risposta alle problematiche riscontrate. A causa della rapidità con cui vengono resi disponibili, i materiali possono contenere errori di battitura e sono soggetti a modifica senza preavviso, in qualsiasi momento. Per altre considerazioni, vedere le Condizioni per l'utilizzo.

Proprietà

Identificativo articolo: 2293762 - Ultima modifica: lunedì 31 ottobre 2011 - Revisione: 4.0
Le informazioni in questo articolo si applicano a:
  • Windows Internet Explorer 9
  • Windows Internet Explorer 7
  • Windows Internet Explorer 8
Chiavi: 
kbfixme kbmsifixme KB2293762
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com