Corruption de fichier se produit sur un volume NTFS avec plus de 4 million fichiers

Traductions disponibles Traductions disponibles
Numéro d'article: 229607 - Voir les produits auxquels s'applique cet article
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous créez et supprimez des fichiers sur un volume NTFS qui contient des fichiers de plus de 4 millions, vous voyez corruption de fichier peut n'apparaître dans une des manières suivantes :
  • Fichiers supprimés continuent d'apparaître sur le lecteur.
  • Fichiers que vous n'avez pas supprimés ne sont plus accessibles.
  • Un message contextuel s'affiche génération d'états qu'endommagé a été détecté sur le lecteur et demande que vous exécuter CHKDSK.

Cause

Ce problème se produit lorsque la table de fichiers maîtres (MFT) a augmenté de plus de 4 Go, ce qui peut se produire lorsque vous avez plus de 4 millions fichiers sur votre ordinateur. Lorsque vous supprimez un fichier dont entrée MFT est au-delà les 4 Go pointer dans ces conditions, une erreur de calcul des causes l'entrée incorrecte pour être marqués comme disponibles. Si cette entrée contient des informations pour un autre fichier, et nouveaux fichiers sont ajoutés au volume peu après que la suppression se produit, l'entrée peut être réutilisée à l'origine le fichier il référencé en fait d'être perdues.

Résolution

Windows NT Server ou Workstation 4.0

Pour résoudre ce problème, procurez-vous le dernier service pack Windows NT 4.0 ou la mise à jour individuelles. Pour des informations pour obtenir le dernier service pack, consultez à :
Pour des informations pour obtenir la mise à jour individuelles, contactez services de support technique Microsoft. Pour une liste complète des numéros de téléphone des services de support technique Microsoft et des informations des coûts de prise en charge, accédez à l'adresse suivante sur le World Wide Web :
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Windows NT Server 4.0, Édition Terminal Server

Pour résoudre ce problème, procurez-vous le dernier service pack pour Windows NT Server 4.0, Édition Terminal Server. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
152734 Comment faire pour obtenir le dernier Service Pack Windows NT 4.0

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés au début de cet article. Ce problème a été corrigé dans Windows NT Server version 4.0, Édition Terminal Server Service Pack 6.

Plus d'informations

Informations sur tous les fichiers dans un volume NTFS sont stockées dans la table MFT. La table MFT contient un ou plusieurs entrées une pour tous les fichiers sur le système. En outre, la table MFT conserve écritures vides ou inutilisées qui peuvent être utilisés pour les fichiers nouvellement créés. Lorsqu'un fichier est supprimé, son entrée est marquée comme être inutilisée de sorte que lorsqu'un nouveau fichier est créé, le système de fichiers pouvez réutiliser l'écriture.

Propriétés

Numéro d'article: 229607 - Dernière mise à jour: mardi 4 février 2014 - Version: 2.5
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Édition Développeur
  • Microsoft Windows NT Server 4.0 Édition Entreprise
Mots-clés : 
kbnosurvey kbarchive kbmt kbhotfixserver kbqfe kbbug kbfix kbqfe KB229607 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 229607
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com