Arquivo corrupção ocorre em um volume NTFS com mais de 4 milhões de arquivos

Traduções deste artigo Traduções deste artigo
ID do artigo: 229607 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Quando você cria e excluir arquivos em um volume NTFS que contém mais de 4 milhões de arquivos, você vê um dano no arquivo que pode aparecerão em uma das seguintes maneiras:
  • Arquivos excluídos continuarão a ser exibidas na unidade.
  • Arquivos que não foram excluídos não estão mais acessíveis.
  • Uma mensagem pop-up é exibida relatórios que foi detectada corrupção na unidade e solicitando que você execute CHKDSK.

Causa

Esse problema ocorre quando a tabela mestra de arquivos (MFT) ficou maior do que 4 GB, que pode acontecer quando você tiver mais de 4 milhões de arquivos no seu computador. Quando você exclui um arquivo de entrada cuja MFT é além de 4 GB aponte sob essas condições, um erro em cálculos faz com que a entrada incorreta para ser marcada como disponível. Se essa entrada contém informações para outro arquivo e novos arquivos são adicionados ao volume logo após a exclusão, a entrada pode ser reutilizada fazendo com que o arquivo realmente referência a ela serão perdidas.

Resolução

Windows NT Server ou Workstation 4.0

Para resolver esse problema, obtenha o service pack mais recente para o Windows NT 4.0 ou a atualização de software individual. Para informações sobre como obter o service pack mais recente, vá para:
Para obter informações sobre como obter a atualização de software individual, contate o Atendimento Microsoft. Para obter uma lista completa de números de telefone do Atendimento Microsoft e informações sobre os custos de suporte, visite o seguinte endereço na Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Windows NT Server 4.0, Terminal Server Edition

Para resolver esse problema, obtenha o service pack mais recente para o Windows NT Server 4.0, Terminal Server Edition. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
152734Como obter o Windows NT 4.0 Service Pack mais recente

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no começo deste artigo. Esse problema foi corrigido primeiro no Windows NT Server versão 4.0, Terminal Server Edition Service Pack 6.

Mais Informações

As informações em todos os arquivos em um volume NTFS são armazenadas na MFT. O MFT contém uma ou mais entradas um para todos os arquivos no sistema. Além disso, o MFT mantém entradas vazias ou não utilizadas que podem ser usadas para arquivos recém-criados. Quando um arquivo é excluído, da entrada está marcada como sendo não utilizada para que quando um novo arquivo é criado, o sistema de arquivos pode reutilizar a entrada.

Propriedades

ID do artigo: 229607 - Última revisão: quarta-feira, 1 de novembro de 2006 - Revisão: 2.5
A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
Palavras-chave: 
kbmt kbhotfixserver kbqfe kbbug kbfix kbqfe KB229607 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 229607

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com