Article ID: 230168 - Last Review: November 1, 2006 - Revision: 2.2 Terminal Server Does Not Support User Mode Printer DriversThis article was previously published under Q230168 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986
(http://support.microsoft.com/kb/256986/EN-US/
)
Description of the Microsoft Windows Registry
SYMPTOMS
When you use a third-party printer driver to print, no output is generated and the server may stop responding (hang). When you print to a file, the resulting file size is 0.
CAUSE
This problem occurs because Windows NT Server 4.0, Terminal Server Edition does not provide support for this type of extension.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
152734
(http://support.microsoft.com/kb/152734/EN-US/
)
How to Obtain the Latest Windows NT 4.0 Service Pack
STATUSMicrosoft has confirmed that this is a problem in Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT Server 4.0, Terminal Server Edition, Service Pack 5. MORE INFORMATION
User-mode printer drivers can be used for modification of the data to be printed. Other uses may be for additional security checks for submitting a print job. You can find out if a particular printer driver uses a user-mode printer driver when you look into the registry under the following registry setting: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Printers\<printer driver name>\PrinterDriverData
| Article Translations
|
Back to the top
