Creazione di snap-in MMC personalizzati mediante Microsoft Management Console

Traduzione articoli Traduzione articoli
Identificativo articolo: 230263 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

Gli amministratori possono utilizzare Microsoft Management Console (Mmc.exe) per creare strumenti speciali per delegare attivitÓ amministrative specifiche a utenti o gruppi. Questi strumenti personalizzati, salvati come file della console MMC (msc), possono essere inviati tramite posta elettronica, condivisi in una cartella di rete o pubblicati sul Web. Possono anche essere assegnati a utenti, gruppi o computer con impostazioni dei criteri di sistema. Uno strumento pu˛ essere aumentato o ridotto, integrato in modo uniforme nel sistema operativo, inserito in un nuovo pacchetto e personalizzato. In questo articolo viene descritto come eseguire queste operazioni.

Creazione di un file di console

  1. Fare clic sul pulsante Start, scegliere Esegui, digitare mmc, quindi scegliere OK. Microsoft Management Console viene avviato con una console vuota (o strumento amministrativo). La console vuota non dispone di alcuna funzionalitÓ di gestione finchÚ non viene aggiunto uno snap-in.
  2. Scegliere Aggiungi/Rimuovi snap-in dal menu File.
  3. La casella Snap-in aggiunti in indica solo la directory principale della console. Scegliere Aggiungi.
  4. Selezionare lo snap-in appropriato nell'elenco di snap-in autonomi disponibili, quindi scegliere Aggiungi.
  5. Al termine scegliere OK.

    ╚ possibile nidificare gli snap-in in una struttura a livelli aggiungendo uno snap-in sotto l'altro nella casella "Snap-in aggiunti in". In alcuni casi potrebbe essere necessario fare clic sulla scheda Estensioni, che contiene la casella di controllo "Aggiungi tutte le estensioni". Quando questa casella di controllo Ŕ selezionata, e in genere lo Ŕ per impostazione predefinita, vengono utilizzate tutte le estensioni localmente installate nel computer in cui Ŕ aperto il file di console. Se questa casella di controllo viene deselezionata, tutti gli snap-in delle estensioni dell'elenco selezionati vengono caricati in modo esplicito quando il file di console viene aperto in un computer diverso.
  6. Scegliere OK per chiudere la finestra di dialogo Aggiungi/Rimuovi snap-in. La finestra della directory principale della console Ŕ ora popolata dagli snap-in selezionati, disponibili nella cartella della directory principale.
NOTA: Ŕ importante pianificare la struttura dello snap-in personalizzato perchÚ sia funzionale e di semplice utilizzo, come verrÓ spiegato in maggiore dettaglio nella sezione successiva.

Personalizzazione del layout degli snap-in nella console

  1. Nel riquadro sinistro fare clic con il pulsante destro del mouse sull'icona dello snap-in e scegliere Nuova finestra da qui. Si aprirÓ una nuova finestra diretta allo snap-in selezionato.
  2. Scegliere Affianca orizzontalmente o Sovrapponi dal menu Finestra per personalizzare le finestre.
  3. Per salvare la nuova console MMC, scegliere Salva con nome dal menu File e digitare un nome per la console. La console viene salvata come file che pu˛ essere distribuito a chiunque abbia bisogno di configurare un computer con lo strumento desiderato.

Impostazione delle opzioni dei file di console

Quando si crea un file di console per un altro utente, Ŕ utile essere in grado di impedire un'ulteriore personalizzazione del file di console da parte di tale utente. Questa operazione pu˛ essere effettuata nella finestra di dialogo Opzioni:
  1. Scegliere Opzioni dal menu File, quindi fare clic sulla scheda Console.
  2. Se si desidera selezionare un'icona diversa, fare clic su Cambia icona, selezionare l'icona appropriata, quindi scegliere OK.
  3. Selezionare una delle quattro modalitÓ console, vale a dire:

    • ModalitÓ di modifica: consente l'accesso a tutte le funzionalitÓ di MMC, compresa la possibilitÓ di aggiungere o rimuovere snap-in, di creare nuove finestre e di esplorare l'intera struttura della console.
    • ModalitÓ utente - Accesso completo: gli utenti hanno accesso a tutte le funzionalitÓ di gestione delle finestre di MMC e accesso completo alla struttura del contesto. Gli utenti non possono aggiungere o rimuovere snap-in nÚ modificare le opzioni del file di console. I comandi di salvataggio non sono disponibili perchÚ le modifiche che non influiscono sulle relazioni degli snap-in vengono salvate automaticamente.
    • ModalitÓ utente - Accesso limitato, finestra multipla: gli utenti non possono aprire nuove finestre nÚ hanno accesso ad aree della struttura della console che non erano visibili al momento in cui il file di console non Ŕ stato salvato. Si applicano anche tutte le limitazioni esistenti per la modalitÓ utente ad accesso completo. Sono consentite pi¨ finestre secondarie, ma l'utente non pu˛ chiuderle.
    • ModalitÓ utente - Accesso limitato, finestra singola: vengono applicate tutte le limitazioni relative alla modalitÓ utente ad accesso limitato, finestre multiple, a eccezione del fatto che esiste una sola finestra, pertanto non sono presenti i controlli per utilizzare pi¨ finestre.
    Nella casella ModalitÓ console selezionare la modalitÓ che si adatta meglio alle esigenze amministrative e di protezione specifiche.
  4. Per impedire che gli utenti apportino modifiche alla console personalizzata, selezionare la casella di controllo Non salvare le modifiche apportate a questa console.
  5. Scegliere OK.
  6. Per salvare la nuova console MMC, scegliere Salva con nome dal menu File e digitare un nome per la console. La console viene salvata come file che pu˛ essere distribuito a chiunque abbia bisogno di configurare un computer con lo strumento desiderato.

Collocare un'icona MSC personalizzata nella cartella Programmi

  1. Fare clic con il pulsante destro del mouse sul pulsante Start, quindi scegliere Apri cartella Utenti.
  2. Fare doppio clic sull'icona Programmi.
  3. Fare clic con il pulsante destro del mouse su un'area vuota della cartella Programmi, scegliere Nuovo, quindi fare clic su Cartella.
  4. Digitare Strumenti console e premere INVIO.
  5. Fare doppio clic sulla cartella Strumenti console per aprirla.
  6. Fare clic con il pulsante destro del mouse su un'area vuota della cartella Strumenti console, scegliere Nuovo, quindi fare clic su Collegamento.
  7. Fare clic su Sfoglia.
  8. Individuare la cartella contenente lo strumento di console personalizzato, quindi scegliere OK. Scegliere Avanti.
  9. Digitare un nome per il collegamento, quindi scegliere Fine.

ProprietÓ

Identificativo articolo: 230263 - Ultima modifica: venerdý 26 ottobre 2007 - Revisione: 3.3
Le informazioni in questo articolo si applicano a
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Datacenter Server
Chiavi:á
kbhowto kbhowtomaster kbfaq kbproductlink KB230263
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com