XADM: O serviço arquivo de informações (Information Store) devolve o erro específico do serviço 3355443752

Traduções de Artigos Traduções de Artigos
Artigo: 231299 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT231299
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Expandir tudo | Reduzir tudo

Sintomas

Após o restauro a partir de uma cópia de segurança online, o serviço de arquivo de informações (Information Store) não é iniciado, apresentando o erro específico de serviço 3355443752. O registo da aplicação contém os seguintes eventos:
Event ID: 5000
Source: MSExchangeIS
Type: Error
Category: General
Unable to initialize the Microsoft Exchange Information Store service. Error 0xc8000228.

Event ID: 1080
Source: MSExchangeIS
Type: Error
Category: Recovery
Unable to recover the database because error 0xc8000228 occurred after a restore operation. The patch file is not generated from this backup.

Event ID: 0
Source: ESE97
Type: Error
Category: Logging/Recovery
MSExchangeIS ((416) ) -552
O número entre parêntesis no último evento pode ser diferente, mas o elemento -552 está presente.

Causa

Este problema resulta da execução de isinteg -patch ou eseutil /r /is imediatamente após o restauro a partir de uma cópia de segurança online e antes de iniciar o serviço de arquivo de informações.

Execute isinteg -patch apenas depois de efectuado o restauro a partir de uma cópia de segurança offline. Se executar isinteg -patch relativamente a um restauro online, as bases de dados perderão consistência (tal como sempre acontece após um restauro online). Nessa altura, o comando Isinteg executa uma recuperação simples, o que equivale a executar Eseutil /r /is.

Um restauro online recupera ficheiros patch, tanto para os arquivos de informações privados como para os públicos (private and public information stores). Esses ficheiros patch, Priv.pat e Pub.pat, contêm transacções que não são reproduzidas durante uma recuperação simples. Por este motivo, a recuperação simples tem como resultado uma base de dados que já não corresponde aos ficheiros patch e que também poderá produzir uma base de dados danificada devido às transacções em falta. Quando o serviço de arquivo de informações é inicializado, a recuperação falha apresentando a seguinte mensagem de erro: -552 Jet_errDatabasePatchFileMismatch.

Resolução

Antes de iniciar o serviço, execute outro restauro da cópia de segurança online sem executar isinteg -patch.

Mais Informação

Note que o Isinteg -patch só será executado se estiver presente um ficheiro Edb.log na pasta Information Store Log. Um restauro online não recupera um ficheiro Edb.log. Consequentemente, a situação aqui descrita apenas ocorre depois de efectuar um restauro sem perdas (que guarda todos os ficheiros de registo existentes nas pastas de arquivo de informações) e quando ao restauro se segue imediatamente o Isinteg -patch. Esta não é a única situação que pode gerar um erro -552 e, noutras circunstâncias, a causa e a resolução podem ser diferentes.

Propriedades

Artigo: 231299 - Última revisão: 23 de janeiro de 2014 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 5.5 Standard Edition
Palavras-chave: 
kbnosurvey kbarchive exc55 kbprb KB231299

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com