ACC2000: Autocorrección de nombres no reparar informe

Seleccione idioma Seleccione idioma
Id. de artículo: 231634 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Principiante: Requiere conocimientos de la interfaz de usuario en equipos de usuario único.

Este artículo se aplica únicamente a las bases de datos de Microsoft Access (.mdb).

Expandir todo | Contraer todo

Síntomas

Aunque la Autocorrección de nombres está habilitada para realizar un seguimiento y realizar cambios en la base de datos, cuando abre un informe después de cambiar un nombre de campo, un nombre de consulta o un nombre de tabla, se le pida el antiguo nombre de campo, o recibir el siguiente mensaje de error:
El motor de base de datos Microsoft Jet no se puede encontrar la tabla entrada ni consultar la ' Table or Query Name '. Asegúrese de que existe y que su nombre está escrito correctamente.

Causa

Si el origen de registros para un informe es una instrucción SELECT de SQL, Autocorrección de nombres reparará la instrucción SQL. Sin embargo, Autocorrección de nombres no repara los controles del informe, propiedades Filter u OrderBy o valores de la lista Campo/expresión del cuadro de diálogo Ordenar y agrupar . Por lo tanto, el informe le pide el antiguo valor del nombre de campo cuando abre el informe.

Solución

Para corregir este problema, abra el informe en la vista Diseño y cambiar manualmente el control o propiedad que no ha solucionado la Autocorrección de nombres.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo.

Más información

Si el informe se ha importado o convertido a partir de una versión anterior de Microsoft Access, o si se ha deshabilitado la opción seguimiento de Autocorrección de nombres cuando se creó el informe, el informe no tiene la información de asignación de nombre que Microsoft Access necesita para reparar los cambios de nombre.

Para que Access cree la información de asignación de nombre para el informe, asegúrese de que las opciones de seguimiento de Autocorrección de nombres y Realizar Autocorrección de nombres están habilitadas. Para ello, en el menú Herramientas , haga clic en Opciones y, a continuación, haga clic en la ficha General . Si no hay marcas de verificación en las casillas de verificación registrar información de Autocorrección de nombre y Realizar Autocorrección de nombres , haga clic para activar las casillas de verificación. Esto permite la Autocorrección de nombres.

Después de habilitar Autocorrección de nombres, abrir el origen del informe en la vista Diseño y guardarlo, abra el informe en la vista Diseño y guárdelo. Esto hace que Access para crear el mapa de nombre para el informe y su origen.

Referencias

Para información adicional acerca de cómo funciona la Autocorrección de nombres y lo que reparará y no repara, consulte en contacto con el siguiente artículo en Microsoft Knowledge Base:
231745ACC2000: Funcionamiento de Autocorrección de nombres y lo repara
Para obtener información adicional sobre cómo funciona Autocorrección de nombres para convertidas bases de datos, consulte en contacto con el siguiente artículo en Microsoft Knowledge Base:
230616ACC2000: Autocorrección de nombres puede no funcionar en una base de datos convertido desde una versión anterior de Access
Para obtener información adicional acerca cómo funciona la Autocorrección de nombres con los objetos importados, consulte en contacto con el siguiente artículo en Microsoft Knowledge Base:
231676ACC2000: No reparar la Autocorrección de nombres importados objetos

Propiedades

Id. de artículo: 231634 - Última revisión: miércoles, 12 de febrero de 2014 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Access 2000 Standard Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kbbug kbpending KB231634 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 231634

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com