Numéro d'article: 232143 - Dernière mise à jour: mardi 27 février 2007 - Version: 4.4

Divers messages d'erreur crée et modifie les fichiers et les clés de Registre du fichier MSI

A noterCet article s'applique à un système d'exploitation différent de celui que vous utilisez. Le contenu de l'article qui ne vous concerne peut-être pas est désactivé.
Avertissement
Cet article s'applique à Windows 2000. Prise en charge pour Windows 2000 s'achève le 13 juillet, 2010. Le Windows 2000 End-of-Support Solution Center (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fwin2000) est un point de départ pour la planification de votre stratégie de migration à partir de Windows 2000. Pour plus d'informations, consultez la Microsoft Support Lifecycle Policy (http://support.microsoft.com/lifecycle/) .
Agrandir tout | Réduire tout

Symptômes

Lorsque vous êtes connecté comme utilisateur standard et que vous exécutez un package Microsoft Installer (MSI), messages d'erreur semblables aux messages suivants peut s'afficher au cours de la phase d'installation :
Erreur 1913, Impossible de mettre à jour le fichier... Vérifiez que le fichier existe et que vous pouvez y accéder.
- ou -
1321 Le programme d'installation ne dispose pas des privilèges suffisants pour modifier ce fichier : filename
- ou -
1401 N'a pas pu créer la clé : registry key
Autres messages d'erreur peuvent se produire, selon si la modification a été créée dans le Registre ou le système de fichiers, mais le message d'erreur signale généralement un manque de privilèges de la part de l'utilisateur ou le service pour effectuer une action relatifs à l'installation du logiciel.

Lorsque vous essayez d'installer Microsoft Office XP Service Pack 3 (SP-3), vous pouvez recevoir le message d'erreur suivant, où path\filename indiquer la lettre du lecteur de CD-ROM et le chemin d'accès d'un fichier qui se trouve sur le Office CD :
Le programme d'installation ne dispose pas des privilèges suffisants pour modifier ce fichier : path\filename
Par exemple, un message d'erreur est semblable au suivant peut s'afficher :
Erreur 1321 l'installateur ne dispose pas des privilèges suffisants pour modifier ce fichier : e:\pfiles\msoffice\office\excel.exe

Cause

Ce problème se produit car le système s'est vu refuser l'accès au répertoire, fichier, ou clés de Registre nécessaires pour installer le logiciel.

Le message d'erreur Office XP SP3 peut se produire si l'accès au CD-ROM a été refusé pour l'utilisateur connecté localement. Ce problème peut se produire si la stratégie permettre l'accès au CD-ROM à l'utilisateur connecté localement uniquement a été activée ou si la stratégie a été définie dans le Registre. L'utilisateur actuel ne sera pas en mesure d'installer le Service Pack 3 Office XP ou pour mettre à jour à partir du CD-ROM.

Résolution

Pour Windows Installer terminer sa fonction avec des privilèges élevés, le système de fichiers et toutes les clés de Registre doivent autoriser SYSTEM un contrôle total sur ces composants pour permettre des installations à avoir lieu.

Pour résoudre ce problème, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, tapez regedit, puis cliquez sur OK.
  2. Recherchez et cliquez sur la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE/Software/Microsoft/Windows NT/CurrentVersion/Winlogon
  3. Dans le volet droit, cliquez avec le bouton droit sur AllocateCDRoms, puis cliquez sur Modifier.
  4. Dans la zone données de la valeur, tapez 0 (zéro), puis cliquez sur OK.

    Remarque La valeur 1 indique que la restriction est activée pour les installations CD-ROM pour cet utilisateur.
  5. Fermez l'Éditeur du Registre.
  6. Réinstallez le Service Pack 3.

Statut

Ce comportement est voulu par la conception même du produit.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professionnel
Mots-clés : 
kbmt kberrmsg kbprb kbsetup KB232143 KbMtfr
Traduction automatiqueTraduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 232143  (http://support.microsoft.com/kb/232143/en-us/ )
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.