Artigo: 232143 - Última revisão: terça-feira, 27 de Fevereiro de 2007 - Revisão: 4.4

Várias mensagens de erro ao ficheiro MSI cria e modifica ficheiros e chaves de registo

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Importante
Este artigo aplica-se para o Windows 2000. Suporte para o Windows 2000 termina em 13 de Julho de 2010. O Windows 2000 End-of-Support Solution Center (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fwin2000) é um ponto de partida para planear a estratégia de migração a partir do Windows 2000. Para mais informações consulte a Microsoft Support Lifecycle Policy (http://support.microsoft.com/lifecycle/) .
Expandir tudo | Reduzir tudo

Sintomas

Quando tem sessão iniciada como um utilizador padrão e que executa um pacote do Microsoft Installer (MSI), poderá receber mensagens de erro semelhantes às seguintes mensagens durante a fase de instalação:
Erro 1913, não pode actualizar o ficheiro... Verifique se o ficheiro existe e se pode acedê-lo.
- ou -
1321 O instalador não tem privilégios suficientes para modificar este ficheiro: filename
- ou -
1401 Não foi possível criar a chave: registry key
Outras mensagens de erro podem ocorrer, dependendo se efectuou a alteração no registo ou o sistema de ficheiros, mas a mensagem de erro normalmente comunica a falta de privilégios por parte do utilizador ou serviço para executar uma acção relacionado com a instalação do software de.

Quando tentar instalar o Microsoft Office XP Service Pack 3 (SP-3), poderá receber a seguinte mensagem de erro, onde path\filename indicar a letra da unidade de CD-ROM e o caminho de um ficheiro localizado no CD do Office:
O instalador não tem privilégios suficientes para modificar este ficheiro: path\filename
Por exemplo, poderá receber uma mensagem de erro semelhante à seguinte:
Erro 1321 O Installer não tem privilégios suficientes para modificar este ficheiro: e:\pfiles\msoffice\office\excel.exe

Causa

Este comportamento ocorre porque o sistema foi negado o acesso ao directório, ficheiro ou chaves de registo necessárias para instalar o software.

A mensagem de erro do Office XP SP3 pode ocorrer se foi negado o acesso para o CD-ROM para o utilizador com sessão iniciada localmente. Este comportamento pode ocorrer se a política de acesso de restringir CD -ROM para o utilizador com sessão iniciada localmente apenas tiver sido activada ou se a política tiver sido definida no registo. O utilizador actual não será possível para instalar o Office XP SP3 ou para actualizar a partir do CD-ROM.

Resolução

De forma a Windows Installer para concluir a respectiva função com privilégios elevados, o sistema de ficheiros e todas as chaves de registo tem de permitir SYSTEM controlo total sobre estes componentes para permitir instalações seja efectuada.

Para resolver este comportamento, siga estes passos:
  1. Clique em Iniciar, clique em Executar, escreva regedit e, em seguida, clique em OK.
  2. Localize e, em seguida, clique na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE/software/Microsoft/Windows NT/CurrentVersion/Winlogon
  3. No painel da direita, clique com o botão direito do rato AllocateCDRoms e, em seguida, clique em Modificar.
  4. Na caixa dados do valor, escreva 0 (zero) e, em seguida, clique em OK.

    Nota O valor 1 indica que a restrição é activada para instalações de CD-ROM para este utilizador.
  5. Feche Editor de registo.
  6. Reinstale o Office XP SP-3.

Ponto Da Situação

Este comportamento ocorre por predefinição.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Palavras-chave: 
kbmt kberrmsg kbprb kbsetup KB232143 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 232143  (http://support.microsoft.com/kb/232143/en-us/ )