FIX: Wiederholte Be- und Entladen von Mtxdm.dll Ursachen 1 MB virtueller Speicherverlust

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Artikel-ID: 232351
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Problembeschreibung

Beim Laden und Entladen von Mtxdm.dll innerhalb einer Schleife, wird ein 1-MB-Leck im virtuellen Speicher mit jeder Iteration der Schleife angezeigt.

Dies ist die wahrscheinlichste Ursache in Anwendungen, die ein ODBC-Verbindungspooling verwenden und sorgen dafür, dass wiederholte Verbindungen und Verbindungstrennungen aus der Back-End-Datenbank oder ODBC-Anwendungen, die viele Verbindungen und getrennte Verbindungen zu einer Oracle-Backend verwenden.

Ursache

Das Leck im virtuellen Speicher wird durch einen Aufruf von TerminateThread() in Mtxdm.dll verursacht.

Wenn Verbindungspooling in einer ODBC­Anwendung verwendet wird, wird der Spender-Manager (Mtxdm.dll) geladen, um den Verbindungspool verwalten, die von einem Arbeitsthread verarbeitet wird, die innerhalb der Mtxdm.dll gestartet wird.

Wenn die Anwendung beendet wird, ist der Worker-Thread durch einen Aufruf von TerminateThread(), getötet, die nicht bereinigen und 1 MB des Arbeitsspeichers für den Worker-Thread-Stack frei.

Dieses Verhalten kann eingesehen werden beim wiederholten Verbindungen und Trennungen an einen Oracle-Datenbankserver herstellen, da der Microsoft Oracle ODBC-Treiber, Mtxdm.dll lädt, ob die Verbindungs-pooling oder nicht verwendet wird.

Lösung

Um dieses Problem zu beheben, beziehen Sie das neueste Servicepack für Windows NT 4.0 oder das einzelne Softwareupdate. Informationen zum Beziehen des neuesten Servicepacks finden Sie in:
Informationen zum Beziehen des einzelnen Softwareupdates wenden Sie sich an Microsoft Product Support Services. Eine vollständige Liste von Microsoft Product Support Services Telefonnummern und Informationen über Supportkosten gehen Sie bitte an folgende Adresse im World Wide Web:
http://support.Microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Windows NT Server oder Workstation 4.0

Um dieses Problem zu beheben, beziehen Sie das neueste Servicepack für Windows NT 4.0 oder das einzelne Softwareupdate. Informationen zum Beziehen des neuesten Servicepacks finden Sie in:
  • Windows Service Pack Center-oder-

  • 152734So erhalten Sie das neueste Windows Nt 4.0 Servicepack
Informationen zum Beziehen des einzelnen Softwareupdates wenden Sie sich an Microsoft Product Support Services. Eine vollständige Liste von Microsoft Product Support Services Telefonnummern und Informationen über Supportkosten gehen Sie bitte an folgende Adresse im World Wide Web:
http://support.Microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Windows NT Server 4.0, Terminal Serveredition

Um dieses Problem zu beheben, beziehen Sie das neueste Servicepack für Windows NT Server 4.0, Terminal Server Edition. Weitere Informationen finden Sie in folgendem Artikel in der Microsoft Knowledge Base:
152734 So erhalten Sie das neueste Windows NT 4.0 Servicepack

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten, die zu Beginn dieses Artikels aufgeführt sind. Dieses Problem wurde erstmals in Windows NT Server Version 4.0, Terminal Server Edition Service Pack 6 behoben.

WEITERE INFORMATIONEN

Manuelle Installation von Hotfix 051099a

Hinweis: Um diesen Hotfix zu erhalten, müssen Sie Microsoft Product Support Services kontaktieren. Bitte finden Sie unter den Abschnitt "Lösung" dieses Artikels Weitere Informationen.
  1. Schließen Sie oder beenden Sie alle Anwendungen oder Dienste, die Mtxdm.dll verwenden. Dies kann die Internet Information Server (IIS), Microsoft Transaction Server (MTS), Microsoft Distributed Transaction Coordinator (DTC) und alle ADO oder ODBC-Anwendungen enthalten.
  2. Laden Sie den Hotfix (051099a.exe) in ein temporäres Verzeichnis, und führen sie die folgenden Dateien zu extrahieren:
    • Mmtxdm.dll
    • Readme.txt
  3. Suchen Sie, und benennen Sie die aktuelle Version des Mtxdm.dll, die im Ordner "\Winnt\System32" für Windows NT-Computer und im Ordner "\Windows\System" für Windows 9 X-Computern sein müssen.
  4. Kopieren Sie die Hotfixversion der Mtxdm.dll im selben Verzeichnis, und starten Sie Ihre Dienste und Anwendungen neu.

Schritte zum Reproduzieren des Verhaltens

Erstellen Sie eine C/C++-Konsolenanwendung mit dem folgenden Code. Führen Sie diese Anwendung beim Verwenden des Systemmonitors zum Virtual Bytes für die Anwendung anzuzeigen.

Hinweis: Dieses Codebeispiel verwendet eine ODBC-Datenquelle, die mit einem Oracle-Backend verbunden, da der Microsoft Oracle ODBC-Treiber, Mtxdm.dll lädt und mehr leicht veranschaulicht das Problem.
   #include        <windows.h>
   #include        <stdio.h>
   #include        <sql.h>
   #include        <sqlext.h>
   #include        <assert.h>

   #define CK_RT(x) if( x != SQL_SUCCESS && x != SQL_SUCCESS_WITH_INFO)    assert(0)

   void main(){
       HENV        henv;
       HDBC        hdbc;
       RETCODE     rc = SQL_SUCCESS;
       char        *dsnStr="DSN=OracleServer;UID=scott;pwd=tiger;";
       short       rtnLen = 0;
       UCHAR       rtnDSN[999] = "";
       int         i,x;


       for (i=0; i < 100; i++)
   	{
               rc = SQLAllocEnv(&henv);
               CK_RT(rc);
               rc = SQLAllocConnect(henv, &hdbc);
               CK_RT(rc);
               rc = SQLDriverConnect(hdbc,
                         NULL,
                         (unsigned char *)dsnStr,
                         strlen(dsnStr),
                         rtnDSN,
                         255,
                         &rtnLen,
                         SQL_DRIVER_NOPROMPT);

               CK_RT(rc);
               SQLDisconnect(hdbc);
               SQLFreeConnect(hdbc);
               SQLFreeEnv(henv);
	   }
   }
				

Eigenschaften

Artikel-ID: 232351 - Geändert am: Mittwoch, 13. Juni 2012 - Version: 3.0
Keywords: 
kbqfe kbhotfixserver kbbug kbfix kbmdac210fix kbmts200fix kbsdkodbc351fix kbvirtualmem kbmt KB232351 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 232351
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