REVISIÓN: Problema de notificación del registro DTC deja transacciones incompletas

Seleccione idioma Seleccione idioma
Id. de artículo: 232533 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando se utiliza Microsoft SQL Server, Microsoft Transaction Server o el Coordinador de transacciones distribuidas (DTC) directamente, las transacciones distribuidas a veces no completan sin motivo aparente.

Dado que la transacción deja de responder, no recibirá un error ni se registra un error en cualquier parte. Sin embargo, puede utilizar la ficha de transacciones de MS DTC Admin Console para ver las transacciones de que "no va a mover," en el estado "sólo falló al notificar" o en el estado "preparación" para un período prolongado de tiempo para obtener una indicación de este problema. MS DTC Admin Console se encuentra en el directorio system32 del equipo:

c:\winnt\system32\dac.exe

Causa

El DTC utiliza un archivo de registro para registrar el estado actual de una transacción. Durante el registro del estado de una transacción, la notificación de registro se pierde y nunca recibió. Esto hace que el Administrador de transacciones esperar indefinidamente y nunca se completa la transacción.

Solución

SQL Server

Para resolver este problema, obtenga el service pack más reciente para Windows NT 4.0 o la actualización de software correspondiente. Para obtener información acerca de cómo obtener el service pack más reciente, visite:
Para obtener información acerca de cómo obtener la actualización de software correspondiente, póngase en contacto con los servicios de soporte técnico de Microsoft. Para obtener una lista completa de los números de teléfono de servicios de soporte técnico de Microsoft e información sobre los costos de soporte, vaya a la siguiente dirección en el World Wide Web:
http://support.Microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Windows NT Server o Workstation 4.0

Para resolver este problema, obtenga el service pack más reciente para Windows NT 4.0 o la actualización de software correspondiente. Para obtener información acerca de cómo obtener el service pack más reciente, visite:
  • Centro de Windows Service Pack - o -

  • 152734Cómo obtener el service pack más reciente para windows nt 4.0
Para obtener información acerca de cómo obtener la actualización de software correspondiente, póngase en contacto con los servicios de soporte técnico de Microsoft. Para obtener una lista completa de los números de teléfono de servicios de soporte técnico de Microsoft e información sobre los costos de soporte, vaya a la siguiente dirección en el World Wide Web:
http://support.Microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Windows NT Server 4.0, Terminal Server Edition

Para resolver este problema, obtenga el service pack más reciente para Windows NT Server 4.0, Terminal Server Edition. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
152734 Cómo obtener el Service Pack más reciente de Windows NT 4.0

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados al principio de este artículo. Este problema se corrigió primero en Windows NT Server versión 4.0, Terminal Server Edition Service Pack 6.

Más información

Instalación de la revisión

Esta revisión sólo debe instalarse en sistemas que ejecuten Microsoft WindowsNT versión 4.0 (se recomienda Service Pack 5 o posterior). No debe instalarse en sistemas que ejecutan Microsoft Windows NT versión 3.51 o Microsoft Windows 2000.

Tenga en cuenta que esta revisión se basa en la versión de lanzamiento de Microsoft DTC incluye Windows NT 4.0 Service Pack 5. Al instalar este hotfix, está actualizando Microsoft DTC en el nivel de Service Pack de Windows NT 4.0 5release además de corregir los problemas que se describen aquí.

Cómo instalar en un sistema sin clústeres

  1. Cree un directorio temporal vacío en el sistema.
  2. Ejecute el archivo ejecutable autoextraíble (I051099c.exe [i386] o A051099c.exe [Alpha]) y escriba el nombre del directorio temporal, cuando se le pida hacerlo. El programa descomprime los siguientes archivos en el directorio temporal:
    Dtcsetup.exe
    Qfe051099c.txt
  3. Detenga el servicio de Microsoft DTC, si se está ejecutando. Detenga todos los servicios que dependen de Microsoft DTC (incluyendo Microsoft Transaction Server, Microsoft SQL Server, Microsoft Message Queue y Microsoft COM Transaction Integrator [COMTI]).
  4. Cierre el Panel de Control, si está abierto.
  5. Ejecute Dtcsetup.exe.
  6. Reinicie el sistema.
  7. Reinicie todos los servicios que dependen de DTC.

Cómo instalar en un clúster con un DTC de Microsoft ya agrupado

  1. Cree un directorio temporal vacío en ambos nodos del clúster.
  2. Ejecute el archivo ejecutable autoextraíble (I051099c.exe [i386] o A051099c.exe [Alpha]) en ambos nodos del clúster y escriba el nombre del directorio temporal, cuando se le pida hacerlo.El programa descomprime los siguientes archivos en el directorio temporal:
    Dtcsetup.exe
    Qfe051099c.txt
  3. Utilice el Administrador de clúster de Microsoft Cluster Server (MSCS) para detener el recurso de clúster de Microsoft DTC, si se está ejecutando. Detenga todos los servicios que dependen de Microsoft DTC (incluyendo Microsoft Transaction Server, Microsoft SQL Server, Microsoft Message Queue y Microsoft COMTI).
  4. Cierre el Panel de Control en todos los sistemas del clúster.
  5. Ejecute Dtcsetup.exe en el nodo que controla el recurso de clúster Microsoft DTC. Cuando se le pida que instale Microsoft DTC en los demás nodos del clúster, ejecute Dtcsetup.exe en estos nodos.
  6. Reinicie todos los sistemas.
  7. Reinicie todos los servicios que dependen de Microsoft DTC.

Cómo instalar en un clúster con un DTC de Microsoft no agrupado

  1. Cree un directorio temporal vacío en ambos nodos del clúster.
  2. Ejecute el archivo ejecutable autoextraíble (I051099c.exe [i386] o A051099c.exe [alpha]) en ambos nodos del clúster y escriba el nombre del directorio temporal, cuando se le pida hacerlo.El programa descomprime los siguientes archivos en el directorio temporal:
    Dtcsetup.exe
    Qfe051099c.txt
  3. Detenga el servicio DTC de Microsoft en todos los sistemas del clúster. Detenga todos los servicios que dependen de Microsoft DTC (incluyendo Microsoft Transaction Server, Microsoft SQL Server, Microsoft Message Queue y Microsoft COMTI).
  4. Cierre el Panel de Control en todos los sistemas del clúster.
  5. Cuando se instala esta versión en un sistema de clúster, el programa de instalación instala automáticamente una versión agrupada de Microsoft DTC. La versión agrupada de Microsoft DTC requiere un grupo de recursos MSCS que contenga un recurso nombre de red y un recurso de disco compartido. Antes de instalar esta versión, asegúrese de que existe al menos un tal grupo de recursos MSCS. Dtcsetup.exe asignará Microsoft DTC al primer grupo de recursos MSCS que busca que contiene un recurso nombre de red y un recurso de disco compartido. Después de asegurarse de el recurso necesario existe grupo, ejecute Dtcsetup.exe en el nodo que controla ese grupo de recursos.
  6. Cuando se le pida que instale Microsoft DTC en los demás nodos del clúster, ejecute Dtcsetup.exe en estos nodos.
  7. Reiniciar todos los equipos.
  8. Reinicie todos los servicios que dependen de Microsoft DTC.

Propiedades

Id. de artículo: 232533 - Última revisión: lunes, 04 de noviembre de 2013 - Versión: 5.0
La información de este artículo se refiere a:
  • Microsoft Transaction Services 2.0
Palabras clave: 
kbnosurvey kbarchive kbqfe kbhotfixserver kbbug kbdtc kbfix kbmt KB232533 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 232533

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com