文書番号: 2342822 - 最終更新日: 2010年8月16日 - リビジョン: 1.2

Outlook Express 6 でフォルダーの検索をして検索結果のメッセージを開くとエラー メッセージが表示されメッセージが開けない

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。
すべて展開する | すべて折りたたむ

現象

Outlook Express 6 で、多数のメッセージ アイテム、およびメッセージに添付されているファイルのサイズが大きいメッセージ アイテムなどデータ量が多いフォルダー (フォルダー内のメッセージのサイズの合計が 700M 程度) の検索を実行し、検索結果からメッセージを開こうとすると、以下のようなエラー メッセージが表示され、メッセージが開けないことがあります。

メッセージを表示できませんでした : このメッセージを表示中に、予期しないエラーが発生しました。メモリ不足か、空き容量が足りない可能性があります。問題を解決してからやり直してください。

なお、この現象は物理メモリの空き容量やディスクの空き容量とは関係無く発生します。


原因

この現象は、メッセージ データを保存する DBX ファイルのサイズが大きすぎるために発生します。 なお、現象は仮想メモリの使用状況によって発生するかどうかが決まるため、現象が発生する DBX ファイルのサイズは環境に依存します。

Outlook Express 6 では、メッセージの検索や検索結果からメッセージを参照する際に、連続したメモリ領域を確保する必要があります。 しかし、多数のメッセージ アイテムや、添付されたファイル サイズが大きいメッセージ アイテムを含むフォルダーで検索を実行した場合、メモリ領域が断片化され、大きな連続したメモリ領域の確保がより難しくなり、メモリ領域の確保に失敗するために、この現象が発生します。

回避策

この現象を回避するには、以下の手順で検索するフォルダーのメッセージを減らし、フォルダーの最適化を行って、DBX ファイルのサイズを減らしてください。

注 : 物理メモリを増設したり、ディスク容量を増やしてもこの現象は回避されません。
  1. サイズが大きいフォルダーのメッセージを別のフォルダーに移動または削除して、メッセージの数を減らします。
  2. Outlook Express 6 の 最適化したいフォルダーを選択します。
  3. [ファイル] メニューをクリックし、[フォルダ] をポイントして、[最適化] をクリックします。
  4. フォルダーの最適化が実行されます。
  5. 現象が発生しなくなるまで、手順 1 から?手順 4?を繰り返します。

この資料は以下の製品について記述したものです。
  • Microsoft Outlook Express 6.0
キーワード:?
kbharmony kbexpertiseinter kbtshoot kbprb kberrmsg KB2342822
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"