Solicitud de bloqueo de volumen no libera volumen después de la operación de archivo

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Síntomas

Cuando ejecuta un programa que utiliza incorrectamente una llamada de función de bloqueo de volumen NTFS en un equipo que ejecuta Windows NT 4.0, el bloqueo del volumen no puede quitarse después de que el programa ha terminado de ejecutarse.

Causa

La función DeviceIoControl () puede utilizarse para bloquear el volumen especificando FSCTL_LOCK_VOLUME como código de control de E/s. Esta función puede no funcionar correctamente si se llama después de realizar las operaciones de archivo siguientes:
  • Abra el archivo de destino y realizar algunas operaciones de E/s para ese archivo. A continuación, cierre el archivo.
  • Tan pronto como cerrar el archivo de destino, cambiar el nombre otro archivo para el archivo de destino mediante MoveFileEx().
Herramientas afectadas por este problema requieren acceso exclusivo al volumen de disco. Estos programas pueden mostrar un mensaje de error como si otro proceso aún tuviera acceso del volumen. Por ejemplo, si ejecuta el CHKDSK -F puede aparecer el comando en un volumen de disco que se produzca este problema, el mensaje de error siguiente:
El tipo de archivo es NTFS.
No se puede bloquear la unidad actual.
CHKDSK no se puede ejecutar porque el volumen está en uso por otro proceso. ¿Desea programar este volumen para que sea comprobado la próxima vez que se reinicie el sistema?
El Administrador de discos también puede verse afectado también.

No se eliminan las referencias en el objeto de archivo cerrado si el archivo se especificó como el nuevo archivo para la función MoveFileEx() antes de que finalice el proceso de escritura de caché de archivo. Otras operaciones de archivo de un volumen funcionan correctamente. Se trata de un problema específico de NTFS. Los volúmenes FAT no se ven afectados por este problema.

Solución

Windows NT Server o Workstation 4.0

Para resolver este problema, obtenga el service pack más reciente para Windows NT 4.0 o la actualización de software individuales. Para obtener información acerca de cómo obtener el service pack más reciente, visite:
  • 152734Cómo obtener el service pack más reciente de windows nt 4.0
Para obtener información acerca de cómo obtener la actualización de software individuales, póngase en contacto con servicios de soporte técnico de Microsoft. Para obtener una lista completa de los números de teléfono de servicios de soporte técnico de Microsoft e información sobre los costos de soporte técnico, vaya a la siguiente dirección en el World Wide Web:
http://support.Microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Windows NT Server 4.0, Terminal Server Edition

Para resolver este problema, obtenga el service pack más reciente para Windows NT Server 4.0, Terminal Server Edition. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en el Microsoft Knowledge Base:
152734 Cómo obtener el Service Pack más reciente de Windows NT 4.0

Solución

Puede ejecutar Clearmem.exe para este problema eliminar. La utilidad vacía la sección utilizada como caché de archivos, por lo tanto el objeto de archivo en cuestión se eliminan las referencias mediante la ejecución se. Esta herramienta se incluye en el kit de recursos de Microsoft Windows NT 4.0.

Estado

Microsoft ha confirmado que se trata de un problema en Windows NT 4.0 y Windows NT Server 4.0, Terminal Server Edition. Este problema se corrigió por primera vez en Windows NT Server versión 4.0, Terminal Server Edition Service Pack 6.

Propiedades

Id. de artículo: 234339 - Última revisión: miércoles, 13 de junio de 2012 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Palabras clave: 
kbhotfixserver kbqfe kbbug kbfix kbmt KB234339 KbMtes
Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 234339

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