Solicitação de bloqueio de volume não libera o Volume após a operação de arquivo

Traduções de Artigos Traduções de Artigos
Artigo: 234339 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando você executa um programa que usa incorretamente uma chamada de função de bloqueio de volume NTFS em um computador executando o Windows NT 4.0, o bloqueio de volume não pode ser removido após a conclusão do programa em execução.

Causa

A função DeviceIoControl() pode ser usada para bloquear o volume, especificando FSCTL_LOCK_VOLUME como o código de controle de e/S. Esta função pode não funcionar corretamente se for chamado depois de executar as seguintes operações de arquivo:
  • Abra o arquivo de destino e fazer algumas e/S de arquivo. Feche o arquivo.
  • Assim que você fechar o arquivo de destino, renomear outro arquivo para o arquivo de destino usando MoveFileEx ().
Utilitário de programas afetados com esse problema requerem acesso exclusivo ao volume do disco. Esses programas podem relatar uma mensagem de erro como se outro processo ainda está acessando o volume. Por exemplo, se você executar o CHKDSK -F comando contra um volume de disco com esse problema, a seguinte mensagem de erro pode ser exibido:
Tipo de arquivo é NTFS.
Não é possível bloquear a unidade atual.
Não é possível executar o CHKDSK porque o volume está em uso por outro processo. Você gostaria de agendar este volume para ser verificado da próxima vez que o sistema for reiniciado?
Administrador de discos também pode ser afetado também.

O objeto de arquivo fechado não referência cancelado se o arquivo fechado foi especificado como o novo arquivo para a função MoveFileEx () antes de concluir o processo de gravação de cache de arquivo. Outras operações de arquivo diferente de bloqueio de um volume funcionam bem. Este é um problema específico de NTFS. Volumes FAT não são afetados por esse problema.

Resolução

Windows NT Server ou Workstation 4.0

Para resolver esse problema, obtenha o service pack mais recente para o Windows NT 4.0 ou a atualização de software individual. Para obter informações sobre como obter o service pack mais recente, vá para:
  • 152734como obter o service pack mais recente do windows nt 4.0
Para obter informações sobre como obter a atualização de software individual, contate o Atendimento Microsoft. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e informações sobre os custos de suporte, vá para o seguinte endereço na World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Windows NT Server 4.0, Terminal Server Edition

Para resolver esse problema, obtenha o service pack mais recente para o Windows NT Server 4.0, Terminal Server Edition. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
152734 Como obter o Service Pack mais recente do Windows NT 4.0

Como contornar

Você pode executar Clearmem.exe para resolver esse problema. O utilitário Clearmem libera a seção usada como cache de arquivos, assim, o objeto de arquivo em questão é sua referência cancelado executando Clearmem. Essa ferramenta está incluída no Microsoft Windows NT 4.0 resource kit.

Ponto Da Situação

A Microsoft confirmou que este é um problema no 4.0 Windows NT e Windows NT Server 4.0, Terminal Server Edition. Esse problema foi corrigido primeiro no Windows NT Server versão 4.0, Terminal Server Edition Service Pack 6.

Propriedades

Artigo: 234339 - Última revisão: 13 de junho de 2012 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Palavras-chave: 
kbhotfixserver kbqfe kbbug kbfix kbmt KB234339 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 234339

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com