New Cryptographic APIs Need Backwards Compatibility

Article translations Article translations
Article ID: 234538 - View products that this article applies to.
This article was previously published under Q234538
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

Symptoms

Calls to the WINTRUST APIs may not work if an older encryption software development kit (SDK) was used to create these calls. These calls usually do not work because of differences in supported structure sizes between the two versions.

Cause

This problem occurs because the encryption support file (Softpub.dll) that is included in Windows NT 4.0 Service Pack 4 is not backwards compatible with the encryption APIs with regard to structure size.

Resolution

To resolve this problem, obtain the latest service pack for Windows NT 4.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack
The latest service pack is also available at the following Internet location:

Status

Microsoft has confirmed that this is a problem in Windows NT 4.0. This problem was first corrected in Windows NT 4.0 Service Pack 5.

Properties

Article ID: 234538 - Last Review: November 2, 2013 - Revision: 3.0
Applies to
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
Keywords: 
kbnosurvey kbarchive kbbug kbfix kbqfe KB234538

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com