STOP 0xC000021A in CSRSS After Attempting to Free an Already Freed Screen Buffer

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Article ID: 234658 - View products that this article applies to.
This article was previously published under Q234658
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SYMPTOMS

When you run a program as a service that constantly creates and closes consoles, the following blue-screen error message may be displayed when you log off the computer:
STOP: c000021a {Fatal System Error}
The Windows SubSystem system process terminated unexpectedly
with a status of 0xc0000005 (0x77f7d40f 0x187fd70).
The system has been shut down.
The parameters for the status 0xC0000005 can vary.

CAUSE

This problem occurs because a screen buffer owned by CSRSS is freed by a process. During the freeing process, the screen buffer's reference count is incremented. When the screen buffer's reference count decrements to 0, an attempt is made to free the screen buffer. Because the screen buffer has already been released (freed), this causes an access violation, which leads to the Stop 0xC00021A.

RESOLUTION

Windows NT Server or Workstation 4.0

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
  • Windows Service Pack Center -or-

  • 152734how to obtain the latest windows nt 4.0 service pack
For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Windows NT Server 4.0, Terminal Server Edition

To resolve this problem, obtain the latest service pack for Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition.

This problem was first corrected in Windows NT Server 4.0 Service Pack 6 and Windows NT Server 4.0, Terminal Server Edition Service Pack 6.

WORKAROUND

To work around this problem, lock the workstation or server instead of logging off. However, this may not be a practical workaround in certain instances.

Properties

Article ID: 234658 - Last Review: June 11, 2012 - Revision: 4.0
APPLIES TO
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Keywords: 
kbhotfixserver kbqfe kbbug kbfix KB234658

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