STOP 0xC000021A no CSRSS após tentar liberar um Buffer de tela já liberada

Traduções de Artigos Traduções de Artigos
Artigo: 234658 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando você executa um programa como um serviço que cria e fecha consoles constantemente, a seguinte mensagem de erro de tela azul pode ser exibida quando você fizer logoff do computador:
STOP: c000021a {Erro Fatal do sistema}
O processo de sistema de subsistema do Windows terminou inesperadamente
com um status de 0xc0000005 (0x77f7d40f 0x187fd70).
O sistema foi desligado.
Os parâmetros para o status de 0xC0000005 podem variar.

Causa

Esse problema ocorre porque um buffer de tela pertencente CSRSS é liberado por um processo. Durante o processo de liberar a contagem de referência do buffer de tela é incrementada. Quando diminui de contagem de referência do buffer de tela para 0, uma tentativa é feita para liberar o buffer de tela. Porque o buffer de tela já foi liberado (liberados), isso causa uma violação de acesso que leva para a parada de 0xC00021A.

Resolução

Windows NT Server ou Workstation 4.0

Para resolver esse problema, obtenha o service pack mais recente para o Windows NT 4.0 ou a atualização de software individual. Para obter informações sobre como obter o service pack mais recente, vá para:
  • Windows Service Pack Center- ou -

  • 152734como obter o service pack mais recente do windows nt 4.0
Para obter informações sobre como obter a atualização de software individual, contate o Atendimento Microsoft. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e informações sobre os custos de suporte, vá para o seguinte endereço na World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Windows NT Server 4.0, Terminal Server Edition

Para resolver esse problema, obtenha o service pack mais recente para o Windows NT Server 4.0, Terminal Server Edition. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
152734 Como obter o Service Pack mais recente do Windows NT 4.0

Ponto Da Situação

A Microsoft confirmou que este é um problema no 4.0 Windows NT e Windows NT Server 4.0, Terminal Server Edition.

Esse problema foi corrigido primeiro no Windows NT Server 4.0 Service Pack 6 e Windows NT Server 4.0, Terminal Server Edition Service Pack 6.

Como contornar

Para contornar esse problema, bloquear estação de trabalho ou servidor em vez de fazer logoff. No entanto, isso não pode ser uma solução prática em determinadas instâncias.

Propriedades

Artigo: 234658 - Última revisão: 13 de junho de 2012 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Palavras-chave: 
kbhotfixserver kbqfe kbbug kbfix kbmt KB234658 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 234658

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com